problem mit httpd.conf

Alles, was den Apache betrifft, kann hier besprochen werden.

problem mit httpd.conf

Postby darklord » 02. October 2006 20:56

Hallo,
also ich habe ein kleines problem und zwar das ich immer wenn ich apahe starte bekomme ich folgende fehlermeldung:

(OS 10049)Die angeforderte Adresse ist in diesem Kontext ung³ltig. : make_sock:
could not bind to address 12.34.56.78:80
no listening sockets available, shutting down
Unable to open logs


ich hoffe jemand kann mir helfen, danke im voraus
darklord
 
Posts: 23
Joined: 29. September 2006 19:53

Postby Termatek » 03. October 2006 18:40

klar ;)

in de httpd.conf steht drin, dass der server auf dem port "80" bei der eigenen ip-adresse "12.34.56.78" lauschen soll.

aber diese ip-adresse hast du garnicht, also kann er dort auch keine anschlüsse öffnen um dort auf eventuelle anfragen zu warten ;)

such mal in der httpd.conf den eintrag "Listen"
und dort trägst du dann die adresse ein, die du hast.
Termatek
 
Posts: 20
Joined: 21. August 2006 13:12

Postby darklord » 08. October 2006 19:28

ja aber auch wenn ich meine ip adresse da rein schreibe bekomme ich folgende fehlermeldung:


Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
(OS 10048)Normalerweise darf jede Socketadresse (Protokoll, Netzwerkadresse oder
Anschluss) nur jeweils einmal verwendet werden. : make_sock: could not bind to
address 0.0.0.0:443
no listening sockets available, shutting down
Unable to open logs

Apache konnte nicht gestartet werden
Apache could not be started
Drücken Sie eine beliebige Taste . . .
darklord
 
Posts: 23
Joined: 29. September 2006 19:53

Postby darklord » 08. October 2006 20:58

so ich habe nun das problem gelöst aber ich kann trozdem localhost nicht aufrufen?????
darklord
 
Posts: 23
Joined: 29. September 2006 19:53

Postby deepsurfer » 09. October 2006 12:07

in der HTTPD.CONF den Listenbefehl ändern auf:
LISTEN 80
Somit reagiert der Apache auch auf wechselnde IPs und sollte damit auch auf "localhost" hören können.

Desweiteren besagt die Fehlermeldung das ein Programm den Port 443 blockiert, dies ist der SSL Port und dürfte durch den laufenden IIS deines Windowssystems blockiert werden.
Folglich den IIS abschalten.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby darklord » 09. October 2006 19:02

a danke jetzt leuft alles einwandfrei
darklord
 
Posts: 23
Joined: 29. September 2006 19:53


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests