DocumentRoot bzw. UserDir: Kriege es einfach nicht hin!

Alles, was den Apache betrifft, kann hier besprochen werden.

DocumentRoot bzw. UserDir: Kriege es einfach nicht hin!

Postby Smine » 30. September 2006 16:29

In Stichworten:

- ich versuche, einen Debian-Server für PHP-Entwicklung einzurichten
- Debian ist drauf und läuft, Samba auch und ist nach zwei Tagen Verzweiflung endlich richtig konfiguriert
- mein Web-Arbeitsverzeichnis habe ich unter /www/vzname/htdocs eingerichtet und kann vom XP-Rechner darauf zugreifen
- Apache 2 läuft (es erscheint die "Es klappt..."-Seite aus dem Verzeichnis /var/www/apache2)

So weit, so gut bzw. schlecht. Trotzdem ich die letzten beiden Tage hunderte von Dokumenten zu diesem Thema gewälzt habe, gelingt es mir nicht, dem Apache beizubringen, "/www/vzname/htdocs" als Standardarbeitsverzeichnis zu nehmen, er bezieht seine Daten weiterhin aus dem Verzeichnis "/var/www/apache2".

Versuche, mit "DocumentRoot" das gewünschte Verzeichnis einzustellen, werden aber ignoriert (außer sie enthalten einen Syntaxfehler - der wird dann gemeldet und der Indianer läuft nicht).

Auch der Versuch, die komplette htppd.conf (bzw. bei mir heisst sie ja apache2.conf) zu löschen und dann mit den Minimalzeilen User, Listen und DocumentRoot zu füllen, funktioniert nicht (er endet in der winsock-Fehlermeldung Nr. 98).

Die Standardkonfiguration verwendet das Modul mod_userdir und lädt eine "userdir.conf" nach, die wie folgt aussieht:

Code: Select all
<IfModule mod_userdir.c>
                      UserDir public_html
                      UserDir disabled root

                      <Directory /home/*/public_html>
                                AllowOverride FileInfo AuthConfig Limit
                                Options MultiViews Indexes SymLinksIfOwnerMatch
                                IncludesNoExec
                       </Directory>
</IfModule>


Auch hier habe ich schon versucht, mein Verzeichnis einzutragen, aber auch das hat nichts gebracht.

Auch wird nirgendwo in diesen conf-Dateien das Standardverzeichnis "/var/www/apache2" erwähnt, so daß ich irgendeinen Verzeichniseintrag korrigieren könnte, um mein Verzeichnis zu aktivieren.

Hat jemand eine Idee? Bin (schon wieder mal...) am verzweifeln.

Vielen Dank für Eure Bemühungen.

Gruß Smine
Smine
 
Posts: 5
Joined: 30. September 2006 13:44

Gelöst!

Postby Smine » 30. September 2006 20:35

Das Problem ist gelöst...im Debianforum habe ich den entscheidenen Tip bekommen: Das DocumentRoot war in einer includierten Datei versteckt, die ich bisher noch nicht gefunden hatte.

Danke an alle, die sich trotzdem die Mühe gemacht haben zu lesen!
Smine
 
Posts: 5
Joined: 30. September 2006 13:44


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests