Wordpress-Link führt zu "Page not found"

Alles, was den Apache betrifft, kann hier besprochen werden.

Wordpress-Link führt zu "Page not found"

Postby LordZed » 11. September 2006 14:05

Hi Leute! Ich habe ein kleines Problem und ich weiß nicht genau woran es liegt. Im Wordpress-Forum habe ich das Problem auch schon angesprochen, aber da antwortet mir keiner. Daher dachte ich die Apache-Pro's hier wissen vielleicht woran mein Problem liegt und wie ich es beheben kann.

Kommen wir zum Problem.
Auf meiner Seite http://lordzed.sitl.de sind ganz unten auf der Seite Links die zu älteren Beiträgen führen. Diese Links funktionieren aber nicht und ich weiß nicht wieso. Wenn ich einen Anklicke, dann komme ich immer auf eine "Page not found"-Seite

Die Links sind virtuelle Links. In Wordpress nennt sich das Permalinks. Ich hab gedacht es könnte an der .htaccess liegen, aber dann versteh ich nicht, wieso nur ich das Problem habe, da die .htaccess von Wordpress erstellt wird.

Der Inhalt der .htaccess:
Code: Select all
<IfModule mod_rewrite.c>
   RewriteEngine On
   RewriteBase /
   RewriteCond %{REQUEST_FILENAME} !-f
   RewriteCond %{REQUEST_FILENAME} !-d
   RewriteRule . /index.php [L]
</IfModule>


Ich hoffe ihr könnt mir vielleicht helfen und/oder erklären, was das Problem ist.

Außerdem ist mir aufgefallen, dass die Links immer zu z.B: http://lordzed.sitl.de/page/4/ führen, obwohl der Link http://lordzed.sitl.de/index.php/page/4/ ist.
LordZed
 
Posts: 9
Joined: 10. September 2006 18:07

Postby deepsurfer » 11. September 2006 14:55

http://lordzed.sitl.de/index.php/page/4/ ist


Es müsste nach meinem verständnis heissen:

http://lordzed.sitl.de/index.php?page4

Somit ist das rewrite nach meinen beschränken wissen falsch.

Hattest du denn nach der Installation dieses rewrite geändert ?
Schau nochmal in die Installanleitung des Wordpress rein, ich mein das dort das rewrite beschrieben ist.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby LordZed » 11. September 2006 22:38

In der Anleitung habe ich nicht nachgesehen, aber als ich die Permalink einstellungen geändert habe, da konnte er die .htaccess noch nicht überschreiben und hat mir gesagt ich soll diese Einträge in der .htaccess vornehmen.

Ich gucke jetzt mal in die Anleitung...
LordZed
 
Posts: 9
Joined: 10. September 2006 18:07

Postby LordZed » 12. September 2006 14:23

Ich glaube es liegt daran, dass er mir aus den Links immer das "index.php/" rausstreicht. Wieso weiß ich nicht, aber vielleicht kann mir das einer von euch erklären.

Alle "virtuellen" Links sind in der Form http://lordzed.sitl.de/index.php/... und alle bleiben es auch. Bis auf die page/x/ Seiten. Da nimmt er immer das index.php raus. Kann mir einer sagen, wass ich als einstellen muss, damit er das nichtmehr tut. Habe Confixx-Admin-Zugriff.
LordZed
 
Posts: 9
Joined: 10. September 2006 18:07


Return to Apache

Who is online

Users browsing this forum: No registered users and 2 guests