safe_mode für individuellen VirtualHost

Alles, was den Apache betrifft, kann hier besprochen werden.

safe_mode für individuellen VirtualHost

Postby Martin_B » 02. September 2006 14:18

Hallo und gleich direkt zum Prob:
meine Server-Umgebung:
Strato-HighEnd-Server
Suse 9.3
Apache2
PHP 4.3.10

habe dabei folgende Probs:
1. Ich möchte für individuelle VirtualHosts den safe_mode aktivieren.
2. Und auch das memory_limit individuell anpassen können.

vorhandene Einstellungen:
-------------in der php.ini----------------
safe_mode = On
memory_limit = 16M
register_globals = Off

-------------in der httpd.conf----------------
-----<Global Environment>-----------------
...
<Directory />
Options -Indexes +FollowSymLinks +Includes
AllowOverride All
</Directory>
...
-----<Virtual server configuration>--------
...
#VHOST domainname.de
<VirtualHost *:80>
php_admin_value open_basedir /home/d/domainname.de/public_html/:/usr/local/lib/php:/tmp
DocumentRoot /home/d/domainname.de/public_html/
ServerName www.domainname.de
IndexOptions
DirectoryIndex index.htm index.html index.php index.php3
ServerAlias domainname.de *.domainname.de
CustomLog "|/usr/local/..." combined
SuexecUserGroup *user* *group*
</VirtualHost>
#/VHOST
...

Das ganze wird/wurde automatisch generiert über ServerAdmin24 (ehemals VISAS) und ist hier in der Originalfassung angegeben.
---------------------------------------------------------------------------

Zu Prob 2:
Klar ist mir soweit das ich Prob 2. in einer .htaccess-Datei lösen könnte durch einen Eintrag in Form von
php_value memory_limit 32M
Das klappt allerdings nicht. Wird nicht übernommen.

Noch ein Edit/Hinweis hinterher:
Die Einstellung -DirectoryListing- ist ja standardmäßig ausgeschaltet.
Durch die Angabe
Options +Indexes
in der .htaccess wird diese korrekt aktiviert.


zu Prob 1:
Hab die letzten Tage gegoogelt und auch das Forum durchsucht und auf den ersten Blick gute Lösungen gefunden:
http://community.apachefriends.org/f/viewtopi ... t=safemode
http://www.tanmar.info/content/view/26/52/
http://wiki.pi-noe.ac.at/ag/PHP_und_Sicherheit

Habe auch u.a. folgende Bücher:
Die Apache Server 2 Bibel (mitp)
Apache Webserver 2 (Addison-Wesley)

Allerdings funktioniert keine Lösung erfolgreich! Ich bekomms nicht hin!!
Der letzte Lösungsansatz aus dem Forum hier sah wirklich vielversprechend aus und habe in wie folgt umgesetzt:
...
#VHOST domainname.de
<VirtualHost *:80>
php_admin_value open_basedir /home/d/domainname.de/public_html/:/usr/local/lib/php:/tmp
DocumentRoot /home/d/domainname.de/public_html/
ServerName www.domainname.de
IndexOptions
DirectoryIndex index.htm index.html index.php index.php3
ServerAlias domainname.de *.domainname.de
CustomLog "|/usr/local/..." combined
SuexecUserGroup *user* *group*
# hier eingefügt...
<Directory /home/d/domainname.de/public_html/>
php_admin_flag safe_mode Off
AllowOverride All
Options Indexes FollowSymLinks
Order allow,deny
Allow from all
</Directory>
#
</VirtualHost>
#/VHOST
...

Verblüffend ist:
Bei obiger Aktivierung, sage ich auch <Options Indexes> und DAS funktioniert/wird umgesetzt!

Natürlich wurde jedesmal nach Änderungen der Apache neu gestartet
/etc/init.d/apache restart

Der Erfolg für meine 2 Probs blieb aus. Benötige Hilfe!
Martin_B
 
Posts: 2
Joined: 02. September 2006 13:37

Postby Martin_B » 08. September 2006 10:08

Benötige Hilfe!
Martin_B
 
Posts: 2
Joined: 02. September 2006 13:37


Return to Apache

Who is online

Users browsing this forum: No registered users and 2 guests