andere Verzeichnisse "einbinden"

Alles, was den Apache betrifft, kann hier besprochen werden.

andere Verzeichnisse "einbinden"

Postby Banana » 05. August 2003 14:24

Hi
Wie kann ich mit Webmin andere Verzeichnisse als /opt/lampp/htdocs in Apache "einbinden"?
Ich will noch einige Verzeichnisse aus /home/... zur Verfügung stellen.

Edit:
Ich denk mal, das geht bei "Einen neuen virtuellen Server anlegen".
Aber was muss ich bei Adresse eingeben? Bei mir sagt Webmin immer, das sei keine gültige Adresse.

Ich hoffe, mir kann jemand helfen.
Wer neben dem Wasserloch lebt, träumt nicht von Durst.
Tad Williams, "Otherland - Stadt der goldenen Schatten"

http://www.jutuholzgerlingen.de.vu
http://www.akrobatikteam-niesky.de.vu
User avatar
Banana
 
Posts: 12
Joined: 31. July 2003 13:50
Location: Holzgerlingen

Postby Banana » 11. August 2003 10:45

Kann mir denn niemand helfen?!?
Wer neben dem Wasserloch lebt, träumt nicht von Durst.
Tad Williams, "Otherland - Stadt der goldenen Schatten"

http://www.jutuholzgerlingen.de.vu
http://www.akrobatikteam-niesky.de.vu
User avatar
Banana
 
Posts: 12
Joined: 31. July 2003 13:50
Location: Holzgerlingen

Postby Pc-dummy » 11. August 2003 12:26

Hi

Ich weis nicht wie das mit Webmin geht...

Sag mir zuerst mal genau was du erreichen willst und dann lässt sich das einfach und schnell mit einem Texteditor in der /opt/lampp/etc/httpd.conf erreichen.

MFG
Pc-Dummy
Gentoo/X86_64, AMD Athlon 64 FX-53, 1,5 GB INFINEON Ram, Audigy 2 ZS Platinum Pro, 300 GB Platten, LG-DVD Brenner
Pc-dummy
AF Moderator
 
Posts: 784
Joined: 29. December 2002 01:46
Location: AT-Vorarlberg-Feldkirch

Postby Banana » 11. August 2003 14:11

Ich möchte wenn ich http://192.168.0.1/homepage im Browser aufrufe, die Dateien, die in /home/*benutzername*/homepage drin sind, sehen.
Wer neben dem Wasserloch lebt, träumt nicht von Durst.
Tad Williams, "Otherland - Stadt der goldenen Schatten"

http://www.jutuholzgerlingen.de.vu
http://www.akrobatikteam-niesky.de.vu
User avatar
Banana
 
Posts: 12
Joined: 31. July 2003 13:50
Location: Holzgerlingen

Postby Pc-dummy » 11. August 2003 15:25

Hi

Einfacher Symlink tuts :)

ln -s /home/benuter/hompage /opt/lampp/htdocs/hompage

MFG
Pc-Dummy
Gentoo/X86_64, AMD Athlon 64 FX-53, 1,5 GB INFINEON Ram, Audigy 2 ZS Platinum Pro, 300 GB Platten, LG-DVD Brenner
Pc-dummy
AF Moderator
 
Posts: 784
Joined: 29. December 2002 01:46
Location: AT-Vorarlberg-Feldkirch

Postby Banana » 11. August 2003 16:00

OK, Danke.
Wer neben dem Wasserloch lebt, träumt nicht von Durst.
Tad Williams, "Otherland - Stadt der goldenen Schatten"

http://www.jutuholzgerlingen.de.vu
http://www.akrobatikteam-niesky.de.vu
User avatar
Banana
 
Posts: 12
Joined: 31. July 2003 13:50
Location: Holzgerlingen

Postby Banana » 12. August 2003 10:47

Ich hab die Symlinks gemahch, aber jetzt kommt wenn ich http://192.168.0.1/homepage aufrufen will nur:

Code: Select all
Forbidden
You don't have permission to access /niesky/index.html on this server.


--------------------------------------------------------------------------------

Apache/2.0.47 (Unix) mod_perl/1.99_08 Perl/v5.8.0 mod_ssl/2.0.47 OpenSSL/0.9.7 PHP/4.3.2 DAV/2 Server at 192.168.0.1 Port 80


Was muss ich einstellen, dass es mir erlaubt ist, die Seite zu sehen
Wer neben dem Wasserloch lebt, träumt nicht von Durst.
Tad Williams, "Otherland - Stadt der goldenen Schatten"

http://www.jutuholzgerlingen.de.vu
http://www.akrobatikteam-niesky.de.vu
User avatar
Banana
 
Posts: 12
Joined: 31. July 2003 13:50
Location: Holzgerlingen

Postby phreaks » 12. August 2003 14:58

Sieht so aus, als ob der Apache-User (siehe httpd.conf) keine Rechte auf dieses andere Userverzeichnis hat...Check mal die Direktive User/Group im httpd.conf gegen die Rechte des Userverzeichnisses...

cheers,
phreaks
Have you ever seen http://www.nullteam.de ?
User avatar
phreaks
 
Posts: 25
Joined: 17. June 2003 10:20
Location: Nürnberg

Postby Pc-dummy » 12. August 2003 15:38

Hi

Ja phreaks dürfte recht haben

Der user in der httpd.conf (also der Apache User) ist norm. nobody dem ganzen entgegen kommen kannst du indem du jedes verzeichnis bis dorthin auf 755 stellst und die dateien auf 644 in diesem verzeichnis!

Damit hat dann der Apache das recht diese Dateien zu lesen!

MFG
Pc-Dummy
Gentoo/X86_64, AMD Athlon 64 FX-53, 1,5 GB INFINEON Ram, Audigy 2 ZS Platinum Pro, 300 GB Platten, LG-DVD Brenner
Pc-dummy
AF Moderator
 
Posts: 784
Joined: 29. December 2002 01:46
Location: AT-Vorarlberg-Feldkirch

Postby Banana » 13. August 2003 11:03

Ich hab die Dateien schon mal auf 777 gestellt (da darf doch dann jeder alles mit den Dateien machen, oder nicht?), um zu testen, ob es dann erreichbar ist. Aber auch dort kam der Fehler.
Wer neben dem Wasserloch lebt, träumt nicht von Durst.
Tad Williams, "Otherland - Stadt der goldenen Schatten"

http://www.jutuholzgerlingen.de.vu
http://www.akrobatikteam-niesky.de.vu
User avatar
Banana
 
Posts: 12
Joined: 31. July 2003 13:50
Location: Holzgerlingen

Postby Oswald » 13. August 2003 16:28

Huhu Banana!

Auch das Verzeichnis in dem die Dateien liegen? Mach bitte mal sowas:

chmod a+x /home /home/benutzer /home/benutzer/homepage

"benutzer" ist natürlich an Deine Gegebenheiten anzupassen.

Gruß,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Banana » 14. August 2003 11:10

Danke, es funktioniert.

Zuerst hat das mit chmod funktioniert. Nach einem Neustart des Servers nicht mehr.
Aber ich hab das jetzt anders gelöst:
Ich bin der einzige User, der den LAMPP braucht und so führe ich den Apache jetzt als <mein Benutzername> aus.
So kann ich natürlich auf mein Home-Verzeichnis problemlos zugreifen.
Wer neben dem Wasserloch lebt, träumt nicht von Durst.
Tad Williams, "Otherland - Stadt der goldenen Schatten"

http://www.jutuholzgerlingen.de.vu
http://www.akrobatikteam-niesky.de.vu
User avatar
Banana
 
Posts: 12
Joined: 31. July 2003 13:50
Location: Holzgerlingen

Postby malon3 » 23. November 2005 12:44

So muss den Thread mal aus der Versenkung holen, da ich ein ähnliches Problem habe welches sich aber nicht lösen lässt :(

Also ich will bestimmte Bereiche aus meinem DocumentRoot in mein home Verzeichniss auslagern damit ich Sachen ändern kann ohne root Rechte.

Dazu wollte ich Symlinks nutzen.

Hier meine Globale Verzeichnissrechte aus der httpd.conf:
Code: Select all
<Directory />
    Options None
    AllowOverride None
    <IfModule mod_access.c>
       Order deny,allow
       Deny from all
    </IfModule>
</Directory>


Hier meine Verzeichnissrechte von meinem default vhost:
Code: Select all
DocumentRoot "/var/www/mydomain.org/htdocs"

<Directory "/var/www/mydomain.org/htdocs">
    Options None MultiViews
    AllowOverride None
    Order allow,deny
    Allow from all
</Directory>


Hier ein entsprechender Ordner der Ausgelagert werden soll:
Code: Select all
<Directory /var/www/mydomain.org/htdocs/pub>
    Options +Indexes +FollowSymlinks
    #IndexOptions FancyIndexing
</Directory>


Hier habe ich noch das endsprechende Verzeichniss in dem ausgelagert werden soll Apache bekanntgemacht:
Code: Select all
<Directory /home/malon3/www>
    Order allow,deny
    Allow from all
</Directory>

Reicht es nur www bekanntzumachen, wirkt sich das dann rekursiv auf die unterverzwichnisse aus?

Rechte für /home/malon3/www/... :
Code: Select all
drwxr-xr-x  2 malon3 apache 4096 23. Nov 12:14 priv
drwxr-xr-x  3 malon3 apache 4096 23. Nov 12:14 pub


Leider bekomme ich immer wenn ich einem Symlink folgen will folgende Fehlermeldung:
Code: Select all
Forbidden

You don't have permission to access /pub/fh/portrait on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
Apache/2.0.54 (Gentoo/Linux) Server at mydomain.org Port 80


Bzw. ausm error_log:
Code: Select all
[Wed Nov 23 12:20:21 2005] [error] [client 84.56.234.136] Symbolic link not allowed: /var/www/mydomain.org/htdocs/pub/fh/portrait


Was hab ich da vergessen? Komm einfach nicht dahinter...

gruß
malon3
 
Posts: 2
Joined: 23. November 2005 12:08

Postby malon3 » 29. November 2005 10:43

Ich habs jetzt mal über nen alias versucht, aber ich hab immernoch ein Rechteproblem :(

Code: Select all
Alias /pub/ "/home/malon3/www/pub"

    <Directory "/home/malon3/www">
       Options +Indexes +Multiviews
       AllowOverride None
       Order allow,deny
       Allow from all
    </Directory>


Code: Select all
[Tue Nov 29 10:39:11 2005] [error] [client 84.57.246.223] (13)Permission denied: access to /pub/ denied, referer: http://mydomain.org/


wirklich keiner ne idee?

gruß
malon3
 
Posts: 2
Joined: 23. November 2005 12:08


Return to Apache

Who is online

Users browsing this forum: No registered users and 7 guests