VirtualHost Problem

Alles, was den Apache betrifft, kann hier besprochen werden.

VirtualHost Problem

Postby Micodat » 15. August 2006 15:20

Hi,

System: Apache 2.2.2 unter Win2003-Server
Ports: 8080 (http) und 443 (https)

Ziel: beim Zugriff von extern (Internet, über DynDNS) soll htaccess verwendet werden, beim Zugriff aus dem Intranet nicht.

Dafür habe ich 3 VirtualHost angelegt:
Code: Select all
<VirtualHost *:8080>
    ServerName localhost:8080
    ServerAlias MyServerName:8080

    Alias /aww/ "c:/web/aww/"

    <Directory "c:/web/aww">
        Options Indexes MultiViews
        AllowOverride None
        Order allow,deny
        Allow from all
    </Directory>

</VirtualHost>

<VirtualHost _default_:443>
    ServerName localhost:443
    ServerAlias MyServerName:443

    Alias /aww/ "c:/web/aww/"

    <Directory "c:/web/aww">
        Options Indexes MultiViews
        AllowOverride None
        Order allow,deny
        Allow from all
    </Directory>

</VirtualHost>

<VirtualHost _default_:443>
    ServerName My.DynDNS.Name:443

    Alias /aww/ "c:/web/aww/"

    <Directory "c:/web/aww">
    AuthType Basic
   AuthName "Passwort wird benötigt"
   AuthUserFile "\Programme\xampp\Apache\pwd\.auftrag"
   Require valid-user
   Options Indexes FollowSymLinks MultiViews
   AllowOverride none
   </Directory>

</VirtualHost>


Intern (Intranet) funktioniert gut.

Aber:
auch wenn ich von extern (Internet) mit https://My.DynDNS.Name/aww drauf zugreife, werden die Seiten angezeigt, ohne das die Abfrage auf "valid-user" kommt.

Irgendeine Idee, woran das liegt?

Ciao
Frank
REALITY.SYS is corrupt. Reboot universe? (y/n)
Micodat
 
Posts: 27
Joined: 01. August 2005 10:21

Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests