vhosts, plesk, vhost.conf syntax

Alles, was den Apache betrifft, kann hier besprochen werden.

vhosts, plesk, vhost.conf syntax

Postby osdoka » 29. July 2006 11:14

Hi!
Um meine vhosts einzurichten, erstelle ich, da plesk 8 verwendet wird, in /var/www/vhosts/crojewe.biz/conf ein file "vhost.conf" (s.u.)
Dies wird so nicht angenommen. Beim Ausführen von
/usr/local/psa/admin/bin/websrvmng -a -v
erhalte ich
websrvmng: Service apache2 failed to restart
Wo ist das Problem?
Ist es ein Konflikt, wenn ich
<VirtualHost 213.83.63.159:80>
ServerName crojewe.biz:80
ServerAlias www.crojewe.biz
identisch wie in httpd.include verwende, die ich ja nicht ändern kann, da von plesk überschrieben wird?
Danke und Gruss,
K

---
Code: Select all
# Listen 80
# NameVirtualHost *:80

<VirtualHost 10.10.10.10:80>
        ServerName   crojewe.biz:80
        ServerAlias  www.crojewe.biz
        #ServerAdmin admin@crojewe.biz
        UseCanonicalName Off
        DocumentRoot /var/www/vhosts/crojewe.biz/httpdocs
#        <IfModule mod_rewrite.c>
#           RewriteEngine On
#           RewriteLog "/var/log/apache2/rewrite_log"
#           RewriteRule ^/(.*) \
#           http://localhost:8080/VirtualHostBase/http/%{SERVER_NAME}:80/0crojewe/crojewe/VirtualHostRoot/$1 [L,P]
#       </IfModule>
        CustomLog  /var/www/vhosts/crojewe.biz/statistics/logs/access_log plesklog
        ErrorLog   /var/www/vhosts/crojewe.biz/statistics/logs/error_log
   <IfModule mod_userdir.c>
        UserDir /var/www/vhosts/crojewe.biz/web_users
   </IfModule>
        Alias  /plesk-stat /var/www/vhosts/crojewe.biz/statistics/
        Alias  /webstat /var/www/vhosts/crojewe.biz/statistics/webstat
        Alias  /webstat-ssl /var/www/vhosts/crojewe.biz/statistics/webstat-ssl
        Alias  /ftpstat /var/www/vhosts/crojewe.biz/statistics/ftpstat
        Alias  /anon_ftpstat /var/www/vhosts/crojewe.biz/statistics/anon_ftpstat
        <IfModule mod_ssl.c>
                SSLEngine off
        </IfModule>
        <Directory /var/www/vhosts/crojewe.biz/httpdocs>
        <IfModule sapi_apache2.c>
                php_admin_flag engine off
        </IfModule>
        <IfModule mod_php5.c>
                php_admin_flag engine off
        </IfModule>
        <IfModule mod_python.c>
        <Files ~ (\.py$)>
                SetHandler python-program
                PythonHandler   mod_python.cgihandler
        </Files>
        </IfModule>
                Options -Includes -ExecCGI
        </Directory>
        <Directory /var/www/vhosts/crojewe.biz/web_users>
        <IfModule sapi_apache2.c>
                php_admin_flag engine off
        </IfModule>
        <IfModule mod_php5.c>
                php_admin_flag engine off
        </IfModule>
        </Directory>
        <Directory "/var/www/vhosts/crojewe.biz/statistics">
                AuthType Basic
                AuthName "Domain-Statistiken"
                AuthUserFile /var/www/vhosts/crojewe.biz/pd/d..httpdocs@plesk-stat
                require  valid-user
        </Directory>

</VirtualHost>
osdoka
 
Posts: 2
Joined: 29. July 2006 09:35

Postby osdoka » 31. July 2006 09:20

In vhost.conf darf kein <VirtualHost> -Tag verwendet werden, sondern nur die Zeilen, welche in den jeweiligen <VirtualHost> von "httpd.include" inkludiert werden sollen.
Also
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteLog "/var/log/apache2/rewrite_log"
RewriteRule ^/(.*) \
..... [L,P]
</IfModule>
osdoka
 
Posts: 2
Joined: 29. July 2006 09:35


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests