Problem: MySQL Authentifikation und Apache 2.2

Alles, was den Apache betrifft, kann hier besprochen werden.

Problem: MySQL Authentifikation und Apache 2.2

Postby fredlcore » 15. July 2006 22:24

Hallo Forum,

ich bin neu hier, habe aber die hilfreichen Posts zu anderen Themen gesehen und hoffe, daß Ihr mir auch weiterhelfen könnt...

Ich habe lange Jahre mod_auth_mysql für zugangsbeschränkte Seiten genutzt, zuerst mit Apache 1.3 und seit einiger Zeit auch mit Apache 2.0.
Mit dem Umstieg von SuSE 10.0 auf 10.1 und demzufolge Apache 2.2 klappt aber gar nichts mehr:

SuSE liefert zwar mod_authn_mysql mit, das Modul wird auch geladen, bloß schmeißt der Apache nun immer einen Error 500 und beklagt sich wie folgt:

Code: Select all
[Sat Jul 15 17:20:02 2006] [error] Internal error: pcfg_openfile() called with NULL filename
[Sat Jul 15 17:20:02 2006] [error] [client 84.190.46.89] (9)Bad file descriptor: Could not open password file: (null)


Wenn ich nun ein

Code: Select all
AuthUserFile    /dev/null


angebe, verschwinden zwar die Fehler und es kommt die Eingabemaske, aber kein User wird akzeptiert (wohl, weil in /dev/null keine enthalten sind ;) ).

Ein AuthBasicProvider Statement hilft auch nicht, da "mysql" nicht als Provider erkannt wird.


In meiner Not wollte ich schon auf mod_authn_dbd umsteigen, aber hier scheitert es dann daran, daß "DBDriver mysql" meckert, daß "mysql" auch hier nicht bekannt ist, gleiches auch für pgsql etc.

Hat einer von Euch einen Tipp oder eine Erklärung für dieses seltsame Verhalten? Oder hat SuSE da einfach nur Mist gebaut?
Habe nun schon stundenlang gegoogelt, aber nichts konkretes zu dieser Konstellation gefunden...

Viele Grüße,

Frederik.
fredlcore
 
Posts: 1
Joined: 15. July 2006 22:10

Lösung?

Postby nw » 28. August 2006 12:41

Ich hatte das selbe Problem (unter Apache 2.0.55 lief's und die selbe Config mit Apache 2.2.3 wollte nicht), aber ich glaube, ich habe die Nuss heute vormittag geknackt. Meine .htaccess sieht jetzt so aus und auf einmal geht's:

Code: Select all
AuthName "(name)"
 AuthType Basic
 AuthMySQLHost (sqlserver)
 AuthMySQLDB webauth
 AuthMySQLUser (usr)
 AuthMySQLPassword (pwd)
 AuthMySQLUserTable downloads
 AuthMySQLNameField name
 AuthMySQLPasswordField pass
 AuthMySQLPwEncryption none
 AuthMySQLEnable On
 require valid-user


Der Knackpunkt war das "AuthMySQLPwEncryption none" - vorher stand dort "AuthMySQLCryptedPasswords Off"...

Grund siehe http://modauthmysql.sourceforge.net/CONFIGURE:

The following parameters have been depricated and replaced by the single parameter AuthMySQLPwEncryption:

AuthMySQLCryptedPasswords On | Off
AuthMySQLScrambledPasswords On | Off
AuthMySQLMD5Passwords On | Off
AuthMySQLAESPasswords On | Off
AuthMySQLSHA1Passwords On | Off


Wenn man den Parameter weggelassen hat, ging es ebenfalls nicht - man muss also wohl explizit festlegen in welcher Form die Pwds in der SQL-Tabelle abgelegt sind.

Gruß,
Nic
nw
 
Posts: 1
Joined: 27. August 2006 12:59

Postby tisba » 29. August 2006 16:30

Hallo zusammen...

bei mir geht es leider trotz korrekter verwendung von AuthMySQLPwEncryption nicht... und langsam verzweifel ich daran :-(

Ich verwende Apache 2.2.0 und mySQL 5.0.18...
tisba
 
Posts: 1
Joined: 29. August 2006 16:14

Postby durtro » 07. September 2006 18:00

Gibts was neues? Ich hab hier das gleiche Problem (SLES 10, mod_auth_mysql 3.0.0)

Laut dem Logging von MySQL wird nichtmal der Connect gemacht. In meiner Config steht folgendes:

[code]
<Files "dateiname">
AuthMySQLAuthoritative On
AuthMySQLEnable On
AuthMySQLHost localhost
AuthMySQLDB <databasename>
AuthMySQLUser <username>
AuthMySQLPassword <userpw>
AuthMySQLUserTable user
AuthMySQLNameField login
AuthMySQLPasswordField passwort
AuthMySQLPwEncryption scrambled
AuthMySQLPort 3306
AuthMySQLSocket /var/lib/mysql/mysql.sock
AuthName "Interner Administrationsbereich"
AuthType Basic
require valid-user
</Files>
[/code]

Die Tabellennamen und angaben stimmen soweit, login mit dem User geht auch und Zugriff auf die Datenbank ist ebenfalls möglich. Trotz debug am Apache nur

[error] Internal error: pcfg_openfile() called with NULL filename
[error] [client XXX.XXX.XXX.XXX] (9)Bad file descriptor: Could not open password file: (null)

im Logfile
durtro
 
Posts: 2
Joined: 07. September 2006 17:45

Postby durtro » 11. September 2006 14:52

Lösung:

Nach langem rumprobieren hab ich ne Lösung gefunden. Ich hab es einfach beim Laden der Module anstatt am Ende an den Anfang gestellt und schon gehts.
durtro
 
Posts: 2
Joined: 07. September 2006 17:45


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests