Keine connect möglich (Apache / dyndns.org)

Alles, was den Apache betrifft, kann hier besprochen werden.

Keine connect möglich (Apache / dyndns.org)

Postby Dragekonge » 15. July 2006 19:26

Hallo ich erbitte um rat da ich persöhnlich alle meine bisherigen kenntnisse ausgeschöpft habe.

Ich habe Appache soweit eingerricht, das über local hoste die komplett seite zu öffnen ist und Appache die schrifft running trägt.
Ich versuche das mit meiner dns über dyndns.org auf meine dortige domains zu legen doch ich kann nicht connecten.

Meine frage ist nun: wie kann ich das Problem beheben? muss ich bei appache irgendwas einstellen damit ich über dyndns zu greifen kann? bzw wenn appache scheinbar läuft wie kann ich außer über local host drauf zugreifen? (zum testen ob es funktiniert)

Ich hoffe die die fragen sind konkret genug gestellt wenn nicht bitte bescheid geben.

MFG Dragekonge
Dragekonge
 
Posts: 4
Joined: 15. July 2006 19:18

Postby Dragekonge » 15. July 2006 19:27

Ganz vergessen das ganze soll als webserver für meine Homepage dienen

MFG Dragekonge
Dragekonge
 
Posts: 4
Joined: 15. July 2006 19:18

Re: Keine connect möglich (Apache / dyndns.org)

Postby Knight1 » 15. July 2006 20:09

Dragekonge wrote:... bzw wenn appache scheinbar läuft wie kann ich außer über local host drauf zugreifen? (zum testen ob es funktiniert)


Über Deine IP-Adresse. Sowohl die Netzwerk-IP in Deinem LAN sowie die Öffentliche im Internet.

Dragekonge wrote:Ich habe Appache soweit eingerricht, das über local hoste die komplett seite zu öffnen ist und Appache die schrifft running trägt.
Ich versuche das mit meiner dns über dyndns.org auf meine dortige domains zu legen doch ich kann nicht connecten.


Meine Frage dazu wäre.
Nutzt Du einen Router um ins Internet zu gelangen?

Wenn Ja musst Du noch das Port-Forwarding auf den Port 80 in dem Router einrichten.
Wenn Nein müsste es eigentlich funktionieren wenn Dein DynDNS-Account korrekt geupdatet ist. Dann wäre auch der Halb-Satz mit der IP-Adresse im LAN aus meiner ersten Antwort hinfällig.


Kai aka Knight1
Image
User avatar
Knight1
 
Posts: 310
Joined: 18. October 2003 10:03
Location: Trier
Operating System: Windows 7 Ultimate x64

Postby Dragekonge » 15. July 2006 20:41

habs nu auf rechner ohne service pack geladen es geht aber nur so halb meine freunde können auch connecten aber er läd das flash intro nicht ordentlich etc.
das gleiche ist auch über local host ka woher kommt
mfg
Dragekonge
 
Posts: 4
Joined: 15. July 2006 19:18

Postby deepsurfer » 17. July 2006 16:36

Dragekonge wrote:habs nu auf rechner ohne service pack geladen es geht aber nur so halb meine freunde können auch connecten aber er läd das flash intro nicht ordentlich etc.
das gleiche ist auch über local host ka woher kommt
mfg

Also klappt schonmal das connecten von ausserhalb über den dyndns-namen.
Das Bilder und Flashs zerstückelt herüberkommen kann mehrere Gründe haben.

- Die zwei einträge in der httpd.conf
Code: Select all
# EnableMMAP and EnableSendfile: On systems that support it,
# memory-mapping or the sendfile syscall is used to deliver
# files.  This usually improves server performance, but must
# be turned off when serving from networked-mounted
# filesystems or if support for these functions is otherwise
# broken on your system.
#
#EnableMMAP off
#EnableSendfile off

sind bei dir wie hier zu sehen einkommentiert.
Lösung: die zwei rauten vor den Anwesiungen entfernen, speichern, apache neu starten, testen und freuen.

- zuviele Hintergrundprogramme am laufen sodass der Apache keine möglichkeit hat die request von aussen und vom LAN zu verarbeiten.

- mehrere Virenscanner am laufen die ein verteilen der Daten so behindern das ein anständiges Arbeiten nicht gewährleistet ist.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests