Internal Server Error 500

Alles, was den Apache betrifft, kann hier besprochen werden.

Internal Server Error 500

Postby CaWa » 10. July 2006 19:00

Ein nettes Hallo an alle Forumer ;o)

Habe ein Problem seit 2 Tagen (Apache2.2 installiert) und zwar hätte ich gerne das wenn man meine Seite (index.html) besucht, das vorher eine Passwort abfrage kommt !
1. ist so etwas überhaupt machbar ?

Habe dazu im Verzeichnis C:/Programme/Apache Software Foundation/Apache2.2/htdocs eine .htaccess erstellt !
schaut so aus :

AuthType Basic
AuthName "CaWaWeb-Check"
AuthUserFile C:/Programme/Apache Software Foundation/Apache2.2/USERLog/.htpasswd
Require valid-user

und im USERLog Verzeichnis eine .htpasswd die so schaut :

User1:passwort

das ganze habe ich dann folgender maßen 'freigeschaltet' :
<Directory />
Options FollowSymLinks
AllowOverride FileInfo
</Directory>

<Directory "C:/Programme/Apache Software Foundation/Apache2.2/htdocs">

Options Indexes FollowSymLinks ExecCGI MultiViews

AllowOverride AuthConfig

</Directory>

<Files ~"^\.ht">
Order allow,deny
Deny from all
</Files>

AccessFileName .htaccess

Letztere Einträge habe ich in Foren etc. nachgelesen.

Habe die .htaccess im htdoc liegen wo auch meine index.html liegt. Wenn ich aber nu die Adresse zum Apache eingebe kommt der 500 error !
Im errorlog steht dann :

C:/Programme/Apache Software Foundation/Apache2.2/htdocs/.htaccess: AuthUserFile takes 1-2 arguments, text file containing user IDs and passwords

???
Muss ich irgendwo noch was eintragen in der conf ???

Vielen Dank für Eure Zeit.

MfG CaWa
CaWa
 
Posts: 2
Joined: 10. July 2006 18:25

Postby Wiedmann » 10. July 2006 19:14

C:/Programme/Apache Software Foundation/Apache2.2/htdocs/.htaccess: AuthUserFile takes 1-2 arguments, text file containing user IDs and passwords

Dann schauen wir uns deinen Befehl "AuthUserFile" und seine Parameter mal an:
Code: Select all
AuthUserFile C:/Programme/Apache Software Foundation/Apache2.2/USERLog/.htpasswd

Ich zähle hier 2 Parameter (IMHO kennt diese Directive auch entgegen der Fehlermeldung nur einen...):
"C:/Programme/Apache"
und
"Software Foundation/Apache2.2/USERLog/.htpasswd"

Weder das eine noch das andere zeigt auf eine Datei mit User und Passwörter.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby CaWa » 10. July 2006 20:13

@Wiedmann
Vielen Dank für diese schnelle Antwort !

Es lag also an den Leerzeichen im Pfad ?!
Ok, hab Apache neu installiert und dem entsprechen ohne Leerzeichen !
Supi, kein Error...

Und... und... es luppt...

1ooo Dank...

MfG CaWa
CaWa
 
Posts: 2
Joined: 10. July 2006 18:25

Postby Wiedmann » 10. July 2006 20:29

Es lag also an den Leerzeichen im Pfad ?!

Jein... Aber eben bei Leerzeichen im Pfad, muss man diesen in Doublequotes reintun:
Code: Select all
AuthUserFile "C:/Programme/Apache Software Foundation/Apache2.2/USERLog/.htpasswd"

(ist ja eigentlich schon von Windows selbst, also allgemein, bekannt...)

BTW war meine Aussage noch nicht mal korrekt. "Software" ist ja auch separat, also hat er 3 Parameter gefunden.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests