Gelöst: SymLinks Problem

Alles, was den Apache betrifft, kann hier besprochen werden.

Gelöst: SymLinks Problem

Postby MongoRider » 07. July 2006 13:30

Hallo
ich hab ein Problem bin bin leider bis jetzt nicht fündig geworden(zumindest nicht in der Art und Weise als das ich es verstehen würde).

Bin leider ziemlicher Noob also bitte so schreiben dass auch ich es versteh.
Also:
Ich hab in einem Verzeichnis (Dir1) einen Symbolischen Link gemacht der auf eine Datei in einem anderen Ordner zeigt (Dir2), allerdings ist der Zugriff darauf verweigert worden.
Kann mir vielleicht irgendjemand sagen wo und was ich ändern muss bzw. hinzufügen muss.

Ich verwende SUSE 9.0 und Apache 2

Danke im Vorraus
Last edited by MongoRider on 20. July 2006 14:48, edited 1 time in total.
MongoRider
 
Posts: 13
Joined: 07. July 2006 13:22

Postby deepsurfer » 07. July 2006 13:55

Ich hab in einem Verzeichnis (Dir1) einen Symbolischen Link gemacht der auf eine Datei in einem anderen Ordner zeigt (Dir2), allerdings ist der Zugriff darauf verweigert worden.

- Rechte (chmod) und/oder Gruppenrichtlinien (chown) der Datei in Dir2 blockiert den Aufruf

- poste mal bitte den von dir benutzten SymLINK befehl hierhin, oftmal ist nur die Reihenfolge falsch.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby MongoRider » 07. July 2006 14:02

Der Ordner und alle darin enthaltenenen SymLinks haben chmod 777 Rechte und im konquerer wenn ich auf einen SymLink klicke funktioniert er auch nur wenn ich im Browser die URL eingeb funktionierts nicht

Link hab ich mit ln -s Quelle Ziel gemacht
Hab auch absoluten und relativen Pfad ausprobiert, hat beisdes nichts gebracht
MongoRider
 
Posts: 13
Joined: 07. July 2006 13:22

Postby MongoRider » 07. July 2006 14:04

sowit ich weiß muss man in der httpd.conf irgendwas umstellen hab da auch schon viel probiert aber klappt nicht
MongoRider
 
Posts: 13
Joined: 07. July 2006 13:22

Postby deepsurfer » 07. July 2006 14:14

Code: Select all
<Directory />
    Options FollowSymLinks
    AllowOverride None
</Directory>

FollowSymLinks = Der Server folgt symbolischen Links in diesem Verzeichnis.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby MongoRider » 07. July 2006 14:19

bei mir steht
<Directory "/srv/www/htdocs">
Options Indexes -FollowSymLinks +Multiviews
Allow Override None
Order allow,deny
Allow from all
</Directory>

soll ich das was du geschrieben hast einfach drunter schreiben oder wie
Bitte ich weiß es klingt blöd aber ich bräucht das bitte deppeneinfach erklärt
:wink:
Danke
MongoRider
 
Posts: 13
Joined: 07. July 2006 13:22

Postby Wiedmann » 07. July 2006 14:23

Options Indexes -FollowSymLinks +Multiviews

Hier verbietest du ja expliziet Symlinks. Da das nicht standardmässig dort steht, hast du es selbst hingeschrieben....

BTW:
Lösch das einfach, oder mach aus dem "-" ein "+".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby MongoRider » 07. July 2006 14:26

das hab ich schon gemacht, war sogar das erste was ich getan hab es bringt aber auch nix
MongoRider
 
Posts: 13
Joined: 07. July 2006 13:22

Postby MongoRider » 07. July 2006 14:33

wenn ich

<Directory "/srv/www/htdocs">
Options Indexes -FollowSymLinks +Multiviews
Allow Override None
Order allow,deny
Allow from all
</Directory>

gesetzt hab und ich meine Links aber in einem Unterverzeichnis hab, muss ich dann für das Unterverzeichnis das gleiche nochmal machen.
Falls dem so ist, muss ich das für das Verzeichnis machen wo die Links drin sind, oder für das wo die Dateien drin sind die verlinkt werden??
MongoRider
 
Posts: 13
Joined: 07. July 2006 13:22

Postby Wiedmann » 07. July 2006 14:39

das hab ich schon gemacht, war sogar das erste was ich getan hab

Da ein "+FollowSymLinks" aber Grundvorausetzung ist und du das als erstes geändert hast, wieso ist das dann in deinem Beispiel nicht drin?

BTW:
Wo immer der Symlink dann hinzeigt, der Apache braucht natürlich Lese- und Execute-Rechte auf das Directory wo die Zieldatei ist, und Leserechte auf die Zieldatei selbst.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby MongoRider » 07. July 2006 14:42

Ich habs wieder zurück verändert nachdem ichs umgeschrieben hab und sich nicht verändert hat, ich wollt mir nämlich nicht gleich die config verhauen
btw: haben auf den ordner htdocs und allen seinen unterordnern alle alle rechte (chmod 777)
MongoRider
 
Posts: 13
Joined: 07. July 2006 13:22

Postby MongoRider » 10. July 2006 08:18

MongoRider wrote:
<Directory "/srv/www/htdocs">
Options Indexes -FollowSymLinks +Multiviews
Allow Override None
Order allow,deny
Allow from all
</Directory>



kann mir vielleicht irgendwer schreiben wie ich das jetzt so hinschreib das es auch funzt?
Am besten wärs wenn ihr einfach mein Beispiel von oben nehmt und dann das ganze nochmal richtig posted
danke
MongoRider
 
Posts: 13
Joined: 07. July 2006 13:22

Postby deepsurfer » 10. July 2006 13:01

Eindeutiger als Wiedmann kann man es doch nicht schreiben.
"-FollowSymLinks" in "+FollowSymLinks" ändern.
Code: Select all
<Directory "/srv/www/htdocs">
Options Indexes +FollowSymLinks +Multiviews
Allow Override None
Order allow,deny
Allow from all
</Directory>
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby MongoRider » 12. July 2006 09:05

deepsurfer wrote:Eindeutiger als Wiedmann kann man es doch nicht schreiben.
"-FollowSymLinks" in "+FollowSymLinks" ändern.
Code: Select all
<Directory "/srv/www/htdocs">
Options Indexes +FollowSymLinks +Multiviews
Allow Override None
Order allow,deny
Allow from all
</Directory>


Ich weiß nicht, aber hast du dir meinen Comment zu Wiedmann dazu auch angeschaut?
Es bringt mir nämlich Nüsse wenn ich da ein + statt einem - mach.
Ich sags nochmal ich hab SUSE 9.0 und Apache 2.0. Ich hab ghört dass bei SUSE das Apache config File auf mehrere aufgeteilt worden sein soll, aber keinen plan auf welche.

Ich hab bis jetzt immer die /etc/httpd/httpd.conf Datei bearbeitet, ich glaub das is die richtige aber falls ich mich irre teilt es mir bitte mit.
danke
Mongo
MongoRider
 
Posts: 13
Joined: 07. July 2006 13:22

Postby MongoRider » 14. July 2006 13:14

hallo, ich spamm ja nur ungern aber kann mir vielleicht wer helfen?
bzw ich hab gehört unter suse gibt es mehrere config files.
Ich hab bis jetzt immer /etc/httpd/httpd.conf bin mir aber mittlerweile nicht mehr sicher ob das das richtige file is.
Außerdem hab ich gemerkt das apache1 auch noch installiert is.
Kann das zu unverträglichkeiten kommen?

danke für alle bisherigen comments und für die die noch kommen
mongo
MongoRider
 
Posts: 13
Joined: 07. July 2006 13:22

Next

Return to Apache

Who is online

Users browsing this forum: No registered users and 8 guests