Hilfe bei VirtualHosts

Alles, was den Apache betrifft, kann hier besprochen werden.

Hilfe bei VirtualHosts

Postby Ill82 » 03. July 2006 18:18

Hallo Leute,

bisher hatte ich immer nur mit Lampp oder Xampp gearbeitet und nur eine dyndns.org, adresse gehabt, da ich jetzt aber bisschen was ausprobieren wollte und verschiedene Webauftritte unter den verschiedenen adressen haben wollte hab ich mich für den allseits beliebten Apache (Ver. 2.0.54) entschieden und installiert, unter Suse 10. Konfigurieren tu ich es derzeit im Webmin.

Nun zu meinem Problem:
wenn ich die virtuellen hosts anlege mit den verschiedenen adressen, dann funktioniert gerade mal einer wirklich richtig

Code: Select all
<VirtualHost *>
DocumentRoot /srv/www/htdocs/<verzeichnis1>
ServerName <vhost1>.dyndns.org
<Directory "/srv/www/htdocs/t<verzeichnis1>">
allow from all
Options +Indexes
</Directory>
</VirtualHost>


wenn ich jetzt weitere vhosts hinzufüge, enden diese auf dem "standard-server" selbst wenn ich dem server sage das er auf eine bestimme adresse hören möchte wie diese z.B.
Code: Select all
<VirtualHost <vhost2>.dyndns.org>
DocumentRoot "/srv/www/htdocs/<verzeichnis2>"
ServerName <vhost2>.dyndns.org
<Directory "/srv/www/htdocs/<verzeichnis2>">
allow from all
Options +Indexes
</Directory>
</VirtualHost>


die frage ist warum macht er das, ich hatte eigentlich die beschreibung so verstanden, das ausgelesen wird um welche adresse es sich handelt.

ich hab auch schon veruscht neben <VirtualHost> den namen der jeweiligen domain, einzutragen, aber da is das gleich problem. liegt es vielleicht daran, das ich das ganze über eine normale DSL-Leitung laufen lasse und er sich dann trotz allem nur auf die IP konzentriert?!

Danke für die Hilfe!

Martin
Ill82
 
Posts: 1
Joined: 03. July 2006 17:43

Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests