403 forbidden

Alles, was den Apache betrifft, kann hier besprochen werden.

403 forbidden

Postby _miro » 22. June 2006 13:54

Hallo,

hatte einen funktionieren Web-Server, der nun nicht mehr funktioniert.
Beim Versuch die Seite aufzurufen kommt immer die Fehlermeldung "403 FORBIDDEN"

Ich hatte vor mir ein Netzwerk Überwachungstool zu installieren. (JFFNMS)
Weil dieses nicht richtig funktionierte, wurde mir empfohlen in der php.ini den Wert Register_Globals auf "On", seitdem will der Apache nicht mehr.
Hab schon den Ordner /srv/www/htdocs/ auf vollen Zugriff gesetzt und als Owner den JFFNMS User gesetzt ... aber trotzdem kommt die Meldung 403 Forbidden.


Folgendes System:

[list=]SuSE Linux 9.1 (i586)[/list]
[list=]Kernel 2.6.8.1 / i686[/list]
[list=]Apache 2.0.49[/list]
[list=]php 4.3.4[/list]


Lt. einem Entwickler der Software solls wohl an der Berechtigung liegen.
Ich bin nicht der Linux Experte, hoffentlich kennt jemand dieses Problem.

Grüsse

miro
_miro
 
Posts: 4
Joined: 22. June 2006 12:33
Location: Köln

Postby deepsurfer » 22. June 2006 17:34

Weil dieses nicht richtig funktionierte, wurde mir empfohlen in der php.ini den Wert Register_Globals auf "On", seitdem will der Apache nicht mehr.

Wenn Authoren emphlen die globals auf On zu setzen....naja... aber ich will nicht lästern...

Zum Problem als solches, ich finde auf anhieb kein LINK zu diesem ominösen
JFFNMS um zu schauen was in deren Anleitung steht.

Hast du mal probiert die globlas wieder auf OFF zu setzen damit dein Apache erstmal wieder startet. ?

Was komisch an dieser Fehlerbeschreibung ist, das es dem Apachen eigentlich schnurz egal ist ob die globals on oder off sind, denn das ist eine PHP angelegenheit.
Hierbei wäre es gut wenn du dir mal die log dateien des Apachen anschaust, darin sollte stehen warum er nicht starten will.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

...

Postby _miro » 23. June 2006 10:25

Hallo,

die Globals hab ich wieder zurückgestellt, aber der Apache funzt danach weiterhin nicht ....


Hier eine Anleitung:
http://jffnms.org/jffnms/INSTALL

Grüsse.

_miro
_miro
 
Posts: 4
Joined: 22. June 2006 12:33
Location: Köln

nochwas

Postby _miro » 23. June 2006 10:27

ach ja ...

da ich nicht so ein Fan vom VIM bin, hab ich winscp zum einlogen auf den Server genutzt und den Winscp Editor zum bearbeiten der php.ini ....


Kann das Probleme verursachen ???

(Ich hab aber doch die Rechtevergabe des gesamten Verzeichnisses auf den JFFNMS User geändert ...)

grüsse

_miro
_miro
 
Posts: 4
Joined: 22. June 2006 12:33
Location: Köln

Postby deepsurfer » 23. June 2006 15:35

da ich nicht so ein Fan vom VIM bin, hab ich winscp zum einlogen auf den Server genutzt und den Winscp Editor zum bearbeiten der php.ini ....


Kann das Probleme verursachen ???

mache ich auch öffters, bisher keine probs gehabt, muss aber gestehen das ich die php.ini dmit noch nicht geändert hatte.


Da nun feststeht das der globals Änderungen nicht schuld sind am nicht starten des Apache, wäre ein Blick in die LOGfiles des Apachen nötig.
Darin sollte stehen warum er nicht starten will.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Logs

Postby _miro » 24. June 2006 11:50

Hallo,

hier die Logs:

access_log:

10.200.200.19 - - [20/Jun/2006:21:45:15 +0200] "GET /jffnms/admin/setup.php HTTP/1.1" 403 1110 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; d
e; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4"
10.200.200.19 - - [20/Jun/2006:21:47:48 +0200] "GET / HTTP/1.1" 403 1122 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.0.4) Gecko/2
0060508 Firefox/1.5.0.4"
10.200.200.19 - - [20/Jun/2006:21:47:53 +0200] "GET /test HTTP/1.1" 403 1110 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.0.4) Gec
ko/20060508 Firefox/1.5.0.4"
10.200.249.255 - - [22/Jun/2006:14:43:41 +0200] "GET / HTTP/1.1" 403 1122 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.0; de; rv:1.8.0.4) Gecko/
20060508 Firefox/1.5.0.4"
10.200.249.255 - - [22/Jun/2006:14:43:41 +0200] "GET /favicon.ico HTTP/1.1" 403 1110 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.0; de; rv:1.8.
0.4) Gecko/20060508 Firefox/1.5.0.4"
10.200.249.255 - - [22/Jun/2006:14:43:41 +0200] "GET /favicon.ico HTTP/1.1" 403 1110 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.0; de; rv:1.8.
0.4) Gecko/20060508 Firefox/1.5.0.4"
10.200.249.255 - - [23/Jun/2006:14:27:10 +0200] "GET / HTTP/1.1" 403 1122 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.0; de; rv:1.8.0.4) Gecko/
20060508 Firefox/1.5.0.4"
10.200.249.255 - - [23/Jun/2006:14:27:10 +0200] "GET /favicon.ico HTTP/1.1" 403 1110 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.0; de; rv:1.8.
0.4) Gecko/20060508 Firefox/1.5.0.4"
10.200.249.255 - - [23/Jun/2006:14:27:10 +0200] "GET /favicon.ico HTTP/1.1" 403 1110 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.0; de; rv:1.8.
0.4) Gecko/20060508 Firefox/1.5.0.4"
10.200.249.255 - - [23/Jun/2006:17:08:19 +0200] "GET / HTTP/1.1" 403 1122 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.0; de; rv:1.8.0.4) Gecko/
20060508 Firefox/1.5.0.4"
10.200.249.255 - - [23/Jun/2006:17:08:19 +0200] "GET /favicon.ico HTTP/1.1" 403 1110 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.0; de; rv:1.8.
0.4) Gecko/20060508 Firefox/1.5.0.4"
10.200.249.255 - - [23/Jun/2006:17:08:19 +0200] "GET /favicon.ico HTTP/1.1" 403 1110 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.0; de; rv:1.8.
0.4) Gecko/20060508 Firefox/1.5.0.4"
10.200.249.255 - - [24/Jun/2006:12:13:19 +0200] "GET / HTTP/1.1" 403 1122 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.0; de; rv:1.8.0.4) Gecko/
20060508 Firefox/1.5.0.4"
access_log lines 578-603/603 (END)



und hier das ...
error_log:

[Tue Jun 20 21:21:18 2006] [error] [client 10.200.200.19] client denied by server configuration: /srv/www/htdocs/
[Tue Jun 20 21:32:43 2006] [error] [client 10.200.200.19] client denied by server configuration: /srv/www/htdocs/
[Tue Jun 20 21:40:46 2006] [error] [client 10.200.200.19] client denied by server configuration: /srv/www/htdocs/jffnms
[Tue Jun 20 21:43:57 2006] [error] [client 10.200.200.19] client denied by server configuration: /srv/www/htdocs/jffnms
[Tue Jun 20 21:43:58 2006] [error] [client 10.200.200.19] client denied by server configuration: /srv/www/htdocs/jffnms
[Tue Jun 20 21:44:43 2006] [warn] child process 11218 still did not exit, sending a SIGTERM
[Tue Jun 20 21:44:43 2006] [warn] child process 11220 still did not exit, sending a SIGTERM
[Tue Jun 20 21:44:43 2006] [warn] child process 11222 still did not exit, sending a SIGTERM
[Tue Jun 20 21:44:43 2006] [warn] child process 11224 still did not exit, sending a SIGTERM
[Tue Jun 20 21:44:43 2006] [warn] child process 11226 still did not exit, sending a SIGTERM
[Tue Jun 20 21:44:43 2006] [warn] child process 11304 still did not exit, sending a SIGTERM
[Tue Jun 20 21:44:44 2006] [notice] caught SIGTERM, shutting down
[Tue Jun 20 21:44:44 2006] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
[Tue Jun 20 21:44:44 2006] [notice] LDAP: Built with OpenLDAP LDAP SDK
[Tue Jun 20 21:44:44 2006] [notice] LDAP: SSL support unavailable
[Tue Jun 20 21:44:44 2006] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
[Tue Jun 20 21:44:45 2006] [notice] LDAP: Built with OpenLDAP LDAP SDK
[Tue Jun 20 21:44:45 2006] [notice] LDAP: SSL support unavailable
PHP Warning: Unknown(): Unable to load dynamic library '/usr/lib/php/extensions/snmp.so' - /usr/lib/php/extensions/snmp.so: undefined symbol:
usmAES192PrivProtocol in Unknown on line 0
[Tue Jun 20 21:44:47 2006] [notice] mod_python: Creating 32 session mutexes based on 150 max processes and 0 max threads.
[Tue Jun 20 21:44:47 2006] [notice] Apache/2.0.49 (Linux/SuSE) configured -- resuming normal operations
[Tue Jun 20 21:45:15 2006] [error] [client 10.200.200.19] client denied by server configuration: /srv/www/htdocs/jffnms
[Tue Jun 20 21:45:15 2006] [error] [client 10.200.200.19] client denied by server configuration: /srv/www/htdocs/jffnms
[Tue Jun 20 21:47:48 2006] [error] [client 10.200.200.19] client denied by server configuration: /srv/www/htdocs/
[Tue Jun 20 21:47:53 2006] [error] [client 10.200.200.19] client denied by server configuration: /srv/www/htdocs/test
[Thu Jun 22 14:43:41 2006] [error] [client 10.200.249.255] client denied by server configuration: /srv/www/htdocs/
[Thu Jun 22 14:43:41 2006] [error] [client 10.200.249.255] client denied by server configuration: /srv/www/htdocs/favicon.ico
[Thu Jun 22 14:43:41 2006] [error] [client 10.200.249.255] client denied by server configuration: /srv/www/htdocs/favicon.ico
[Fri Jun 23 14:27:10 2006] [error] [client 10.200.249.255] client denied by server configuration: /srv/www/htdocs/
[Fri Jun 23 14:27:10 2006] [error] [client 10.200.249.255] client denied by server configuration: /srv/www/htdocs/favicon.ico
[Fri Jun 23 14:27:10 2006] [error] [client 10.200.249.255] client denied by server configuration: /srv/www/htdocs/favicon.ico
[Fri Jun 23 17:08:19 2006] [error] [client 10.200.249.255] client denied by server configuration: /srv/www/htdocs/
[Fri Jun 23 17:08:19 2006] [error] [client 10.200.249.255] client denied by server configuration: /srv/www/htdocs/favicon.ico
[Fri Jun 23 17:08:19 2006] [error] [client 10.200.249.255] client denied by server configuration: /srv/www/htdocs/favicon.ico
[Sat Jun 24 12:13:19 2006] [error] [client 10.200.249.255] client denied by server configuration: /srv/www/htdocs/
error_log lines 1505-1553/1553 (END)


Anscheinend ist die Server Konfig nicht in Ordnung.
Wie kann ich nun weiter vorgehen???

Grüsse

miro
_miro
 
Posts: 4
Joined: 22. June 2006 12:33
Location: Köln


Return to Apache

Who is online

Users browsing this forum: No registered users and 5 guests