PHP Installationsfehler

Alles, was den Apache betrifft, kann hier besprochen werden.

PHP Installationsfehler

Postby onlineuser » 11. June 2006 23:14

Hi,

habe folgendes Problem mit dem Laden des PHP-Moduls.

httpd.exe: Syntax error on line 2 of C:/Programme/Apache Software Foundation/Apa
che2.2/conf/httpd.conf: Cannot load C:/Programme/Apache Software Foundation/PHP/
php5apache.dll into server: Das angegebene Modul wurde nicht gefunden.
Note the errors or messages above, and press the <ESC> key to exit. 28...


In meiner httpd.conf stehen folgende Einträge:

# For PHP 5 do something like this:
LoadModule php5_module "C:/Programme/Apache Software Foundation/PHP/php5apache.dll"
AddType application/x-httpd-php .php

# configure the path to php.ini
PHPIniDir "C:/Programme/Apache Software Foundation/PHP/"


Mit meinem alten Apache 2.0.55 und PHP 4.x.y funktionierte es so. Das Verzeichnis mit dem Leerzeichen ist auch nicht schuld, da das alte Verzeichnis damals "Apache Group" geheissen hat. ansonsten hab ich die Zeilen 1:1 übernommen.

Hatte diesen Fehler damals auch. Hab dann, glaube ich, die php5apache2.dll und weitere .dll Dateien ins Windows/System-Verzeichnis kopiert, aber dies half jetzt auch nicht.

Kennt dieses Problem jemand?

Liebe Grüsse.
onlineuser
 
Posts: 22
Joined: 05. January 2006 18:07

Postby onlineuser » 26. June 2006 17:03

Hi,

hat niemand einen Lösungsvorschlag für mich!?

Liebe Grüsse.
onlineuser
 
Posts: 22
Joined: 05. January 2006 18:07

Postby Wiedmann » 26. June 2006 17:08

Man könnte z.B. diesen Thread lesen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby onlineuser » 26. July 2006 07:19

Hi,

Mit diesem Trick (httpd.exe.manifest nach C:\Programme\Apache Software Foundation\Apache2.2\bin kopieren und php5apache2.dll nach C:\Programme\Apache Software Foundation\PHP kopieren) funktioniert zwar PHP, aber gewisse Seiten parst das Ding einfach nicht. Es bleibt nur ein weißer Bildschirm zu sehen (z.B.: Woltlab Burning Book).

Habs mit verschiedensten Versionen probiert. Jetzt denke ich mir, kann der Hund nur da begraben sein. Funktioniert PHP 5.1.4 mittlerweile schon mit den originalen Dateien des Apache 2.2.2?

Hab grad in den Logfiles nachgesehen:

[Wed Jul 26 09:36:52 2006] [error] [client 127.0.0.1] PHP Parse error: parse error, unexpected $end in C:\\Programme\\Apache Software Foundation\\#Webserver\\new\\burningbook\\admin\\install.php on line 495

Warum gibt er nur einen weissen Bildschirm aus und nicht den Fehler, wie bisher!? Also scheint das Woltlab Gästebuch nicht ganz PHP 5 kompatibel zu sein!?

PS: Problem ist, dass in den PHP Dateien auch normaler HTML-Code steht. Anscheinend mag das PHP nicht. Kann man das wo einstellen, dass er "gemischte" Dateien auch parsen kann!?

Scheint der Schalter display_errors = On gewesen zu sein. :)

Liebe Grüsse.
onlineuser
 
Posts: 22
Joined: 05. January 2006 18:07


Return to Apache

Who is online

Users browsing this forum: No registered users and 5 guests