403 Forbidden bei virtuellem Host

Alles, was den Apache betrifft, kann hier besprochen werden.

403 Forbidden bei virtuellem Host

Postby ZaHaDum » 20. May 2006 21:30

Hi Leute!

Ich habe bei meinem Apache-Server (2.0.55 unter Windows XP) einen zusätzlichen virtuellen Host definiert um die Entwicklungsumgebungen meiner zweiten Internetseite besser von der anderen trennen zu können.
Dafür habe ich in der httpf-conf-Datei folgende Zeilen eingefügt:

Code: Select all
 NameVirtualHost *:80

#Eintrag zur Erhaltung von localhost
<VirtualHost *:80>
    ServerName localhost
    ServerAdmin info@localhost
    DocumentRoot "C:/Programme/Apache Group/Apache2/htdocs"
    ErrorLog logs/error.log
    CustomLog logs/access.log common
</VirtualHost>

#Eintrag für den zweiten host jbo
<VirtualHost *:80>
    ServerName jbo
    ServerAdmin info@jbo
    DocumentRoot "C:/Programme/Apache Group/Apache2/jbo"
    ErrorLog logs/error.log
    CustomLog logs/access.log common
</VirtualHost>

<Directory "C:/Programme/Apache Group/Apache2/jbo">
    AllowOverride All
    Options IncludesNoExec
    Order allow,deny
    Allow from all
</Directory>


Ebenfalls habe ich der HOSTS-Datei folgenden Eintrag hinzugefügt:

Code: Select all
127.0.0.1    jbo


Nun kann ich den virtuellen Host JBO zwar erreichen, bekomme dabei aber immer die Standard-Fehlermeldung 403 Forbidden.

Was kann man da machen?
ZaHaDum
 
Posts: 4
Joined: 20. May 2006 21:09

Postby deepsurfer » 21. May 2006 12:49

Nun kann ich den virtuellen Host JBO zwar erreichen, bekomme dabei aber immer die Standard-Fehlermeldung 403 Forbidden.


Was steht denn in den LOGdateien ??
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby ZaHaDum » 21. May 2006 12:58

Die Log-Dateien sind leer. Das macht das Problem ja gerade so undurchsichtig.
ZaHaDum
 
Posts: 4
Joined: 20. May 2006 21:09

Postby deepsurfer » 21. May 2006 13:16

ahh denke habs gefunden.... folgendes


dein erster VHOST ist sozusagen der VHOST der bei einem Fehler angezeogt wird.
In diesem ersten VHOST hast du kein Directory definiton für Order allow,deny gesetzt, somit ist der Zugrif generell schonmal unterbunden.

daher dürfte das "localhost" schonmal nicht funktionieren.

Folglich das erstmal erweitern und localhost testen.

Aus dieser erkenntnis sollte nun beim einem Fehler beim Aufruf des jbo der localhost antworten und auch die Logfile schreiben.


Desweiteren werden im VHOST zwei (jbo) die selbe LOGdateien benutzt, grundsätzlich nichts einzuwenden, hat aber den nachteil das es bei der Fehlersuche erschwert wenn etwas unter jbo nicht richtig funktioniert.
Folglich für die jbo Logs nur einen anderen namen nehmen.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby ZaHaDum » 21. May 2006 13:32

Aber localhost funktioniert auch weiterhin einwandfrei.

Habe die httpf-conf-Datei jetzt folgendermaßen modifiziert:

Code: Select all
NameVirtualHost *:80

<VirtualHost *:80>
    ServerName localhost
    ServerAdmin info@localhost.de
    DocumentRoot "C:/Programme/Apache Group/Apache2/htdocs"
    ErrorLog logs/error.log
    CustomLog logs/access.log common
</VirtualHost>

<Directory "C:/Programme/Apache Group/Apache2/htdocs">
    AllowOverride All
    Options IncludesNoExec
    Order allow,deny
    Allow from all
</Directory>

<VirtualHost *:80>
    ServerName jbo
    ServerAdmin info@jbo-stukenbrock.de
    DocumentRoot "C:/Programme/Apache Group/Apache2/jbo"
    ErrorLog logs/error.log
    CustomLog logs/access.log common
</VirtualHost>

<Directory "C:/Programme/Apache Group/Apache2/jbo">
    AllowOverride All
    Options IncludesNoExec +ExecCGI
    Order allow,deny
    Allow from all
</Directory>


Aber alles bleibt beim alten.

Wenn der Server auf einem UNIX bzw Linux-System laufen würde, würde ich versuchen das Problem über die Dateiatribute zu lösen, da 403 Forbidden normalerweise durch fehlerhafte Atribute für die Berechtigungen ausgelöst wird.
Diese Option habe ich bei Windows aber leider nicht.

Habe in der error.log folgenden Eintrag:

Code: Select all
[Sun May 21 14:26:11 2006] [error] [client 127.0.0.1] Directory index forbidden by rule: C:/Programme/Apache Group/Apache2/jbo/


Aber im Verzeichnis existiert eine Datei mit dem Namen index.htm.
Warum versucht der Server dann einen Verzeichnisindex anzuzeigen?
ZaHaDum
 
Posts: 4
Joined: 20. May 2006 21:09

Postby deepsurfer » 21. May 2006 13:38

Ich iddi


Die Directory directiven müssen innerhalb des des <VirtualHost> stehen.


Code: Select all
NameVirtualHost *:80

<VirtualHost *:80>
    ServerName localhost
    ServerAdmin info@localhost.de
    DocumentRoot "C:/Programme/Apache Group/Apache2/htdocs"
    ErrorLog logs/error.log
    CustomLog logs/access.log common

<Directory "C:/Programme/Apache Group/Apache2/htdocs">
    AllowOverride All
    Options IncludesNoExec
    Order allow,deny
    Allow from all
</Directory>
</VirtualHost>   #<<-- der kommt hier unten hin dann nächster VHOST

<VirtualHost *:80>
    ServerName jbo
    ServerAdmin info@jbo-stukenbrock.de
    DocumentRoot "C:/Programme/Apache Group/Apache2/jbo"
    ErrorLog logs/error.log
    CustomLog logs/access.log common

<Directory "C:/Programme/Apache Group/Apache2/jbo">
    AllowOverride All
    Options IncludesNoExec +ExecCGI
    Order allow,deny
    Allow from all
</Directory>
</VirtualHost>   #<<-- der kommt hier unten hin
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Wiedmann » 21. May 2006 13:51

@ Deep, bei VHosts bist dich manchmal auf dem Holzweg ;-)

ZaHaDum wrote:
Code: Select all
Directory index forbidden by rule:

Aber im Verzeichnis existiert eine Datei mit dem Namen index.htm.

Deine VHostkonfig hat schon beim ersten Mal gepasst. Aber sind "*.htm"-Dateien auch im "DirectoryIndex" aufgeführt?

BTW:
Wenn der Server auf einem UNIX bzw Linux-System laufen würde, würde ich versuchen das Problem über die Dateiatribute zu lösen, da 403 Forbidden normalerweise durch fehlerhafte Atribute für die Berechtigungen ausgelöst wird.

Das Problem könntest du auch unter Windows haben... nur hättest du dann unter beiden OS'se einen Eintrag im "error.log", dass vom OS her der Zugriff auf die Datei für den Apache-Prozess verboten wurde.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby ZaHaDum » 21. May 2006 14:29

Super, jetzt läuft auch der zweite VirtualHost einwandfrei! :D

An dieser Stelle vielen Dank für die Hilfe und Mühen. :)
ZaHaDum
 
Posts: 4
Joined: 20. May 2006 21:09


Return to Apache

Who is online

Users browsing this forum: No registered users and 2 guests