Verzeichis-Browsing

Alles, was den Apache betrifft, kann hier besprochen werden.

Verzeichis-Browsing

Postby Quäntchen » 03. May 2006 14:30

Hallo, ich versuch zur Zeit mal alles selber zu installieren. Apache natürlich als erstes. Nach der Installation gefie mir jedoch folgendes überhaupt nicht:
Image

Kann man das Verzeichnis Browsing auf die übliche Art umstellen, mit Symbolen und in so ner liste?

Ich zähle auf eure Antworten *g
Quäntchen
 
Posts: 27
Joined: 27. December 2005 10:02

Postby deepsurfer » 03. May 2006 14:36

Leg einfach mal einige Dateien in diesen Pfad hinein und rufe es dann wieder im Browser auf.
In der Grundinstallation sind schon ICONs für das Indexing vorhanden.

Um eigene zu benutzen kann man das mittels einer htaccess-Steuerdatei machen oder halt die im Apache schon vorhandenen Images gegen eigene Ersetzen.

http://www.trash.net/faq/htaccess.shtml#fancyindexing
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Quäntchen » 03. May 2006 14:41

Genau das verstehe ich nichz, selbst wenn ich Dateien reinlege ist es so. Un in der autoindex.conf ist FancyIndexing auf on gestellt. Und trotzdem funktioniert es nicht. Liegts es vielleicht daran, weils der Aapche 2.2 ist der egentlich noch inoffiziell ist? (für Windows)
Quäntchen
 
Posts: 27
Joined: 27. December 2005 10:02

Postby deepsurfer » 03. May 2006 14:46

Schau ma in deine httpd.conf ob es dort zwei Zeilen gibt die wie folgt aussehen...
Code: Select all
#EnableMMAP off
#EnableSendfile off


Wenn ja, dann mal beide <rauten> vor jeder Zeile entfernen, speichern, apachen neu starten und testen.

Solltest du diese zwei Zeilen nicht haben so nimm diese von hier und setze sie in deine httpd.conf (natürlich ohne die rauten).
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Quäntchen » 03. May 2006 14:48

Funktioniert leider immer noch nicht. Ich versuch es mal mit der Version 2.0.55
Quäntchen
 
Posts: 27
Joined: 27. December 2005 10:02

Postby Wessi » 04. May 2006 16:17

Hallo,

ich versuche mich seit 3 Tagen in Apache einzulesen, blicke jedoch gar nichts davon :D ist ziemlich umfangreich das ganze. Ich wollte eigentlich unseren Root Server so einstellen das es genau das macht, was bei hier passiert. Also einfach das Verzeichis auflistet. Könnte mir bitte jemand helfen und sagen wie das geht? Sind wahrscheinlich nur ein zwei dinge die ich einstellen muss.

Es handelt sich um einen Linux Rootserver mit Apache 2. Wenn ich http://88.x.x.x aufrufe soll er eine Liste des Verzeichnis z.B. /www/pub/ wiedergeben. In dem sind dann Dateien, welche Downloadbar sein sollen.

Vielen Dank
Wessi
 
Posts: 1
Joined: 04. May 2006 15:57

Postby deepsurfer » 04. May 2006 16:21

Quäntchen wrote:Funktioniert leider immer noch nicht. Ich versuch es mal mit der Version 2.0.55


hhmmm.....
ich wüsste jetzt auch nicht mehr weiter, denn das Bild zeigt ja das er das Indexing vollzieht, aber halt die enthaltenen Dateien und ordner nicht anzeigt.

Frage: kann es sein das nur ein Ordner dort ist und dieser Ordner mittels einem htaccess-Authenfizierung geschützt wurde ?
Wenn das der Fall ist so wird dies nicht im Indexing angezeigt !
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby deepsurfer » 04. May 2006 16:30

Wessi wrote:Hallo,

ich versuche mich seit 3 Tagen in Apache einzulesen, blicke jedoch gar nichts davon :D ist ziemlich umfangreich das ganze. Ich wollte eigentlich unseren Root Server so einstellen das es genau das macht, was bei hier passiert. Also einfach das Verzeichis auflistet. Könnte mir bitte jemand helfen und sagen wie das geht? Sind wahrscheinlich nur ein zwei dinge die ich einstellen muss.

Es handelt sich um einen Linux Rootserver mit Apache 2. Wenn ich http://88.x.x.x aufrufe soll er eine Liste des Verzeichnis z.B. /www/pub/ wiedergeben. In dem sind dann Dateien, welche Downloadbar sein sollen.

Vielen Dank


Hi Wessi,

normalerweise in der httpd.conf einbaubar.
Schau mal nach, es gibt die Sektion
DocumentRoot xxxxxxxxxxxxxxxxx
und im normal etwas darunter ein <Directoy> Directive, die Inhaltlich
mit diesen Befehlen gefüllt ist.
Options -Indexes FollowSymLinks Includes ExecCGI
Wenn du das so auch hast das minuszeichen vor dem Wort Indexes entfernen, speichern, apache neu starten und schaun ob nun das DirectorBrowsing läuft.

Anmerkung:
Dieser Befehl ist auch separat in VirtualHost und ALIAS bereichen einbaubar. So auch als komplett seprate Funktion mittels einer
.htaccess Datei.
http://www.trash.net/faq/htaccess.shtml ... neoptionen
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests