Apache hinter 2 Routern

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache hinter 2 Routern

Postby Hardstep » 28. April 2006 00:14

HI
Also erstmal vorweg, Xamp läuft super und problemlos (als Testplatform).


ich habe folgendes Problem:

ich sitze hinter 2 Routern

1. SpeedTouch 516 (Thomson):
_________________________

Mit fester IP (extern)

und fester WAN IP (10.0.0.138)

als NAPT Standertserver ist der 2. Router eingetragen :

2. Netgear WPN824 :
_________________________
Ebenfalls feste WAN IP (10.0.0.2)

feste Lan IP (192.168.1.1)
Die Clients haben feste "Classe-C" IP´s (192.168.1.[2-42])

_________________________

Soweit so gut :)

Alle port Anfragen müssten ja eigentlich von Route 1 an den Standertsever (Router 2 IP 10.0.0.2) übergeben werden.

Im Router 2 müsste ich ja dann den Port des Apache auf meine IP (192.168.1.10) forwarden, oder?

Aber wenn ich jetzt im Browser http://[feste ip]:80 eingebe passiert nix :(


Ich habe den Apache auch zu Testzwecken auf port 81 laufen lassen und konnte Ihn dann über http://localhost:81 aufrufen nur aus dem Web funktioniert das alles nicht (Port 81 habe ich natürlich auf meine IP forwardet in Router 2.)

Währe cool wenn jemand Rat hat!
Hardstep
 
Posts: 5
Joined: 01. July 2005 11:53

Postby deepsurfer » 30. April 2006 13:11

hhmmmmm, zwei Router (nein, ich frage nicht ;) ), wenn ich jetzt nicht ganz daneben liege im ersten Router eine "Forward Port 80" auf die LAN-Ip des PCs wo XAMPP läuft einrichten.
Sodass ein HTTPDrequest vom ersten Router definiert wird, und der zweite Router weis dann schon wo der PC steht und leitet den Request dorthin.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian


Return to Apache

Who is online

Users browsing this forum: No registered users and 8 guests