Für jeden User im Home einen eigenen Webordner ?httpd.conf

Alles, was den Apache betrifft, kann hier besprochen werden.

Für jeden User im Home einen eigenen Webordner ?httpd.conf

Postby jochen graf » 20. April 2006 09:41

Hallo,

wir haben ein Projekt Names WULV.

Nun sollte jeder angelegte User in seinem Home einen Webordner haben, über der er dann sein Projekt über das Web aufrufen bzw. bearbeiten kann.

Wie stelle ich nun das ein oder besser was benötige ich dafür?

der Pfad zur Zeit
/srv/www/htdocs

benötige ich da virtuelle Server?

danke
gruß jochen
jochen graf
 

Postby Wiedmann » 20. April 2006 10:23

mod_userdir z.B.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

userdir gesetzt

Postby jochen graf » 20. April 2006 10:37

Hallo,

danke

habe in die /etc/apache2/httpd.conf

## Einfügen der mod_userdir.conf für die Webuser

Include /etc/apache2/mod_userdir.conf eingetragen

die Rechte des Ordners auf 755 gesetzt.



Inhalt der mod_userdir.conf

<IfModule mod_userdir.c>
# Note that the name of the user directory ("public_html") cannot easily be
# changed here, since it is a compile time setting. The apache package
# would have to be rebuilt. You could work around by deleting
# /usr/sbin/suexec, but then all scripts from the directories would be
# executed with the UID of the webserver.
#
# To rebuild apache with another setting you need to change the
# %userdir define in the spec file.

# not every user's directory should be visible:
UserDir disabled root

# to enable UserDir only for a certain set of users, use this instead:
#UserDir disabled
#UserDir enabled user1 user2


# the UserDir directive is actually used inside the virtual hosts, to
# have more control
#UserDir public_html

<Directory /home/*/public_html>

AllowOverride FileInfo AuthConfig Limit Indexes
Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec

<Limit GET POST OPTIONS PROPFIND>
Order allow,deny
Allow from all
</Limit>

<LimitExcept GET POST OPTIONS PROPFIND>
Order deny,allow
Deny from all
</LimitExcept>

</Directory>

</IfModule>

Doch beim Aufruf des Weblinks


http://192.168.50.235/jochen/public_html/index.html

erhalte ich folgenede Meldung









Objekt nicht gefunden!

Der angeforderte URL konnte auf dem Server nicht gefunden werden. Sofern Sie den URL manuell eingegeben haben, überprüfen Sie bitte die Schreibweise und versuchen Sie es erneut.

Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber.
Error 404

Hast du einen Tipp??

danke
jochen graf
 

Postby Wiedmann » 20. April 2006 11:45

Hast du einen Tipp??

Die Doku dazu lesen ;-)


Müsste IMHO so sein:
http://192.168.50.235/~jochen/index.html
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Klappt

Postby jochen graf » 20. April 2006 16:08

Hallo,

klappt danke

http://192.168.50.235/~jochen/

Habe erste seit heute morgen was mit dem Apache zu tun.


schönes Wochenende :wink: :wink:
jochen graf
 


Return to Apache

Who is online

Users browsing this forum: No registered users and 1 guest