403 trotz chmod 777

Alles, was den Apache betrifft, kann hier besprochen werden.

403 trotz chmod 777

Postby nicknick » 11. April 2006 16:54

Hallo,
hab apache installiert und funktionierte alles gan gut. Dann hab ich die DocumentRoot geändert und nun kann ich nur noch localhost aufrufen wo dann die apache seite kommt. Sobald ich dann localhost/index.html aufrufe hab ich keine permission mehr obwohl die rechte für alle Ordner 777 sind. Wie kann ich den apache dazu bewegen die Seiten anzuzeigen?

Ich habe alle so gelassen nur die Documentroot geändert. Virtual host ist aus. Und ne .httpacces gibts auch net.
nicknick
 
Posts: 5
Joined: 04. April 2006 09:34

Postby mbscholz » 12. April 2006 08:50

Hast du schon mal in die error.log geschaut? Da müsste eigentlich was sinnvolles dazu drinstehen.

Gruß
Michael
mbscholz
 
Posts: 6
Joined: 17. March 2005 17:12

Postby nicknick » 12. April 2006 10:49

Das bring mich irgentwie nicht weiter
Code: Select all
[Tue Apr 11 17:27:09 2006] [error] [client 127.0.0.1] File does not exist: /home/www/favicon.ico
[Tue Apr 11 17:27:56 2006] [error] [client 127.0.0.1] (13)Keine Berechtigung: access to /index.html denied
nicknick
 
Posts: 5
Joined: 04. April 2006 09:34

Postby Wiedmann » 12. April 2006 10:50

Dann hab ich die DocumentRoot geändert

Wie hast du das /genau/ gemacht?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby mbscholz » 12. April 2006 11:04

nicknick wrote:Das bring mich irgentwie nicht weiter
Code: Select all
[Tue Apr 11 17:27:09 2006] [error] [client 127.0.0.1] File does not exist: /home/www/favicon.ico
[Tue Apr 11 17:27:56 2006] [error] [client 127.0.0.1] (13)Keine Berechtigung: access to /index.html denied


Die favicon-Zeile ist egal, aber die untere Zeile sagt eindeutig dass er auf die index nicht zugrifen kann. Hast du einen Zugriff über Konsole? Dann könntest du mit einem "su www-data" (oder wie auch immer der Nutzername deines Webserves ist) in seinen Modus wechseln und das mal testen, ob du wirklich nicht darst oder ob es eine Einstellung im Server ist.
mbscholz
 
Posts: 6
Joined: 17. March 2005 17:12


Return to Apache

Who is online

Users browsing this forum: No registered users and 2 guests