"Vorladen einer HTML-Seite" erzeugt Fehler 403????

Alles, was den Apache betrifft, kann hier besprochen werden.

"Vorladen einer HTML-Seite" erzeugt Fehler 403????

Postby giacomo » 16. July 2003 00:35

Auf der Suche nach einer Lösung, um eine HTML-Seite komplett vorzuladen (inkl.aller Grafiken, Bilder, Flash-Animationen) und dann "auf einen Schlag" anzuzeigen, habe ich im Internet Folgendes gefunden. Man bastele sich folgende HTML-Seite:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<html>
<head>
<title>meineseite.htm vorladen</title>
<script type="text/javascript">
function Is() {
agent = navigator.userAgent.toLowerCase();
this.major = parseInt(navigator.appVersion);
this.minor = parseFloat(navigator.appVersion);
this.ns = ((agent.indexOf('mozilla') != -1) &&
(agent.indexOf('spoofer') == -1) && (agent.indexOf('compatible') == -1) &&
(agent.indexOf('opera') == -1) &&
(agent.indexOf('webtv') == -1));
this.ns2 = (this.ns && (this.major == 3));
this.ns3 = (this.ns && (this.major == 3));
this.ns4 = (this.ns && (this.major == 4));
this.ns6 = (this.ns && (this.major >= 5));
this.ie = (agent.indexOf("msie") != -1);
this.ie3 = (this.ie && (this.major < 4));
this.ie4 = (this.ie && (this.major == 4) && (agent.indexOf("msie 5.0") == -1));
this.ie5 = (this.ie && (this.major == 4) && (agent.indexOf("msie 5.0") != -1));
this.ieX = (this.ie && !this.ie3 && !this.ie4);
}

var is = new Is();

var url = 'meineseite.htm';

</script>

</head>

<body onLoad="location.href = url;">

<p><font size="2" face="Verdana, Arial, Helvetica, sans-serif">Seite wird geladen...</font></p>

<script type="text/javascript">
if (document.layers)
document.write('<layer src="' + url + '" visibility="hide"><\/layer>');

else if (document.all || document.getElementById)
document.write('<iframe src="' + url + '" style="visibility: hidden;"><\/iframe>');

else location.href = url;
</script>

</body>
</html>


Mit dieser vorgeschalteten Seite wird "meineseite.htm" vollständig vorgeladen (inkl. aller Grafiken, Texte und Flash-Animationen) und dann auf einen Schlag ausgegeben. Klappt nach meinen Tests mit NN4, NN7, MSIE6, Opera 7 und Mozilla 1.3. Läuft auf meinem Puretec-Webspace einwandfrei, ebenso auf meinem WAMP, aber (und jetzt kommt etwas völlig Unerklärliches):
auf dem LAMP-Server eines Kollegen unter Apache/1.3.26 erscheint ein 403 (forbidden).

Gibt es hier einen Apache-Experten, der sich das erklären kann? Ich sehe da nur clientseitiges Scripting (oder bin ich blind?), was kann denn da der Server gegen haben??

Vielen Dank,
giacomo
giacomo
 
Posts: 5
Joined: 15. July 2003 23:30

Postby Oswald » 16. July 2003 07:57

Huhu giacomo,

haben die Dateien auf dem Server dir richtigen Zugriffsrechte? Schau doch mal bei Deinem Kollegen in die error_log um die genau Ursache für den 403 zu finden.

Und ja, Du hast recht: Java-Skript ist etwas absolut clientmäßiges und hat mit dem Server nichts zu tun. Aber der Feher 403 ist ein Serverfehler, also ist da auch die Ursache zu finden.

Liebe Grüße,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby giacomo » 16. July 2003 08:47

Kai Seidler wrote:Huhu giacomo,

haben die Dateien auf dem Server dir richtigen Zugriffsrechte?


Hallo Oswald,
erstmal vielen Dank für Deine schnelle Antwort. Aber welche Zugriffsrechte meinst Du? Wo muss ich da gucken??

Gruß von
giacomo
giacomo
 
Posts: 5
Joined: 15. July 2003 23:30

Postby Oswald » 16. July 2003 09:05

Huhu giacomo!

Okay, das mit den Zugriffsrechten ist 'ne längere Geschichte. Lassen wir das zunächst. ;)

Fangen wir anders an: Welches Linux benutzt Dein Kollege?

Gruß,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby giacomo » 22. July 2003 09:29

Sorry, ich war ein paar Tage weg.

Er benutzt Suse Linux 7.x und den Apache 1.3.26

Gruß
giacomo
giacomo
 
Posts: 5
Joined: 15. July 2003 23:30

Postby Oswald » 22. July 2003 09:32

Moin giacomo!

Also: Greif bitte mal bei Deimem Kollegen auf den Webserver zu und erzeuge so den 403-Fehler. Gleich danach ruf mal auf dem Linux-System folgenden Befehl auf:

tail /var/log/httpd/error_log

Dort müsste nun mind. eine Fehlermeldung angezeigt werden. Was steht da alles?

Liebe Grüße,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby mango » 23. July 2003 22:04

Hallo ich hab den gleichen Fehler nur dass ich mein Apache mit winXP betreibe in meinem error-log steht folgendes
[Wed Jul 23 23:03:56 2003] [error] [client 127.0.0.1] (20025)Error string not specified yet: access to /php/php.exe/phpinfo.php failed, referer: http://localhost
[Wed Jul 23 23:05:00 2003] [error] [client 127.0.0.1] (20025)Error string not specified yet: access to /php/php.exe/phpinfo.php failed, referer: http://localhost

Und wenn ich auf ein .php file will zugreiffen ( denn der Fehler 403 kommt nur bei den PHP files steht das hier:
Forbidden
You don't have permission to access /php/php.exe/phpinfo.php on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.


--------------------------------------------------------------------------------

Apache/2.0.46 (Win32) Server at localhost Port 80

Wieso hab ich keine Rechte php files öffnen zu können????
PS: Schreibschutz is deaktiviert in allen Verzeichnissen.
mango
 
Posts: 42
Joined: 29. June 2003 20:44

Postby giacomo » 24. July 2003 01:17

Und was will uns das sagen???

Gruß,
giacomo
giacomo
 
Posts: 5
Joined: 15. July 2003 23:30

Postby mango » 24. July 2003 07:05

Das soll bedeuten, dass ich mit meinem Apachen (lokal installiert=localhost) keine .php seiten anzeigen lässt.
Obwohl ich php installiert und in die httpd.conf eingebunden hab!!
Wie schon gesagt ist die Fehlermeldung welche angezeigt wird beim versuch ne php Seite zu öffnen:
Forbidden
You don't have permission to access /php/php.exe/phpinfo.php on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.


Bitte um hilfeee
mango
mango
 
Posts: 42
Joined: 29. June 2003 20:44

Postby Oswald » 24. July 2003 10:36

Huhu giacomo!

Hast Du mal in die Logdatei bei Deinem Kollegen geguckt?

Gruß,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby giacomo » 24. July 2003 10:49

Huhu Oswald!

Kollege ist gerade ein paar Tge verreist. Aber ich bleibe dran! Sobald er zurück ist geht's weiter!

Gruß,
giacomo
giacomo
 
Posts: 5
Joined: 15. July 2003 23:30

Postby mango » 25. July 2003 12:55

Also mein Problem hat sich gelöst
Ich hatte einen Schreibfehler in der httpd.conf

MFG
mango
mango
 
Posts: 42
Joined: 29. June 2003 20:44


Return to Apache

Who is online

Users browsing this forum: No registered users and 9 guests