Dummie braucht hilfe

Alles, was den Apache betrifft, kann hier besprochen werden.

Dummie braucht hilfe

Postby manuela » 13. July 2003 22:46

Hi,

folgende frage
habe auf meinem server

PHP Version 4.3.1
und brauche GD für ein script
nun zeigt mir mein info.php das GD installiert ist
es funktioniert aber nicht
bekomme immer den error
PHP running on your server does not support the GD image library

was ist falsch und wie macht man oder frau es richtig

bin leider ein totaler Anfänger in diesen Dingen


Besten Dank
manuela
 

Postby Oswald » 13. July 2003 22:59

Ahoi!

Was zeigt Dir phpinfo() bzgl. GD genau an? Kannst Du bitte den GD-Part aus phpinfo() hier mal zitieren?

Gruß,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby Guest » 13. July 2003 23:03

von info.php

gd
GD Support enabled
GD Version bundled (2.0 compatible)
GIF Read Support enabled
PNG Support enabled
WBMP Support enabled
Guest
 

Postby Guest » 13. July 2003 23:07

vielleicht habe ich mich falsch ausgedrückt
ich brauche GD library
ist das ein zusatzmodul oder so?
Guest
 

Postby Guest » 13. July 2003 23:11

Hallo

Habe es auch schon mit Image Magic probiert
installiert nach diesen anweisungen
http://www.photopost.com/howtoinstall-php.html

wenn ich sage find / -name convert
bekomme ich diesen pfad
/usr/local/bin/convert

wenn ich diesen im install.php einsetze
bekomme ich diesen error

Warning: is_dir() [function.is-dir]: Stat failed for /usr/local/bin/convert/ (errno=20 - Not a directory) in /usr/home/abster/html/mydomain/copp/install.php on line 76


eines von den beiden GD oder Image Magik bräuchte ich

Danke
Guest
 

Postby Oswald » 13. July 2003 23:14

Nein, Du hast Dich nicht falsch ausgedrückt.

Du brauchst GD und - wie man sieht - hast es auch schon.

Okay also weiter. Die Meldung "PHP running on your server does not support the GD image library" kann demnach nicht von Deinem PHP kommen. Also kann es nur von dem Programm kommen, dass Du da laufen lassen willst. Scheinbar meint das Programm GD wäre nicht da, obwohl es eben doch da ist.

Welches Programm willst Du laufen lassen?

Gruß,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby Guest » 13. July 2003 23:19

Coppermine Photo Gallery

habe ich auch schon installiert
kann aber keine Bilder hochladen ohne GD oder Image Magic
Guest
 

Postby Oswald » 13. July 2003 23:35

Was zeigt die Coppermine beim Punkt "Method for resizing images" unter "Config" an? Steht ziemlich am Ende der Seite. Dort sollte stehen "GD version 2.x".

Daran denken, dass Du nur JPEGs und PNGs hochladen kannst.

Gruß,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby Guest » 13. July 2003 23:50

Method for resizing images GD version2.x
habe ich mit jpg propiert error GD not supported

jetzt mit png und habe folgenen error bekommen
No picture was uploaded !

If you have really selected a picture to upload, check that the server allows file uploads...


info.php zeigt mir

file_uploads on
Guest
 

Postby Guest » 14. July 2003 00:52

Hallo Oswald,

Besten Dank für Deine Hilfe habe es nun mit Image Magic
zum Laufen gebracht
weis zwar nicht wie aber es funktioniert jetzt

nocheinmal vielen Dank

Gruß
manuela
Guest
 


Return to Apache

Who is online

Users browsing this forum: No registered users and 5 guests