Virtual Hosts | 403 Fehler | Windowsberechtigung???

Alles, was den Apache betrifft, kann hier besprochen werden.

Virtual Hosts | 403 Fehler | Windowsberechtigung???

Postby SebHoff » 13. March 2006 05:18

Hallo.

Ich hab schon viel über VHosts hier gelesen, und je mehr ich gelesen hatte, desto ärgerlicher find ich es, dass es nun wieder wen gibt (mich) der euch mit diesem Problem nervt, jedoch habe ich (zumindest in den ersten 5 Seiten der Suche) keine Antwort gefunden, dass mein Problem lösen hat können, oder ich habe was falsch gemacht.

Folgendes Szenario.

Apache/2.0.55 (Win32) PHP/5.1.2 Server läuft gut und stabil.
2 VHosts sind eingerichtet und man kann sie auch ansteuern:

    #NameVirtualHost 127.0.0.1

    <VirtualHost *:80>
    ServerAdmin blubb@blubb.de
    ServerName sebhoff
    DocumentRoot "D:/Apache Group/Apache2/htdocs"
    ErrorLog "D:/Apache Group/Apache2/htdocs/logs/error_log"
    </VirtualHost>

    <VirtualHost *:123>
    ServerAdmin blubb@blubb.com
    ServerName intern.sebhoff
    DocumentRoot "E:/Daten"
    ErrorLog "D:/Apache Group/Apache2/htdocs/logs/error_log"
    </VirtualHost>

Der Sinn und Zweck soll sein, das Besucher von Außen, die den definierten Port nicht kennen nicht in mein Daten Verzeichniss komme, wo meine Testecke für Scripts / etc ist.... Zudem soll später dann noch per .htaccess ein PW Schutz rein, aber das ist hier nicht Thema.

Verschieben kann und möchte ich das Daten Verzeichniss auch nicht, weil ich es schon zusehr in Windows eingbunden habe, und Programme und Umgebungsvariablen darauf zugreifen (Der Speicherplatz auf C: wurde knapp :? )

Weil ich nicht alleine an dem Computer arbeite habe ich direkt mal die Sicherheitsrechte nur für mich angepasst.

Wenn ich nun eingebe http://sebhoff bekomme ich die Apache Willkommensseite, was auch alles so richtig ist, wo auch später anderer Inhalt für die da draußen hinkommt. Bei http://sebhoff:123 wirds zwar auch angesprochen, dort bekomme ich aber einen 403 Fehler.

Meine Vermutung wäre, dass ich wegen den Sicherheitseinstellungen für die Ordner nicht per Browser darauf zugreifen kann. Ich habe aber shcon versucht, die Sicherheitsberechtigungen für "DIENSTE" auch zu aktivieren, bekomme aber den gleichen Fehler. Nach ein wenig herumprobieren mit anderen Ordnern hab ich festgestellt, dass ich nix anderes als die ursprünlgihce DocumentRoot nehmen kann. Wenn ich diese Zeilen für die Generelle DocRoot (oben) kommentiere, startet Apache nicht mehr. Kann es sein, dass der general DocRoot dem VHost dennoch übergeordnet ist ?

Welche Einstellungen müsste ich übernehmen damit das ganze funktioniert. Mit .../htdocs als Doc Root funktioniert der 2.VHost ja auch, bringt mir aber nix.


mfg - SebHoff

[/list]

"Mit dem Rücken zur Wand ist nach vorne alles frei...."
SebHoff
 
Posts: 2
Joined: 13. March 2006 04:28

Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests