Apache error.log entschlüsseln

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache error.log entschlüsseln

Postby Icke » 09. July 2003 09:44

Hallo,

also ich versuche den apache 2 für einen Internetshop zu konfigurieren. Es sind daten im Format .cgi vorhanden.
Meine Antwort vom Server in der error.log geht von "Sie dürfen diese nicht ausführen" obwohl ich das im Directory mit execcgi erlaubt habe.
Nun sagt er:

[Wed Jul 09 10:49:14 2003] [error] [client 127.0.0.1] (OS 3)Das System kann den angegebenen Pfad nicht finden. : couldn't spawn child process: C:/Programme/Apache Group/Apache2/cgi-bin/index.cgi, referer: http://127.0.0.1/
[Wed Jul 09 10:49:24 2003] [error] [client 127.0.0.1] File does not exist: C:/Programme/Apache Group/Apache2/htdocs/index.cgi
[Wed Jul 09 10:49:40 2003] [error] [client 127.0.0.1] (OS 3)Das System kann den angegebenen Pfad nicht finden. : couldn't create child process: 720003: index.cgi, referer: http://127.0.0.1/
[Wed Jul 09 10:49:40 2003] [error] [client 127.0.0.1] (OS 3)Das System kann den angegebenen Pfad nicht finden. : couldn't spawn child process: C:/Programme/Apache Group/Apache2/cgi-bin/index.cgi, referer: http://127.0.0.1/

obwohl die Datei index.cgi im cgi-bin liegt. ????
Was mache ich denn falsch??

MfG und danke für eure Zeit

Icke
Icke
 

Postby Oswald » 09. July 2003 09:53

Huhu Icke,

kannst Du bitte mal die erste Zeile der index.cgi hier posten?

Ich geh mal davon aus, dass C:/Programme/Apache Group/Apache2/cgi-bin/index.cgi auch existiert?

Gruß,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

kann ick schon

Postby Icke » 09. July 2003 10:04

#!/usr/bin/perl

require "init.pm";
&GetParam;

&documentheaderlong;

if ($warenkorb_datei eq "")
{
&PrintIndexOP;
}
if ($warenkorb_datei eq "1")

so sehe ich das jetz wenn ich die seite anklicke. er findet sie jetz aber zeigt mir den quelltext.

mfg

icke
Icke
 

Postby Oswald » 09. July 2003 10:07

Huhu Icke,

alles klar! ;)

Hast Du auf Deinem System auch Perl installiert? Dein CGI braucht Perl und die erste Zeile musst Du etwa so anpassen:

#!C:\Perl\perl.exe

Bzw entsprechend Deiner Perl-Installation und wo bei Dir die perl.exe-Datei liegt.

Liebe Grüße,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

so isses jetz

Postby Icke » 09. July 2003 10:07

also habe ein neues verzeichniss erstellt und nun siehts so in dem root und script verzeichniss aus.

<Directory "d:/shop">
Options FollowSymLinks Indexes Includes ExecCGI MultiViews
AllowOverride None
Order allow,deny
Allow from all
</Directory>

und ???????
Icke
 

ach so

Postby icke » 09. July 2003 10:09

ach deswegen stieß ich immer auf perl wenn ich nach cgi suchte!!!
mhm dann müsste die datei perl exe aber auch doert sein wie angegeben oder?
ist das nicht bestandteil des apache?
icke
 

Postby Oswald » 09. July 2003 10:16

Richtig, Perl ist nicht im Apache enthalten und muss extra installiert werden.

#!/usr/bin/perl

Ist die Unix-Variante. So würde es z. B. unter Linux funktionieren. Aber unter Windows natürlich überhaupt nicht.

Wenn Du Perl bei Dir installlierst, dann musst Du auf alle Fälle auch noch mal alle CGI-Dateien ändern und am Anfang den richtigen Pfad eintragen. An Deiner Stelle würd ich aber vorher mach überprüfen ob Dein Shopsystem überhaupt unter Windows funktoniert. Es scheint ja erst mal eine Unix-Software zu sein.

Gruß,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby icke » 09. July 2003 10:20

äh, na das is ja nich gleich hoffnung machen. :-)
ok ich werde es prüfen wo er mir die erste zeile erstellt und das einträgt mit dem falschen pfad.
wie kann ich denn perl installieren für windows?
ich habe seiten gefunden aber die bieten mir eine perl mod datei an.
aber ich danke dir für die hilfe das war wenigstens mal eindeutig für mich verständlich.

danke

alkor
icke
 

Postby Oswald » 09. July 2003 10:26

Da hast Du zwei Möglichkeiten:

a) Du benutzt unser WAMPP. Da sind Apache, Perl, MySQL, PHP und andere Kleinigkeiten drin.

oder

b) Du lädst Dir zum Beispiel Perl einzeln von ActivePerl runter: http://www.activestate.com/Products/ActivePerl/

Auf alle Fälle viel Erfolg!

Liebe Grüße,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

DANKE

Postby Icke » 09. July 2003 10:36

Also Danke nochmals, ich entscheide mich für WAMPP ist im Download.
Dann werde ich wohl weiter kommen.

Vielen Dank und Schönen Tag wünsche ich.

Alkor Beer :D
Icke
 

äh

Postby Icke » 09. July 2003 11:42

Tja soweit kam ich dann doch nich, wa.
Also habe die Zeile geändert aber jetzt gint er diese Meldung.

Serverfehler!
Die Anfrage kann nicht beantwortet werden, da im Server ein interner Fehler aufgetreten ist.

Fehlermeldung:
couldn't create child process: 720003: index.cgi

Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber.

Error 500
127.0.0.1
09.07.2003 12:52:36
Apache/2.0.46 (Win32) mod_perl/1.99_10-dev Perl/v5.8.0 PHP/4.3.2 mod_ssl/2.0.46 OpenSSL/0.9.7b


Was ist denn das "create child process"?
Die Verzeichnisse sind doch die im Wampp\htdocs für die html und bin-cgi für die cgi daten oder?

Danke im voraus.
Icke
 

Postby Oswald » 09. July 2003 12:03

Was hast Du in der ersten Zeile der index.cgi stehen?
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux


Return to Apache

Who is online

Users browsing this forum: No registered users and 6 guests