Vom regen in die Traufe - .htaccess und Passwortschutz

Alles, was den Apache betrifft, kann hier besprochen werden.

Vom regen in die Traufe - .htaccess und Passwortschutz

Postby TConnect » 17. February 2006 09:57

Hallo zusammen,

da in einer älteren Version von XAMPP das PHP Modul mcrypt nicht funktioniert hat, habe ich mir gestern die neueste Version des XAMPP aus dem Netz gezogen und installiert. Nach der Auskommentierung des entsprechenden Moduls in der (richtigen) php.ini hat dies zumindestens vernünftig funktioniert.

ABER: Jetzt funktioniert nirgendwo mehr mein Passwortschutz der Verzeichnisse innerhalb des DocumentRoot des Apache. Ich hatte zwei Verzeichnisse schützen lassen und da beide Verzeichnisse von den selben Benutzern verwendet werden dürfen, liegt in beiden Verzeichnissen eine .htaccess mit dem dem Verweis auf eine .htpasswd Datei. Letztere liegt zentral außerhalb des DocRoot.

Der Inhalt der beiden Dateien ist:

AuthUserFile E:/000_apacheroot/.htpasswd
AuthName "Meine interna"
AuthType Basic

<Limit POST GET>
require user Schlumpf
</Limit>


Da ich den XAMPP ja neu installiert habe, mußte ich ja letztlich nur meine beiden zu schützenden Verzeichnisse komplett kopieren. Die .htpasswd hat sich ja nicht bewegt. Deswegen war ich davon ausgegangen, dass nach der Neuinstallation des XAMPP der Verzeichnisschutz unmittelbar wieder besteht. Warum ist das jetzt nicht so?

PS: Ich hab mal in der alten httpd.conf Datei nach dem Stichwort "AccessFileName" suchen lassen. Dies ist in der neuen httpd.conf gar nicht vorhanden. Das Umkopieren der Direktiven:

AccessFileName .htaccess
<Files ~ "^\.ht">
Order allow,deny
Deny from all
</Files>


in die neue httpd.conf und ein anschließender fehlerfreier Neustart hat aber nix gebracht.

Wie gehe ich jetzt vor?

Grüße
TConnect
TConnect
 
Posts: 100
Joined: 31. March 2004 22:26

Postby Wiedmann » 17. February 2006 11:03

Wie gehe ich jetzt vor?

Die Suchfunktion des Forums benutzen? ...


(Für das htdocs-Verzeichnis wurde AllowOverride auf None anstatt On konfiguriert.)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Suchfunktion in allen Ehren

Postby TConnect » 17. February 2006 11:35

Hallo Wiedmann,

erst einmal herzlichen Dank für Deinen Hinweis. Du hast Recht, im zweiten oder dritten Match bei der Suche mit dem Stichwort ".htpasswd" hast Du die Lösung schon einmal aufgeführt. Ich war aber so fixiert auf die Einstellungen zu "AccessFileName", dass ich gar nicht daran gedacht habe, dass das Problem ganz woanders liegen könnte.

Warum ist denn eigentlich der Eintrag AccessFileName in der neuen Apache Version (des aktuellsten XAMPP) nicht mehr in der conf vorhanden?

Grüße
TConnect
TConnect
 
Posts: 100
Joined: 31. March 2004 22:26

Postby Wiedmann » 17. February 2006 14:55

Warum ist denn eigentlich der Eintrag AccessFileName in der neuen Apache Version (des aktuellsten XAMPP) nicht mehr in der conf vorhanden?

Weil er unnötig ist, wenn man diese Datei ".htaccess" nennt (ist der Defaultwert) --> siehe Apache-Manual
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Na dann erst einmal danke

Postby TConnect » 22. February 2006 10:41

Danke für Deine Hilfe.

Liebe Grüße
TConnect
TConnect
 
Posts: 100
Joined: 31. March 2004 22:26


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests