Virtual Host oder Directory oder wie?

Alles, was den Apache betrifft, kann hier besprochen werden.

Virtual Host oder Directory oder wie?

Postby umbertones » 12. February 2006 23:38

Hi,

ich habe einen Rechner mit Apache auf Port 80 laufen. Nur dieser Port ist von aussen auch sichtbar (Router).

Auf dem Rechner läuft noch ein anderer Webserver auf einem anderen Port.

Ich möchte jetzt den Apache so konfigurieren, daß bei

http://server.url/andererserver

der Apache vom Port 80 die Website von dem anderen Server anzeigt.

Redirect geht nicht, weil der andere Port ja nach draussen nicht sichtbar ist.

Im Prinzip müßte es mit Virtual Host und Proxy gehen, aber wie gebe ich da ein Directory an? Ich steh' auf der Leitung.

Vielen Dank im voraus für alle Tips!

Umbi
umbertones
 
Posts: 3
Joined: 12. February 2006 23:31
Location: Böblingen

Postby KingCrunch » 13. February 2006 07:05

Ich denke, das wird so net funktionieren, da er immer versucht den zweiten Server irgendwie mit dem Client zu verbinden. Entweder gibste dann den anderen Port auf frei, oder aber du schreibt (zB in PHP oder einer Sprache deiner Wahl) eine Art Relay: Ein Script, was die Ausgabe des anderen Servers abfängt und dies an den Client weiter leitet.
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Postby Wiedmann » 13. February 2006 11:55

Ich möchte jetzt den Apache so konfigurieren, daß bei
http://server.url/andererserver
der Apache vom Port 80 die Website von dem anderen Server anzeigt.

"ProxyPass" und "ProxyPassReverse" ist dein Freund.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby KingCrunch » 13. February 2006 13:00

*merk* :)
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Grosser Schritt....

Postby umbertones » 13. February 2006 21:59

Wiedmann wrote:"ProxyPass" und "ProxyPassReverse" ist dein Freund.


Danke erstmal, wenn man weiss, wo man suchen muss, ist es gleich viel einfacher. :-)

Die "Umleitung" funktioniert, aber die Bilder vom umgeleiteten Server fehlen. Mouseover-Effekte funktionieren aber...hmmm.
Wenn ich "Grafik anzeigen" wähle, kommt ein 400er Bad Request.

Wenn ich auf einen Link clicke, springt er auf die index.html...

Vermutlich läßt sich die Seite nicht so einfach "reversen".

Gruss
Umbi
umbertones
 
Posts: 3
Joined: 12. February 2006 23:31
Location: Böblingen

Re: Grosser Schritt....

Postby umbertones » 14. February 2006 23:08

umbertones wrote:Die "Umleitung" funktioniert, aber die Bilder vom umgeleiteten Server fehlen. Mouseover-Effekte funktionieren aber...hmmm.


Ok, das war mein Fehler mit dem fehlenden "trailing slash" bei den ProxyPass-Direktiven in der httpd.conf

umbertones wrote:Wenn ich auf einen Link clicke, springt er auf die index.html...


Das ist aber komisch! Manche Links werden richtig umgesetzt und manche nicht, obwohl die sich teilweise nur um Zeichen unterscheiden.

Was kann denn das sein?

Vielen Dank im voraus!

MfG
Umbi
umbertones
 
Posts: 3
Joined: 12. February 2006 23:31
Location: Böblingen


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests

cron