Apache2 + Virtual Host. Ich dreh durch.

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache2 + Virtual Host. Ich dreh durch.

Postby bene » 10. February 2006 13:06

Ich habe gerade mal ein Problem. Ich habe hier nen sauberen Debian 3.1 Webserver aufgesetzt aber nun wegen webEdition ein Problem. Ich habe im /var/www zwei ordner fischerappelt und ligalux. Nun muss ich die aber zum Doc root machen, damit ich das dumme CMS installieren kann. Ich habe nun am Ende von der datei "default" in sites-availible im /etc/apache2 Ordner folgendes reingeschrieben.

<VirtualHost www.cccccc.de>
ServerName www.cccccc.de
ServerAdmin bc@ccccccc.de
DocumentRoot /var/www/ccccccc
ErrorLog logs/error_log
CustomLog logs/access_log common
</VirtualHost>

<VirtualHost www.bbbbb.de>
ServerName www.bbbbb.de
ServerAdmin bc@bbbbbb.de
DocumentRoot /var/www/bbbbbb
ErrorLog logs/error_log
CustomLog logs/access_log common
</VirtualHost>

Bekomme beim start nun aber das Problem:

tkweb:/home/bene# /etc/init.d/apache2 start

Starting web server: Apache2[Fri Feb 10 13:07:05 2006] [warn] VirtualHost www.fischerappelt.de:0 overlaps with VirtualHost www.ligalux.de:0, the first has precedence, perhaps you need a NameVirtualHost directive

tkweb:/home/bene#


Die default sieht so komplett aus:

NameVirtualHost *
<VirtualHost *>
ServerAdmin webmaster@localhost

DocumentRoot /var/www/
<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>
<Directory /var/www/>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
# This directive allows us to have apache2's default start page
# in /apache2-default/, but still have / go to the right place
RedirectMatch ^/$ /apache2-default/
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
AllowOverride None
Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>

ErrorLog /var/log/apache2/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog /var/log/apache2/access.log combined
ServerSignature On

Alias /doc/ "/usr/share/doc/"
<Directory "/usr/share/doc/">
Options Indexes MultiViews FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
Allow from 127.0.0.0/255.0.0.0 ::1/128
</Directory>

</VirtualHost>

<VirtualHost www.cccccc.de>
ServerName www.cccccc.de
ServerAdmin bc@ccccccc.de
DocumentRoot /var/www/ccccccc
ErrorLog logs/error_log
CustomLog logs/access_log common
</VirtualHost>

<VirtualHost www.bbbbb.de>
ServerName www.bbbbb.de
ServerAdmin bc@bbbbbb.de
DocumentRoot /var/www/bbbbbb
ErrorLog logs/error_log
CustomLog logs/access_log common
</VirtualHost>
bene
 
Posts: 5
Joined: 10. February 2006 13:02

Postby Wiedmann » 10. February 2006 13:14

Code: Select all
NameVirtualHost *
<VirtualHost *>
ServerAdmin webmaster@localhost

DocumentRoot /var/www/
<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>
<Directory /var/www/>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
# This directive allows us to have apache2's default start page
# in /apache2-default/, but still have / go to the right place
RedirectMatch ^/$ /apache2-default/
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
AllowOverride None
Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>

ErrorLog /var/log/apache2/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog /var/log/apache2/access.log combined
ServerSignature On

Alias /doc/ "/usr/share/doc/"
<Directory "/usr/share/doc/">
Options Indexes MultiViews FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
Allow from 127.0.0.0/255.0.0.0 ::1/128
</Directory>

</VirtualHost>

<VirtualHost www.cccccc.de>
ServerName www.cccccc.de
ServerAdmin bc@ccccccc.de
DocumentRoot /var/www/ccccccc
ErrorLog logs/error_log
CustomLog logs/access_log common
</VirtualHost>

<VirtualHost www.bbbbb.de>
ServerName www.bbbbb.de
ServerAdmin bc@bbbbbb.de
DocumentRoot /var/www/bbbbbb
ErrorLog logs/error_log
CustomLog logs/access_log common
</VirtualHost>

Du musst das bei deinen VHosts nur genauso machen wie es schon für den ersten VHost vorgemacht wurde:
anstatt: "<VirtualHost www.bbbbb.de>"
dieses: "<VirtualHost *>"
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby bene » 10. February 2006 13:20

Das Problem ist dann aber, das der Apache nicht startet.
bene
 
Posts: 5
Joined: 10. February 2006 13:02

Postby KingCrunch » 10. February 2006 13:29

Soweit ich das erkenne, weil dann der VirtualHost doppelt definiert wird.
Das System muss scho über verschiedene Hosts verfügen, die dann auch entsprechend in der Hosts eingetragen sein müss(t)en. Oder natürlich du legst es auf einen anderen Port, geht auch sehr gut
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Postby bene » 10. February 2006 13:31

Es muss aber doch möglich sein mehrere anzulegen bei nur einer IP
bene
 
Posts: 5
Joined: 10. February 2006 13:02

Postby Wiedmann » 10. February 2006 14:12

Das Problem ist dann aber, das der Apache nicht startet.

Bei welcher genauen Config startet er dann mit welcher genauen Fehlermeldung nicht?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby bene » 10. February 2006 15:01

Also ich habe es nun komplett anderst gemacht. Die default in sites-availible bleibt im original. Dann habe ich nun 2 Dateien erstellt.

NameVirtualHost *:80

<VirtualHost *:80>
ServerName www.cccc.de
ServerAlias www.ccccc.de *.cccc.de
DocumentRoot /var/www/ccccc
ErrorLog logs/error_log
CustomLog logs/access_log common
</VirtualHost>


und das ganze mit einer zweiten domain. Da habe ich nun schon mal das problem, das der apache nicht starten will da er sagt:

tkweb:/etc/apache2/sites-enabled# /etc/init.d/apache2 start
Starting web server: Apache2[Fri Feb 10 15:59:30 2006] [warn] NameVirtualHost *:80 has no VirtualHosts

die beiden dateien liegen im availible und ein link im enable
bene
 
Posts: 5
Joined: 10. February 2006 13:02

Postby bene » 10. February 2006 15:10

schritt weiter.

So beide dateien sehen nun so aus:

NameVirtualHost *:80

<VirtualHost *:80>
ServerName www.cccc.de
ServerAlias www.ccccc.de *.cccc.de
DocumentRoot /var/www/cccc
</VirtualHost>


wenn ich nun die ip aufrufe lande ich direkt im cccc ordner. und er erkennt das root nur vvvv komme ich ja nun nicht dran. die domains selber kann ich ja noch nicht umziehen =( geht das irgendwie zu trixen mit Diretory Alias oder sowas?
_________________
bene
 
Posts: 5
Joined: 10. February 2006 13:02


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests