generell die eigene website anzeigen lassen

Alles, was den Apache betrifft, kann hier besprochen werden.

generell die eigene website anzeigen lassen

Postby -buTch- » 04. July 2003 08:52

Hallo !
ich habe jetzt schon öfters versucht einfach meine website unter localhost zu sehen, geht aber nicht..also, man kann doch in der httpd.conf unter diesem eintrag
<Directory "C:/apache/Apache2/intranet/">

einfach festlegen wo die website ist. Nachdem ich das geamcht habe zeigt mein Browser nur den Inhalt des Ordners, ich möchte aber das die index.htm geht !

deswegen habe ich es mal so versucht
<Directory "C:/apache/Apache2/intranet/index.htm">

aber dann kommt

Forbidden
You don't have permission to access / on this server.

kann mir bitte jemand weiterhelfen ? ich verzweifle bald..

btw. ich teste das ganze local ! also im browser steht dann http://localhost/ ....

ps. wie kann man generell die berechtigungen für eine Datei festlegen ?

[/b][/i]
-buTch-
 
Posts: 4
Joined: 03. July 2003 15:05

Postby Kristian Marcroft » 04. July 2003 09:03

Hi,

ich hab jetzt einfach mal in die httpd.conf geschaut und folgendes gefunden was:
<Directory "/wampp2c/phpMyAdmin/">
Options Indexes MultiViews ExecCGI
DirectoryIndex index.php
Order allow,deny
Allow from all
</Directory>


Ich würde das mal anpassen und dann schaun ob es geht?
ggf. index.htm in index.html umbenennen?

Achja dein erster Directory war wohl das "richtigere" :)

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby -buTch- » 04. July 2003 10:04

Hi KriS,

danke für dein Hilfe, aber diese Zeilen konnte ich nicht bei mir finden.. ich muss auch dazu sagen, dass ich nicht das wamp2 packet installiert habe, sondern nur Apache2 und acktive perl.....

ich habe aber in der httpd ähnlichen gefunden:
Code: Select all
<Directory "C:/apache/Apache2/manual">
    Options Indexes FollowSymLinks MultiViews IncludesNoExec
    AddOutputFilter Includes html
    AllowOverride None
    Order allow,deny
    Allow from all
</Directory>


dort habe ich die zeile eingetagen, die du meintest, hat aber nichts gebracht.

Was mir noch aufgefallen ist:
Code: Select all
Alias /manual "C:/apache/Apache2/manual"

<Directory "C:/apache/Apache2/manual">
    Options Indexes FollowSymLinks MultiViews IncludesNoExec
    AddOutputFilter Includes html
    AllowOverride None

    Order allow,deny
    Allow from all
</Directory>


muss ich da auch den pfad ändern ?
wenn ich es mache, hab ich ebenfalls wieder die gleiche fehlermeldung :-/


es kann doch nicht so schwer sein, dass der apache meine site aufmacht..
help :/
-buTch-
 
Posts: 4
Joined: 03. July 2003 15:05

Postby -buTch- » 07. July 2003 11:05

ich habe es selbst rausbekommen
so muss es aussehen das es klappt
Code: Select all
<Directory "C:/wamp/wamp2/intranet">
    Options Indexes FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all

</Directory>
DirectoryIndex index.html index.htm
-buTch-
 
Posts: 4
Joined: 03. July 2003 15:05


Return to Apache

Who is online

Users browsing this forum: No registered users and 8 guests