mod_rewrite Problem

Alles, was den Apache betrifft, kann hier besprochen werden.

mod_rewrite Problem

Postby Manfred Kooistra » 02. February 2006 23:34

Ich versuche Besucher meiner Seite aufgrund der im Accept Language Header übermittelten Spracheinstellung des Browsers in unterschiedliche Unterverzeichnisse umzuleiten. Dafür habe ich eine .htaccess mit diesem Inhalt erstellt:

RewriteEngine On

RewriteCond %{HTTP_ACCEPT_LANGUAGE} ^de [NC]
RewriteRule ^/ http://www.domain.com/de/ [L,R=301]

RewriteCond %{HTTP_ACCEPT_LANGUAGE} ^en [NC]
RewriteRule ^/ http://www.domain.com/en/ [L,R=301]

RewriteRule ^/ http://www.domain.com/no/ [L,R=301]

Nun lande ich immer im Verzeichnis ../no . Versteht RewriteCond die Variable HTTP_ACCEPT_LANGUAGE nicht, oder mache ich einen anderen Fehler?

(Ja, ich weiß schon, daß ich die Besucher auch über AddLanguage usw. auf unterschiedliche Dokumente umleiten kann, aber ich will sie in Unterverzeichnisse bekommen.)
Manfred Kooistra
 
Posts: 3
Joined: 02. February 2006 23:14
Location: Reutlingen

Postby KingCrunch » 02. February 2006 23:48

ModRwrite.info
Versuchs ma mit ACCEPT, kann aber auch sein, dass das was ganz anderes is ;)
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Postby Manfred Kooistra » 02. February 2006 23:56

KingCrunch wrote:ModRwrite.info
Versuchs ma mit ACCEPT, kann aber auch sein, dass das was ganz anderes is ;)


HTTP_ACCEPT enthält den MIME Typ (z.B. text/html) aber keine Information zur Sprache.

Die Dokumentation zu mod_rewrite nennt nur HTTP_ACCEPT, aber über Google finde ich einige Beispiele mit HTTP_ACCEPT_LANGUAGE - haben sich die Verfasser dieser Beiträge alle geirrt?
Manfred Kooistra
 
Posts: 3
Joined: 02. February 2006 23:14
Location: Reutlingen

Postby KingCrunch » 02. February 2006 23:59

Ich bin mir nicht sicher, aber ist es nicht auch möglich, dass der Client (Browser) die Sprache nicht mitsendet?
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Postby Manfred Kooistra » 03. February 2006 00:04

KingCrunch wrote:Ich bin mir nicht sicher, aber ist es nicht auch möglich, dass der Client (Browser) die Sprache nicht mitsendet?


Ja, wäre möglich, dafür ist ja die letzte Direktive, aber meiner sendet die Sprache mit (ich habe das überprüft: www.scanmybrowser.com).
Manfred Kooistra
 
Posts: 3
Joined: 02. February 2006 23:14
Location: Reutlingen


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests

cron