httpd.conf Syntaxfehler, Neustart trotzdem erfolgreich?

Alles, was den Apache betrifft, kann hier besprochen werden.

httpd.conf Syntaxfehler, Neustart trotzdem erfolgreich?

Postby Goldfisch » 31. January 2006 15:39

Hi,

Ich traue mich nicht mehr so recht, Apache neu zu starten, seit mir httpd -S einen Syntaxfehler meldet:
Syntax error on line 361 of /etc/httpd/conf/httpd.conf:
Invalid command 'Order', perhaps mis-spelled or defined by a module not included in the server configuration

Komischerweise steht in der Zeile nichts, was mir bedenklich vorkäme, sondern nur "Order allow,deny", was noch nie geändert wurde, und in der letzte nicht auskommentierten Zeile davor "AllowOverride FileInfo AuthConfig", was schon vor längerer Zeit geändert wurde.

Dies passiert erst, seit einige Änderungen (in ganz anderen Bereichen) in der httpd.conf vorgenommen wurden - allerdings wurden die wegen mangelnden Erfolgs angeblich wieder rückgängig gemacht bzw. durch die Backup-Version ersetzt.

Apache wurde seitdem zwar schon mehrmals erfolgreich neu gestartet, aber solange ich es nicht verstehe, will ich kein Risiko eingehen. Hat jemand einen Hinweis, der mich auf die richtige Spur bringt? Weitere Informationen liefere ich gern noch nach, ich wusste nur nicht, was noch wichtig sein könnte.

Grüße aus dem Goldfischteich (nein, ich bin gar kein Aquarianer)
Goldfisch
 
Posts: 2
Joined: 31. January 2006 14:10

Postby Wiedmann » 31. January 2006 16:31

Syntax error on line 361 of /etc/httpd/conf/httpd.conf:
Invalid command 'Order', perhaps mis-spelled or defined by a module not included in the server configuration

Damit der Apache diese Directive kennt, muss das Modul "mod_access" oder "mod_authz_host" geladen sein (je nach Apache-Version).

Findest du aber alles im dazugehörigen Apache-Manual.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Goldfisch » 01. February 2006 16:09

mod_access ist lt. httpd -l vorhanden. Das Problem tritt nun auch nicht mehr auf. Angeblich soll es an den Binärdateien gelegen haben, wo irgendetwas schief lief.

Trotzdem vielen Dank!
Goldfisch
 
Posts: 2
Joined: 31. January 2006 14:10


Return to Apache

Who is online

Users browsing this forum: No registered users and 5 guests