SSL nur eine Subdomain, sonst nicht.

Alles, was den Apache betrifft, kann hier besprochen werden.

SSL nur eine Subdomain, sonst nicht.

Postby Midhas » 26. January 2006 15:45

Hallo zusammen,

ich hab mir nen VServer im I-Net besorgt, kost' kaum was und ist für meine Zwecke mehr als gut geeignet...Darauf läuft im Moment ein Apache 2 und zusätzlich auch Confixx 3 Pro...

Jetzt will ich aber für eine Subdomain, nur für eine, eine SSL-Zertifizierung einrichten. Nicht für den ganzen Server oder alle Domains, sondern nur für diese eine Subdomain... Das Zertifikat erstellen und in Apache einrichten ist kein Problem... Was hakt ist HTTPS nur für die Subdomain zuzulassen.

Was ich gemacht habe:
Es exitiert ein Verzeichnis abc. Die Subdomain abc.def.de ist in das Verzeichnis gelegt. Alles mit Confixx erledigt. Da Confixx allerdings alle Einstellungen überschreibt, wenn neue Benutzereinstellungen gespeichert werden, kann ich also nicht an der /etc/apache2/confixx_vhosts/web0.conf rumbasteln, ohne die Einstellungen immer nachziehen oder alles ohne Confixx machen zu müssen. Also habe ich in der /etc/apache2/sites-available eine neue Seite angelegt:

<Virtualhost *:443>
ServerName abc.def.de

DocumentRoot /var/www/web0/html/abc

SSLEngine On
SSLCertificateFile ...
SSLCertificateKeyFile ...

...
</Virtualhost>

Was nun passiert ist folgendes und das habe ich auch bis jetzt nicht beändert bekommen. Obwohl der ServerName abc.def.de eingetragen ist... Gilt SSL/HTTPS für alle Anfragen, egal welche Domain, egal welche Subdomain. Auch ein :443 hinter den ServerName packen hat nichts geholfen... Rufe ich eine Domain mit HTTP auf, wird diese in das richtge Verzeichnis geleitet. Alle HTTPS-Aufrufe an unterschiedliche Domain gehen in Verzeichnis das als DocumentRoot angegeben ist... :-( Ich hab mir schon einen Wolf gesucht... Alles was ich gefunden ist, das es so anscheinend richtig ist...

Ich hoffe hier direkt an der Quelle des Apaches :-) Antwort zu finden. Danke im Voraus...

Gruß
Midhas
Midhas
 
Posts: 3
Joined: 26. January 2006 15:26

Postby deepsurfer » 26. January 2006 16:40

wenn ich mich jetzt nicht irre, müsste die ssl.conf editiert werden, und dort der VHOST der mit dem Zertifikat laufen soll eingetragen werden.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Midhas » 27. January 2006 08:54

:-( Leider nicht... Habe in der ssl.conf ein include auf meine Datei mit dem Virtualhost gemacht... Ein Apache-Restart brachte das gleiche Ergebnis: Jede Domain, jede Subdomain die mit HTTPS aufgerufen wird landet auf dem documentroot des virtuellen Hosts. :-(

<VirtualHost *:443>
ServerName web0.irgendwo.de
ServerAlias www.domain.de domain.de

DocumentRoot /var/www/web0/html/

<Directory /var/www/web0/html/>
Options +FollowSymLinks
AllowOverride All
Order allow,deny
Allow from all
</Directory>

ErrorLog /var/log/apache2/error.log

LogLevel warn

CustomLog /var/log/apache2/access.log combined
ServerSignature On

SSLEngine On
SSLCertificateFile /etc/apache2/ssl/www.domain.de.crt
SSLCertificateKeyFile /etc/apache2/ssl/www.domain.de.key

</VirtualHost>

Wenn ich https://www.domain.de aufrufe, funktioniert es. Wenn ich https://www.domain2.de aufrufe, die ich auch habe, funktioniert es auch, geht dann aber in das Documentroot-Dir von web0, siehe oben.

Wie gehts jetzt weiter ? Jemand eine Idee ?
Midhas
 
Posts: 3
Joined: 26. January 2006 15:26

Postby Midhas » 30. January 2006 07:49

:-( Hat hier denn auch keiner eine Antwort ?
Midhas
 
Posts: 3
Joined: 26. January 2006 15:26


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests