mod_auth_sspi

Alles, was den Apache betrifft, kann hier besprochen werden.

mod_auth_sspi

Postby nixwissa » 25. January 2006 09:39

Hallo,

seit ca. 4 Monaten verwenden wird in der Abteilung Subversion in Verbindung mit dem Apache Server als neues Versionierungssystem.

Um das Repository vor unerlaubten Zugriffen zu schützen habe ich die Authentifizierung mit mod_auth_sspi gegen das AD konfiguriert. Wenn der Benutzer authentifiziert und autorisiert ist, hat er lesenden bzw. schreibenden Zugriff auf das Repository.

Laut unserer Security Policy müssen bei der Passwortwahl mindestens drei der folgende Kriterien erfüllt werden:
min. 8 Zeichen
Groß Kleinschreibung
Alphanumerische Zeichen (Buchstaben und Zahlen)
Sonderzeichen
Passwort wird alle 3 Monate gewechselt.

Einer meiner Kollegen hat mit seinem neuen Passwort Probleme sich einzuloggen. Folgender Eintrag ist in der error.log zu finden:
(OS 1326)Logon failure: unknown user name or bad password. : user XXXXXXXX: authentication failure for

Da im Passwort Sonderzeichen vorkommen, frage ich mich ob mod_auth_sspi mit gewissen Zeichen z.B.: !,§,#,..... bzw. Umlauten Probleme hat.
Wäre toll wenn ihr mir weiterhelfen könnt.

OS: Windows XP SP2
Apache 2.0.54
mod_auth_sspi 1.0.3 für Apache 2.0.54

Danke im Voraus
Alex

Danke
nixwissa
 
Posts: 2
Joined: 25. January 2006 09:12

Postby deepsurfer » 25. January 2006 18:22

http://tortoisesvn.sourceforge.net/docs ... SVN_de.pdf
Auf seite 34 und 35 wird etwas von den Accountnamen und deren Pfade gesprochen. Damit verbunden ist auch die gross und kleinschreibung, die für Windows Irrelevant sind aber für Subversion gänzlich unterschiede darstellen.

Vielleicht mit den Admin abklären ob es damit zusammenhängt.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby nixwissa » 26. January 2006 09:04

Ich nehme mal an, dass du die Schreibweise der AuthzSVNAccessFile meinst.

Benutzername und TortoiseSVN Loginname stimmen in der Schreibweise überein. Es scheitert ja auch nicht an der Authorisierung sondern an der Autentifizierung.

Eintrag in der Apache Error Log wenn die Anmeldedaten nicht stimmen:
Logon failure: unknown user name or bad password. : user DOMAIN\\user: authentication failure

Benutzer vorhanden, Windows Login erfolgreich; übermittelter Login stimmt nicht mit dem Eintrag in der SVNAccess Datei überein
z.B.: SVNAccess Eintrag: DOMAIN\user
Benutzername der beim Tortoisesvn Login verwende wurde: User
Access denied: 'DOMAIN\User' PROPFIND test:/

Im Falle meines Kollegen kommt es zum Logon Fehler, obwohl der Benutzername als auch das Passwort korrekt übermittelt worden sind.

Das Problem trat schon einmal in Verbindung mit Umlauten auf. Jetzt würde mich interessieren welche Sonderzeichen ich verwenden bzw. nicht verwenden darf.

Danke
nixwissa
 
Posts: 2
Joined: 25. January 2006 09:12


Return to Apache

Who is online

Users browsing this forum: No registered users and 2 guests