Apache versackt nach Start

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache versackt nach Start

Postby Tom02 » 23. January 2006 21:38

Nach Start des Apachen [2.054 oder 2.2.0] erscheint "Apache is starting...", etwas später beginnt Festplatte endlos zu klappern/nudeln (Lampe immer an, Geräusch). Dann z.B. bei "http://localhost/index.html" im Browser ewig Fortschrittsbalken und "Seite http://localhost/index.html wird geöffnet", aber keine Anzeige und das war's
Tom02
 
Posts: 3
Joined: 23. January 2006 20:17

Postby deepsurfer » 24. January 2006 14:48

Windows / Linux ?

Mal gerpüft ob die Festplatte nicht voll ist ?

TEMP/TMP Verzeichnisse mal leeren

War dieses Verhalten von anfang an oder ist dies jetzt erst aufgetaucht ?
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Tom02 » 24. January 2006 15:56

Hallöchen Deep Chirio,

erst mal Danke für die schnelle Rückmeldung !

Betriebssystem: Windows XP
Festplatte: 40 GB (in versch. Partitionen, aber keine voll): "DIR" im DOS-Fenster meldet: "C: 11.207.647.232 Bytes frei", "D: 1.361.850.368 Bytes frei".
Ich habe auf dem Rechner 2 Bootpartitionen, eine mit W98 u. eine mit XP, und eine Datenpartition. Auf der 98-er Partition habe ich einstmals einen Apachen (Version 1....) auf C: installiert mit MySQL, PHP, Perl; lief (bzw. läuft? Schon lange nicht mehr gestartet...) alles. Die C-Partition von W98 ist unter XP nicht sichtbar!
Unter XP hatte ich allerdings schon mal einen erfolglosen Installationsversuch von WAMPP ins Verzeichnis d:\www\. Schon damals traten dieselben Symptome beim Start von Apache auf wie jetzt.
Deinstallation mit Ashampoo Uninstaller, außerdem per-Hand-Suche in INI-Dateien und Registry nach Apache-(und MySQL-)Einträgen. Glaube, alles gelöscht zu haben. In services.msc z.B. weder Apache- noch MySQL-Dienst vorhanden!
Jetzt nach langer Zeit neuerlicher erfolgloser Install.-Versuch, diesmal mit XAMPP.
Fällt Dir dazu noch was ein ?

Lieben Dank im voraus.

Thomas
Tom02
 
Posts: 3
Joined: 23. January 2006 20:17

Postby deepsurfer » 24. January 2006 16:19

Mal Testen..... (ist nix schlimmes und du kannst nix kaputt machen)

Folgendes:
Die httpd.conf editieren und ganz runter scrollen, am ende folgende zeile
Hinzufügen.

Code: Select all
Win32DisableAcceptEx


Speicher, apache neu starten........

Sollte es nicht den effekt haben dann einfach die Zeile wieder löschen....speichern, apache neu starten.

Ich wüsste jetzt nicht woran es dann liegen könnte.
Last edited by deepsurfer on 25. January 2006 18:13, edited 2 times in total.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Wiedmann » 24. January 2006 16:20

Win32DisableAcceptEx On

ohne "On".
-->
Code: Select all
Win32DisableAcceptEx
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby deepsurfer » 24. January 2006 16:22

du warst wieder schneller.... war gerade dabei es zu ändern... ;)
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Tom02 » 24. January 2006 16:56

Ja, Ja ! das war's ! Wunderbar !

[Ich wollt' Dir/Euch eine minikleine Spende zukommen lassen (von 5 Euro, Pardon: Bin nur ein Arbeitsloser). Geht das nur über PayPal? Bzw. ich hoffe, es gibt keine Gebühren für Euch... Sonst bitte eine Bankverbindung angeben.

Ich würde den 2.Teil der Mail dann später wieder löschen. Ist das okay?]
Tom02
 
Posts: 3
Joined: 23. January 2006 20:17

Postby Wiedmann » 24. January 2006 17:08

Am besten wendest du dich hierzu an Kai:
http://community.apachefriends.org/f/profile. ... rofile&u=2
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby PhoeNIXz » 24. January 2006 18:12

hab ma dazu ne frage obs bei mir hilft:

Ich habe diese Zeile auch bei mir eingefügt, nur heißt sie httpD.conf was mich schon wundert. Naja ich benutze x64 und jetzt lastet Apache net mehr aus sondern(mithilfe eines programms schön zu erkennen...) startet und beendet sich dauernd... kennt ihr dazu den grund? Ich bin da so drauf gekommen wegen Win32 und disable..so...^^
PhoeNIXz
 
Posts: 3
Joined: 19. January 2006 14:22
Location: Gute Frage...

neue XAMPP Version 1.5.1 Apache fast bei 100% CPU

Postby RaceRat » 27. January 2006 02:05

Hallo Leute,

ich habe das gleiche Problem wie "Tom02" es ganz am Anfang hatte.
Mein System: Notebook mit Win2000 Pro und noch genug freien Speicher.

Also ich hab mir heute die neueste Version(1.5.1) von XAMPP mal runtergeladen und installiert. Mein System ist dann genauso ausgelastet wie bei beim Tom02. Das Problem mit der CPU Auslastung kenne ich schon aus den früheren XAMPP Versionen, hatte es auch immer mit "Win32DisableAcceptEx" gelöst. Bei dieser Version ist es aber etwas anders, es gibt eine httpd.conf und eine oldhttpd.conf.

In der httpd.conf gibt es diese Zeile "Win32DisableAcceptEx" gar nicht mehr. In der oldhttpd.conf ist dieser Wert "Win32DisableAcceptEx" noch vorhanden. Ich habe mal die oldhttpd.conf in httpd.conf umbenannt und dann in dieser Datei den Wert "Win32DisableAcceptEx" aktiviert und deaktiviert (also wie bei den alten Version, mit # davor), es es hatte sich nichts geändert.

Was kann man da tun? Vielleicht habt ihr eine Idee.

Aktueller Versionen:
MySQL 5.0.18
Apache 2.2.0
PHP 5.1.1
phpMyAdmin 2.7.0 pl1
RaceRat
 
Posts: 2
Joined: 27. January 2006 01:18
Location: Mannheim und Leipzig

Postby deepsurfer » 27. January 2006 14:09

in der httpd.conf gibt es diese Zeile "Win32DisableAcceptEx" gar nicht mehr. In der oldhttpd.conf ist dieser Wert "Win32DisableAcceptEx" noch vorhanden. Ich habe mal die oldhttpd.conf in httpd.conf umbenannt und dann in dieser Datei den Wert "Win32DisableAcceptEx" aktiviert und deaktiviert (also wie bei den alten Version, mit # davor), es es hatte sich nichts geändert.


Ja ist richtig, es gibt ein oldhttpd.conf, die ist aber im jetzigen zustand nur ein Überbleibsel.

Wie ich aber geschrieben hatte einfach die
httpd.conf editieren und das "Win32DisableAcceptEx" an letzter Stelle hinzufügen
Wäre dieser eintrag wie zu damalaigen Zeiten noch vorhanden gewesen dann hätte ich geschrieben das man die zeile mit
#Win32DisableAcceptEx die raute (#) einfach entfernen sollte.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Wiedmann » 27. January 2006 14:36

httpd.conf editieren und das "Win32DisableAcceptEx" an letzter Stelle hinzufügen

Genaugenommen sollte das in die Datei "httpd-mpm.conf", innerhalb des Blockes für "<IfModule mpm_winnt_module>".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby deepsurfer » 27. January 2006 16:39

Wiedmann wrote:
httpd.conf editieren und das "Win32DisableAcceptEx" an letzter Stelle hinzufügen

Genaugenommen sollte das in die Datei "httpd-mpm.conf", innerhalb des Blockes für "<IfModule mpm_winnt_module>".


Todo für new release:
setzen wa das am besten auch für kommende XAMPP-versionen dort einkommentiert rein.
Habe es extra nicht auf dieses include gesetzt, weil für eine Zeile gerade unnötig ist, zumal es sich ja um einzelfälle handelt.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Wiedmann » 27. January 2006 18:04

setzen wa das am besten auch für kommende XAMPP-versionen dort einkommentiert rein.

Schonmal in der 1.5.2-beta1 die Datei "httpd-mpm.conf" angeschaut?

BTW:
Was machen dazu deine diesbezüglichen Tests?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

funzt jetzt.

Postby RaceRat » 27. January 2006 21:13

Hallo ich bins nochmal,

ich bedanke mich für die Antworten:

Also jetzt läuft alles so wie ich es will.
Geholfen hat die Methode mit der httpd.conf. Ich hab einfach ans Ende "Win32DisableAcceptEx" eingefügt.

Ich hab auch die Möglichkeit vom "Wiedmann" ausprobiert.
Also die httpd-mpm.conf editieren, und innerhalb des Blockes für "<IfModule mpm_winnt_module>", die Zeile "Win32DisableAcceptEx einfügen". Diese hat nicht funktioniert.

Ich bedanke mich bei euch für die Hilfe.

MfG
RaceRat
RaceRat
 
Posts: 2
Joined: 27. January 2006 01:18
Location: Mannheim und Leipzig

Next

Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests