Apache2 und zwei Netzkarten

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache2 und zwei Netzkarten

Postby e2e4 » 10. January 2006 15:27

Salut,

ich habe eine zweite Netzkarte in Apache eingebaut, um die Webseite (Intranet) auch in einem zweiten Netz verfügbar zu machen. Dazu habe ich die Virtual-Host-Konfiguration in apache2.conf folgendermassen eingerichtet:

NameVirtualHost 192.168.5.135
NameVirtualHost 192.168.7.6

<VirtualHost 192.168.5.135>
ServerName wiki
DocumentRoot /usr/share/dokuwiki/
ErrorLog /var/log/apache2/httpd/error_log
TransferLog /var/log/apache2/httpd/access_log
</VirtualHost>

<VirtualHost 192.168.7.6>
ServerName wiki
DocumentRoot /usr/share/dokuwiki/
ErrorLog /var/log/apache2/httpd/error_log
TransferLog /var/log/apache2/httpd/access_log
</VirtualHost>


Während auf den ersten Host problemlos zugegriffen werden kann (wie bisher), taucht bei der 192.168.7.6-Adresse ein 403-Forbidden-Fehler auf. Eine .htaccess habe ich aber nicht im Einsatz. Im Logfile keine Einträge!

Ist der Ansatz falsch oder gibt es noch etwas weiteres zu beachten?

Grüße, e2e4
e2e4
 
Posts: 4
Joined: 11. October 2005 09:02

Postby Wiedmann » 10. January 2006 15:35

Wenn du voher keine VHosts hattest, brauchst du jetzt auch keine einzurichten. Oder hattest du vorher schon einen/mehrere?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby e2e4 » 11. January 2006 15:05

Salut, vorher hatte ich einen: 192.168.5.135.

Grüße, e2e4
e2e4
 
Posts: 4
Joined: 11. October 2005 09:02

Postby deepsurfer » 11. January 2006 18:33

Eigentlich egal, du brauchst nur einen VHOST, wegen deklaration deines Wikipfades.
Damit Apache aber keine Probleme macht wegen der IP, wäre die erweiterung der Listen Directive angebracht.

Die LISTEN directive erweitern
Code: Select all
Listen 192.168.5.135:80
Listen 192.168.7.6:80




Code: Select all
NameVirtualHost servername

<VirtualHost *:80>
ServerName wiki
DocumentRoot /usr/share/dokuwiki/
ErrorLog /var/log/apache2/httpd/error_log
TransferLog /var/log/apache2/httpd/access_log
</VirtualHost>

chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Wiedmann » 11. January 2006 22:25

NameVirtualHost servername

<VirtualHost *:80>

Der Parameter vom (von den) "VirtualHost" mus immer zum "NameVirtualHost".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby e2e4 » 13. January 2006 10:06

Der Parameter vom (von den) "VirtualHost" mus immer zum "NameVirtualHost".


Dies kann ich bestätigen, deshalb ist meine Lösung folgendermassen realisiert:

Code: Select all
Listen 192.168.5.135:8080
Listen 192.168.7.6:8080

NameVirtualHost *:8080

<VirtualHost *:8080>


Möchte ich aber diese Einstellung mit Port 80 vornehmen, gelingt mir das nicht im Erfolg. Folgende Fehlermeldung:

Starting web server: Apache2(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs


netstat -nat zeigt mir keine Serveraktivität auf Port 80 (Apache vorher gestoppt). Die Aussage dieser Meldung ist mir noch nicht klar.

Grüße, e2e4
e2e4
 
Posts: 4
Joined: 11. October 2005 09:02


Return to Apache

Who is online

Users browsing this forum: No registered users and 5 guests