SELinux, PHP, Apache: DB-Zugriff

Alles, was den Apache betrifft, kann hier besprochen werden.

SELinux, PHP, Apache: DB-Zugriff

Postby crazynet24 » 04. January 2006 16:16

Moinsen,
ich kann unter Fedora (2.6.11-1.1369 FC4) keine Datenbank-Verbindung zu einem andere Rechner herstellen, wenn httpd (Apache 1.3....) automatisch unter /etc/rc.d/rc3.d gestartet wird.

Beende ich den Apache auf einer root-konsole und starte ihn dann von dort aus neu, funktioniert der Datenbankzugriff wie gewohnt...

Das dürfte wohl irgend ein Sicherheitsmechanismus von SELinux sein, aber ich find verdammt nochmal keine Doku oder Hinweise zu genau diesem Problem...

kann mir jemand helfen?

viele Gruesse
Stefan
crazynet24
 
Posts: 2
Joined: 04. January 2006 15:45

Postby KingCrunch » 04. January 2006 16:38

Je nachdem, ob du nicht als Root arbeitest (was man ja auch nicht tun sollte ;)) kann es sein, dass die Rechte fehlen.
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Postby deepsurfer » 04. January 2006 16:44

klingt etwas banal, aber nimm den autostart aus der rc3 heraus. (kopie anfertigen)

schreib mit chmod 755 ein eigenes Startscript das den apache hochfährt (selber befehl als wenn du Konsolen befehl zum starten des apachen benutzt)

Dieses Script ins rc3 reinsetzen.

Wenn ich mich jetzt nicht irre wird der Apache vor dem Network-Connect-Freigaben gestartet und der Apache baut dadurch keinen Verbindung auf weil die definitionen in der httpd.conf schon abgearbeitet sind.

Wenn ich mit meinem Latein nicht falsch liege sollte nun der Apache nach den freigaben gestartet werden und somit die gewünschte Verbindung aufgebaut werden.

Ansonsten mal in der SUSE-Hilfe (Rettungsring) nach "Startreihenfolge" suchen, bestimmt gibt es noch eine elegantere Lösung als mein Test-Konstrukt hier.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Problem gelöst!

Postby crazynet24 » 05. January 2006 09:46

Problem gelöst!

dokumentiert unter (nicht trivial):
https://bugzilla.redhat.com/bugzilla/sh ... ?id=164700

dazu folgendes für die Nachwelt:
Der Netzwerkzugriff unter Apache funktioniert per default nicht und muss mit:
/usr/sbin/setsebool httpd_can_network_connect=1
zugelassen werden.

Die Einstellung kann mit der -P Option persistiert werden, also:

/usr/sbin/setsebool -P httpd_can_network_connect=1

Danke an alle!

----------------------------------------------
Suchmaschinen Keywords:
SELinux Fedora Redhat PHP Apache Datenbankzugriff fopen mysql connection Datenbankverbindung kein Zugriff Datenbank Database mysql_connect
crazynet24
 
Posts: 2
Joined: 04. January 2006 15:45


Return to Apache

Who is online

Users browsing this forum: No registered users and 7 guests