virtualhost geht nicht im netzwerk

Alles, was den Apache betrifft, kann hier besprochen werden.

virtualhost geht nicht im netzwerk

Postby mato » 24. June 2003 19:00

hi leute
habe die frage schon in apachefriends gestellt, aber offensichtlich das falsche board.
also, habe apache (1.3) auf linux suse 8.1 laufen und er bereitet mir lokal keinerlei probleme (perl, php u.s.w.). auch virtuelle host's funtzen wunderbar. mein problem besteht darin das ich den rechner (in einer schule - weiterbildung) in ein win98 - netzwerk mit "nt4 - server" als webserver stellen will, damit jeder der 30 rechner im netz sozusagen seinen eigenen webaccount zum testen von perl und php hat. dies wollte ich also mit virtualhost realisieren, wie gesagt, lokal in linux funtzt alles, nur über das netzwerk kann ich faktisch nur den server aufrufen, nicht aber die virtualhost's "seite kann nicht angezeigt werden". habe meiner meinung nach schon alles probiert (hoffe ich aber nicht, denn irgendwie muss es ja gehen).
was mache ich falsch, habe es auch mit apache in der 2-er version probiert, da ging es nicht mal lokal, b.z.w. hat er beim aufruf eines virtualhost nicht weitergeleitet sondern auf den serverordner selbst zugegriffen.

in der httpd.conf sieht das dann im etwa so aus:

Code: Select all
Listen 192.xxx.xxx.80:80
...
NameVirtualHost 192.xxx.xxx.80
...
<VirtualHost 192.xxx.xxx.80>
    DocumentRoot  /srv/www/htdocs/domain1
    ServerName domain1
</VirtualHost>

und immer so weiter

von den dozenten hier hat keiner einen plan von linux oder gar von apache. ich mache das ganze eigentlich nur um meinen horizont zu erweitern und nicht mit microsoft auf der stelle zu treten. bin also auch noch nicht so vertraut mit der materie wie ich gerne möchte. ich hoffe mir kann jemand weiterhelfen, ihr wollt doch nicht das ich das vertrauen zu "nicht-microsoft-produkten" verliere, noch habe ich es.
mato
mato
 

Return to Apache

Who is online

Users browsing this forum: No registered users and 2 guests