Probleme mit .htacess unter Win2K

Alles, was den Apache betrifft, kann hier besprochen werden.

Probleme mit .htacess unter Win2K

Postby dwhadmin » 05. December 2005 16:40

Hallo,

ich habe vielfach gesucht nach htaccess in diesem Forum aber eine Lösung für mein Problem konnte ich leider nicht finden.
Daher poste ich mein Problem in einem neuen Thread:

Ich habe den aktuellen Apache2 unter c:\Apache installiert.
Das htdocs-Verzeichnis liegt hier c:\Apache\Apache2\htdocs

Ich habe dann die http.conf angepasst: Alle Einträge "AllowOverride None"
wurden durch "AllowOverride All" ersetzt.
Dann habe ich mir im htdocs-Verzeichnis zwei Dateien angelegt:
.htpasswd und .htacess.

In .htpasswd habe ich meinen User definiert (htpasswd -c c:\Apache\Apache2\htdocs\.htpasswd myuser)

.htaccess sieht bei mir wie folgt aus:
AuthType Basic
AuthName "LokinRikweiert"
AuthUserFile c:/Apache/Apache2/htdocs/.htpasswd
require valid-user

Für AuthUserFile habe ich folgende Varianten ausprobiert:
slash und backslas und Kleinschreibung

In der httpd.conf existiert außerdem folgende Zeile:
AccessFileName .htaccess

Alle Änderungen wurden gespeichert und der Apache restartet.

Ich bin der Meinung, dass alles regelgerecht ist, jedoch funktioniert es nicht. Die Apache-Start-Seite wird noch immer so angezeigt. Eine Authentifizierung wird nicht gefordert.

Hat jemand eine Lösung woran es liegen kann?

Danke im vorraus,
dwhadmin
dwhadmin
 
Posts: 1
Joined: 05. December 2005 16:28

Return to Apache

Who is online

Users browsing this forum: No registered users and 5 guests