Probleme mit der RewriteEngine (mod_rewrite)

Alles, was den Apache betrifft, kann hier besprochen werden.

Probleme mit der RewriteEngine (mod_rewrite)

Postby Flow23 » 18. October 2005 10:49

Hallo zusammen,

in unserer Apache2-Konfiguration haben wir möglichst wenig Befehle direkt in die httpd.conf gepackt, vielmehr haben wir die entsprechenden Segmente per Includes eingebunden. Nun wollten wir einen Virtuellen Host erstellen, um unsere Internetseite in zwei Instanzen zu betreiben.
Leider traten beim Virtuellen Host Probleme mit der Pfadfindung über die URL auf. Wir erhielten den Tip, dass das Modul Rewrite einzubinden sei, welches die Probleme eventuell beheben könnte. Wir haben deshalb in der Datei loadmodule.conf den Eintrag

LoadModule alias_module

mit LoadModule rewrite_module ersetzt und in der Datei vhosts.conf steht

<VirtualHost 172.16.10.20>
ServerName 172.16.10.20
RewriteEngine On
DocumentRoot /srv/www/htdocs/webfs
</VirtualHost>

Sobald wir den Apache neu starten, wird uns in der Datei vhosts.conf ein Syntaxfehler aufgezeigt und zwar an der Stelle wo wir RewriteEngine On stehen haben.

Kann uns mal jemand Schritt für Schritt sagen, wo und wie wir das Rewrite-Modul für unseren Virtuellen Host aktivieren müssen???

Gruß Florian Scheidler
Flow23
 
Posts: 10
Joined: 25. November 2004 09:46
Location: Hamburg

Postby deepsurfer » 18. October 2005 11:31

schau mal hier vorbei...

http://www.modrewrite.de/

dort sollte alles geklärt werden, zudem sind die Moderatoren dort im Forum sehr fit in sachen mod_rewrite.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Flow23 » 18. October 2005 11:47

Danke!
Flow23
 
Posts: 10
Joined: 25. November 2004 09:46
Location: Hamburg


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests