Script will typo3/typo3temp statt typo3temp finden

Alles, was den Apache betrifft, kann hier besprochen werden.

Script will typo3/typo3temp statt typo3temp finden

Postby Imagine » 17. October 2005 16:32

Hallo,
ich habe Probleme einer Extension unter Typo3 (rtehtmlarea 0.7.2) auf einem Apache2-Server. Ich habe das Problem bereits mit dem Entwickler der Extension diskutiert, mit dem Resultat, dass die Extension funktioniert. Sie hat auch einmal bei mir in der Konstellation Apache 1.3 und Typo3 (3.7.0) funktioniert.
Das Phänomen äussert sich so, dass ich über den Firefox den Richtexteditor im Typo3-Backend nicht aufrufen kann - der Editor lädt unendlich.

Jetzt komme ich zu dem, weswegen ich mich an das Forum hier wende. Wenn ich während des Aufrufes mein Error-Logfile geöffnet habe sehe ich folgende Meldungen:
Code: Select all
[Sun Oct 16 10:06:39 2005] [error] [client 84.161.31.106] File does not exist: /home/andreas/linuxmaker/typo3/typo3conf, referer: http://www.linuxmaker.
de/typo3admin/wizard_rte.php?&P[table]=tt_content&P[uid]=5&P[pid]=5&P[field]=bodytext&P[returnUrl]=%2Ftypo3admin%2Fsysext%2Fcms%2Flayout%2Fdb_layout.php
%3Fid%3D5%26SET%5Bfunction%5D%3D1
[Sun Oct 16 10:06:39 2005] [error] [client 84.161.31.106] File does not exist: /home/andreas/linuxmaker/typo3/typo3temp, referer: http://www.linuxmaker.de/typo3admin/wizard_rte.php?&P[table]=tt_content&P[uid]=5&P[pid]=5&P[field]=bodytext&P[returnUrl]=%2Ftypo3admin%2Fsysext%2Fcms%2Flayout%2Fdb_layout.php
%3Fid%3D5%26SET%5Bfunction%5D%3D1


Und das ist das, was ich nicht verstehe. Das entsprechende Script eine Datei in einem Verzeichnis, das an dieser Stelle nicht zu existieren hat:
/typo3/typo3conf und typo3/typo3temp

Beide Verzeichnisse liegen auf gleicher Ebene wie das Verzeichnis typo3 - das ein Link zu den Typo3-Soucres ist. Damit Ihr die Struktur nachvollziehen könnt, hier die Struktur unter linuxmaker, das ein umbenanntes dummy-3.8.0-Verzeichnis ist:
Code: Select all
-rwxr-xr-x  1 www-data www-data    46 2005-05-23 02:41 clear.gif
-rw-r--r--  1 root     root       664 2005-10-11 12:51 default.htm
-rw-r--r--  1 root     root      1206 2005-10-17 16:04 favicon.ico
drwxr-xr-x  8 www-data www-data  4096 2005-10-17 16:04 fileadmin
-rw-r--r--  1 root     root       664 2005-10-08 17:15 home.html
-rwxr-xr-x  1 www-data www-data  4509 2005-05-23 02:41 _.htaccess
drwxr-xr-x  2 root     root      4096 2005-10-17 16:21 img
-rw-r--r--  1 root     root       692 2005-10-10 21:49 index2.html
lrwxrwxrwx  1 www-data www-data    18 2005-10-05 20:57 index.php -> tslib/index_ts.php
lrwxrwxrwx  1 www-data www-data    11 2005-10-05 20:57 media -> tslib/media
f
lrwxrwxrwx  1 www-data www-data    17 2005-10-05 20:57 showpic.php -> tslib/showpic.php
lrwxrwxrwx  1 www-data www-data    15 2005-10-05 20:57 t3lib -> typo3_src/t3lib
lrwxrwxrwx  1 www-data www-data    15 2005-10-05 20:57 tslib -> typo3_src/tslib
lrwxrwxrwx  1 www-data www-data    15 2005-10-05 20:57 typo3 -> typo3_src/typo3
drwxr-xr-x  3 www-data www-data  4096 2005-10-16 10:39 typo3conf
lrwxrwxrwx  1 www-data www-data    25 2005-10-05 20:57 typo3_src -> ../../www/typo3_src-3.8.0
drwxr-xr-x  8 www-data www-data  4096 2005-10-14 18:01 typo3temp
drwxr-xr-x  7 www-data www-data  4096 2005-10-06 10:06 uploads


Woran kann das liegen, dass der Aufruf der RTE-HTMLArea-Extension immer wieder unter linuxmaker/typo3/ sucht statt unter linuxmaker?

Ich habe allenfalls Virtuelle Hosts in der apache2/sites-available/vhosts.conf anlegt und hier ein ScriptAlias gesetzt, um auf das Typo3-Backend zugreifen zu können:
Code: Select all
Alias /typoadmin "/home/andreas/linuxmaker/typo3/"
        <Directory "/home/andreas/linuxmaker/typo3/">
                Options Indexes MultiViews +FollowSymLinks
                AllowOverride None
                Order allow,deny
                Allow from all
        </Directory>


Habt Ihr hierzu eine Antwort?

Vielen Dank!

Imagine
Last edited by Imagine on 17. October 2005 16:46, edited 1 time in total.
Imagine
 
Posts: 2
Joined: 17. October 2005 15:57

Postby Imagine » 17. October 2005 16:45

Hallo,

ich habe zwar eine Lösung gefunden, wäre aber dankbar, wenn mir jemand sagen kann, warum mit dem ScriptAlias "typoadmin" nicht funktioniert bzw. zu diesem Eklat führt.

Ich habe jetzt in der vhost.conf eben folgendes gesetzt:
Code: Select all
Alias /Admin "/home/andreas/linuxmaker/typo3/"
<Directory "/home/andreas/linuxmaker/typo3/">
                Options Indexes MultiViews +FollowSymLinks
                AllowOverride None
                Order allow,deny
                Allow from all
        </Directory>


Jetzt klappt der Aufruf der Extension, sie sucht nicht mehr unter typo3/

Grüsse

Imagine
Imagine
 
Posts: 2
Joined: 17. October 2005 15:57


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests