Hohe CPU-Last mit php-Fotogalerie

Alles, was den Apache betrifft, kann hier besprochen werden.

Postby robertws » 04. November 2005 19:39

nattl wrote:schnucki, für die tatsache, dass du einer ziemlich guten software, die du gratis aus dem web runtergeladen hast, die schuld gibst, dass *du* ein php-script nicht zum laufen bringst und bist dann noch ziemlich harsch mit den leuten, die dir hier im forum ebenfalls gratis versuchen, dein problem zu helfen, lehnst du dich ganz schön weit raus...

wenn du glaubst, dass dies die richtige methode ist, von anderen leuten hilfe zu bekommen, dann wünsch ich dir viel glück.


Ach so. Und mit Deiner Nachricht hast Du jetzt natürlich maßgebend zur Sache beigetragen, also zur Problemlösung. Frage Dich selbst: Bist Du Teil der Lösung, oder Teil des Problems?

Wie ich Dir gerne erneut schreibe, läuft dieses Script auf zahlreichen Webservern tadellos (Galerie-Erstellung innerhalb weniger Millisekunden). Und solange es keine weiteren Ideen mehr gibt, liegt es nunmal aus meiner Sicht an Xampp. Dies liegt ja auch nahe, denn ich habe es gestern abend sogar mit einem Testzugang eines vSERVERs zum Laufen bekommen.

Du, Süße, bist sicherlich nur ein Teil des Problems in diesem Forum, denn zur Sache hast Du ja absolut gar nichts beigetragen.
robertws
 
Posts: 16
Joined: 08. October 2005 09:13

Postby schnikemike » 07. November 2005 21:23

Könnte es daranb liegen das zu viele datenbankabfragen im Hintergrund laufen (mysql).


Hab auch das Problem das mein server ausgelastet ist. allerdings nur ne p3 200 mhz mit 200 mb sd ram.

ansonsten könnte ich mir noch vorstellen das deien (meine ) festplatte zu problemen führ. zu kleiner cache schlechte zugriffszeit.


werds mir mal die tage anschauen. hab hier noch ein paar andere rechner rumstehen.


Da mit linux denke ich macht nicht alzuviel aus.

Hatte ne zeitlang verschieden Linux versione ausprobiert ( Alle mit kde x.x). Hatten grundsätzlich mehr Performance aber sind nach ner weile auch langsamer geworden.


Der vorteil dürfte aber sein das man alle nicht beötigten packe entfernen kann.


Dann bring es natürlich noch mehr performance arbeitsspeicher zu verfühfung steht.
Man muss sich natürlich dann auch weit mehr in Linux einarbeiten.


wenns an mysql liegt könnte das hier helfen.

http://dev.mysql.com/doc/refman/4.0/de/server-parameters.html
schnikemike
 
Posts: 6
Joined: 05. November 2005 17:03

Postby robertws » 07. November 2005 23:00

Hallo schnikemike

MySQL benötige ich gar nicht und starte es auch gar nicht erst. Das Script braucht nur PHP, kein *SQL. Daran kann es also nicht liegen...

Ich habe die Sache jetzt erstmal aufgegeben und habe aus dem Rechner einen Original-Apache für Win32 und einen FTP-Server (FileZilla Server) gemacht. Dann kann man sich die Fotos aber natürlich nicht in schönen Galerien ansehen, sondern bekommt nur die Dateiauflistung des Apache :-(

Es ist ganz schön mies, ich bin echt schlecht gelaunt, dass phpAutoGallery so lahm ist. Aber es gibt wohl auch keine Alternativen zu dem Script, oder kennst Du welche? (Foto-Galerien sollen "instant" / "on the fly" dynamisch erzeugt werden).

Gruß
Robert
robertws
 
Posts: 16
Joined: 08. October 2005 09:13

Postby schnikemike » 08. November 2005 23:08

Hatte nach soetwas schon mal vor einer ewigkeit geschaut. ich such mal bei mir auf der platte. Ansonsten kannst du ja eien fotogallerie wie zb coppermine oder fotoshow verwenden. Damit kann man ein batch script starten welches alle fotos + unterordner in eien bildergallerie aufnimmt.

Kann aber noch ein bischen dauern bis ich was finde beschäftige mich gerade mnit was anderem un weis nicht genau wo ich die foto scripte habe.

Bei bei fast 250 gb + zig backup dvds kann das ein bisserl dauern. Daweil kannst dir das mit coppermine mal anschauen. Gubt es als stand alone version. (also ohne cms wie phpnuke , postnuke etc. laufähig)

MFG
schnikemike
 
Posts: 6
Joined: 05. November 2005 17:03

Postby robertws » 03. October 2006 18:38

Hallo schnikemike,

hat Du inzwischen Deine DVDs und Platte durchforstet? Wenn ja, melde Dich doch mal - wäre sehr nett. - Auch obwohl ich phpAutoGallery jetzt zum Laufen bekommen habe! Ja, es funktioniert einwandfrei, nur bei sehr großen Verzeichnissen (100 Fotos und mehr) dauert das Erstellen der Foto-Galerie noch etwas lange, aber das ist ja auch okay bei so vielen Fotos. (138 Fotos = 88 Sekunden, 6 Fotos = 0,1 Sekunden).

Beste Grüße!
robertws
 
Posts: 16
Joined: 08. October 2005 09:13

Previous

Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests