einloggen über .htaccess funktioniert nicht mehr

Alles, was den Apache betrifft, kann hier besprochen werden.

einloggen über .htaccess funktioniert nicht mehr

Postby dragonfire73 » 30. September 2005 12:00

z. B. das einloggen in die Xampp Oberfläche.
Obwohl die korrekten Zugangsdaten eingegeben wurden, kommt immer wieder das Login-Fenster.

Es ist dabei egal ob ich über locahost oder die Domain gehe.
Auch bei anderen mit .htaccess geschützen Verzeichnissen besteht das gleiche Problem.
Alles andere von .htaccess funktioniert, nur das einloggen nicht.

Das komische ist nur, vorher hat alles wunderbar funktioniert und jetzt geht es nicht mehr.
Ich habe zwar die config-Datei des Apache vor kurzem aufgerufen, aber nichts geändert (zumindest nicht wissentlich).

Woran kann das liegen ?

xampp für Windows.
dragonfire73
 
Posts: 8
Joined: 30. September 2005 10:38

Postby Hanspeter Thöni » 30. September 2005 12:42

Hast du mal in's Apache error.log geschaut?
.....\xampp\apache\logs\error.log

Der Apache schreibt dort normalerweise eine Zeile rein wenn er einen User nicht reinlassen will. Dort steht auch dann der Grund warum. (User nicht bekannt, password-Datei nicht gefunden usw).

Gruss Hanspeter
Gruss Hanspeter
User avatar
Hanspeter Thöni
 
Posts: 233
Joined: 17. August 2004 10:29
Location: Schweiz

Postby dragonfire73 » 30. September 2005 13:01

Den Gedanken hatte ich gerade auch und folgende Fehlermeldung steht drin:

[Fri Sep 30 11:23:13 2005] [error] [client 127.0.0.1] MySQL ERROR: Access denied for user 'ODBC'@'localhost' (using password: NO)
[Fri Sep 30 11:23:13 2005] [error] [client 127.0.0.1] MySQL user admin not found: /xampp


Wieso MySQL Error bzw. User.
dragonfire73
 
Posts: 8
Joined: 30. September 2005 10:38

Postby Hanspeter Thöni » 30. September 2005 13:37

Aem, das ist aber wohl kein .htaccess Problem, sondern ein Mysql-Einloggproblem. Hier wird ein anonymer login versucht, aber abgewiesen. php meldet sich standardmässig mit diesem User an mysql an, wenn weder User noch passwort im script angegeben werden.

Das sollte aber eigentlich nicht zum obigen Problem führe, es sei denn, willst du phpmyadmin starten?
Gruss Hanspeter
User avatar
Hanspeter Thöni
 
Posts: 233
Joined: 17. August 2004 10:29
Location: Schweiz

Postby dragonfire73 » 30. September 2005 14:08

Das ist ja das was mich so verwirrt.

ich rufe mit http://localhost/xampp die Oberfläche auf.

Es kommt das Login für den xampp user und dann kommen folgende Fehlermeldungen in der error.log

[Fri Sep 30 15:05:28 2005] [error] [client 127.0.0.1] MySQL ERROR: Access denied for user 'ODBC'@'localhost' (using password: NO)
[Fri Sep 30 15:05:28 2005] [error] [client 127.0.0.1] MySQL user admin not found: /xampp
[Fri Sep 30 15:05:32 2005] [error] [client 127.0.0.1] MySQL ERROR: Access denied for user 'ODBC'@'localhost' (using password: NO)
[Fri Sep 30 15:05:32 2005] [error] [client 127.0.0.1] MySQL user admin not found: /xampp
[Fri Sep 30 15:05:37 2005] [error] [client 127.0.0.1] MySQL ERROR: Access denied for user 'ODBC'@'localhost' (using password: NO)
[Fri Sep 30 15:05:37 2005] [error] [client 127.0.0.1] MySQL user admin not found: /xampp
[Fri Sep 30 15:05:43 2005] [error] [client 127.0.0.1] MySQL ERROR: Access denied for user 'ODBC'@'localhost' (using password: NO)
[Fri Sep 30 15:05:43 2005] [error] [client 127.0.0.1] MySQL user admin not found: /xampp


Ich habe es mal viermal hintereinander probiert.

Was hat das Login mit Mysql zu tun.

Liegt es an falschen Einstellungen in der PHP.ini

Hier mal der Bereich für ODBC und MySQL
[ODBC]
;odbc.default_db = Not yet implemented
;odbc.default_user = Not yet implemented
;odbc.default_pw = Not yet implemented

; Allow or prevent persistent links.
odbc.allow_persistent = On

; Check that a connection is still valid before reuse.
odbc.check_persistent = On

; Maximum number of persistent links. -1 means no limit.
odbc.max_persistent = -1

; Maximum number of links (persistent + non-persistent). -1 means no limit.
odbc.max_links = -1

; Handling of LONG fields. Returns number of bytes to variables. 0 means
; passthru.
odbc.defaultlrl = 4096

; Handling of binary data. 0 means passthru, 1 return as is, 2 convert to char.
; See the documentation on odbc_binmode and odbc_longreadlen for an explanation
; of uodbc.defaultlrl and uodbc.defaultbinmode
odbc.defaultbinmode = 1

[MySQL]
; Allow or prevent persistent links.
mysql.allow_persistent = On

; Maximum number of persistent links. -1 means no limit.
mysql.max_persistent = -1

; Maximum number of links (persistent + non-persistent). -1 means no limit.
mysql.max_links = -1

; Default port number for mysql_connect(). If unset, mysql_connect() will use
; the $MYSQL_TCP_PORT or the mysql-tcp entry in /etc/services or the
; compile-time value defined MYSQL_PORT (in that order). Win32 will only look
; at MYSQL_PORT.
mysql.default_port =

; Default socket name for local MySQL connects. If empty, uses the built-in
; MySQL defaults.
mysql.default_socket =

; Default host for mysql_connect() (doesn't apply in safe mode).
mysql.default_host =

; Default user for mysql_connect() (doesn't apply in safe mode).
mysql.default_user =

; Default password for mysql_connect() (doesn't apply in safe mode).
; Note that this is generally a *bad* idea to store passwords in this file.
; *Any* user with PHP access can run 'echo get_cfg_var("mysql.default_password")
; and reveal this password! And of course, any users with read access to this
; file will be able to reveal the password as well.
mysql.default_password =

; Maximum time (in secondes) for connect timeout. -1 means no limimt
mysql.connect_timeout = -1

; Trace mode. When trace_mode is active (=On), warnings for table/index scans and
; SQL-Erros will be displayed.
mysql.trace_mode = Off
dragonfire73
 
Posts: 8
Joined: 30. September 2005 10:38

Postby Hanspeter Thöni » 30. September 2005 15:25

Wenn du die .htaccess entfernst, also den Zugriff nicht schützt, geht es dann?
Sind dann diese mysql-Fehlermeldungen weg?
Was steht in der .htaccess drin?
[Fri Sep 30 11:23:13 2005] [error] [client 127.0.0.1] MySQL user admin not found: /xampp

Bei mir sieht die Fehlermeldung fast gleich aus, wenn ich mit einem User probiere der nicht eingetragen ist:
[Fri Sep 30 13:40:22 2005] [error] [client 127.0.0.1] user dkdkdk not found: /verwalt_test/Musik_mut/vmms.php


Das einzige was bei dir mehr da ist ist anscheinend ein MYSQL. Da bei mir hier direkt ein php-file angesprochen wurde ist auch der vollständige Link drin. Die Fehlermeldung aber scheint sonst bis auf das Mysql dieselbe zu sein
Gruss Hanspeter
User avatar
Hanspeter Thöni
 
Posts: 233
Joined: 17. August 2004 10:29
Location: Schweiz

Postby dragonfire73 » 30. September 2005 17:13

Das ist die Standard .htaccess-Datei die von der Xampp-Oberfläche erzeugt wird:

AuthName "xampp user"
AuthType Basic
AuthUserFile "D:\apachefriends\xampp\security\xampp.users"
require valid-user


Der von mir eingegebene Use und as Password stimmen mit der xampp.users überein.

Was hat damit "odbc@localhost" zu tun ?
dragonfire73
 
Posts: 8
Joined: 30. September 2005 10:38

Postby dragonfire73 » 30. September 2005 17:20

Wenn ich die .htaccess Datei lösche geht es natürlich ohne Probleme.

Es steht dann folgedes in der Access.log:
127.0.0.1 - - [30/Sep/2005:18:14:31 +0200] "GET /xampp HTTP/1.1" 401 545
127.0.0.1 - admin [30/Sep/2005:18:14:35 +0200] "GET /xampp HTTP/1.1" 401 545
127.0.0.1 - - [30/Sep/2005:18:14:41 +0200] "GET /favicon.ico HTTP/1.1" 304 -
127.0.0.1 - - [30/Sep/2005:18:15:48 +0200] "GET /xampp HTTP/1.1" 301 375
127.0.0.1 - - [30/Sep/2005:18:15:48 +0200] "GET /xampp/ HTTP/1.1" 200 603
127.0.0.1 - - [30/Sep/2005:18:15:48 +0200] "GET /xampp/head.php HTTP/1.1" 200 755
127.0.0.1 - - [30/Sep/2005:18:15:48 +0200] "GET /xampp/start.php HTTP/1.1" 200 1480
127.0.0.1 - - [30/Sep/2005:18:15:48 +0200] "GET /xampp/navi.php HTTP/1.1" 200 3844


und in der Error.log ist keine Fehlermeldung vorhanden.
dragonfire73
 
Posts: 8
Joined: 30. September 2005 10:38

Postby dragonfire73 » 30. September 2005 17:22

Ich habe gerade mal per PHPmyAdmin auf meinen MySQL Datenbank-Server die Benutzer gechecked.

Da gibt es keinen Benutzer "ODBC".
Muss der da sein ?

Edit.
Es gibt den user ja auch nicht. Da beschreibt ja glaube ich nur den allgemeinen Zugriff auf Mysql aus Anwendungen heraus.

Ich glaube mittlerweile, dass es an den Einstellungen bei phpmyadmin liegt. Nur wieso auf einmal.
dragonfire73
 
Posts: 8
Joined: 30. September 2005 10:38

Postby dragonfire73 » 30. September 2005 21:51

Hat noch jemand eine Idee?
dragonfire73
 
Posts: 8
Joined: 30. September 2005 10:38

Postby Wiedmann » 30. September 2005 22:07

Du hast in der httpd.conf "mod_auth_mysql" aktiviert.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby dragonfire73 » 01. October 2005 01:41

ich habe das Modul mal deaktiviert.
Und es funktioniert. Keine Probleme mehr beim einloggen.

Danke. Danke

Was bewirkt dieses Modul eigentlich ?
Die Datenbanken sind nach der Abschaltung des Modules aber nach wie vor noch mit einem Passwort geschützt, oder ?
dragonfire73
 
Posts: 8
Joined: 30. September 2005 10:38


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests