Apache SSL antwortet nicht

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache SSL antwortet nicht

Postby Ehdoranil » 29. September 2005 08:16

Hallo

ich habe Apache 2 mit openssl und mod_ssl gemäß http://buecher.lingoworld.de/apache2/mod_ssl.html installiert. Es erscheint mir auch alle logisch - aber: Wenn ich jetzt https://<mydomain> angebe kommt der Fehler
"Die Verbindung mit <mydomain> wurde unerwartet abgebrochen. Ein Teil der Daten wurde eventuell übertragen!
Kann mir bitte jemand Helfen? Wenn ich nach dem Fehler Google bekomm ich nicht mal ein Ergebnis

Hier nochmal die Daten in der httpd.conf:

Code: Select all
    LoadModule ssl_module modules/mod_ssl.so

    Listen 443

    SSLMutex default
    SSLRandomSeed startup builtin
    SSLSessionCache none

    NameVirtualHost *

    //Diverse VirtualHosts
    <VirtualHost *:443>

        ServerName <mydomain>
        DocumentRoot "D:/Server/ssl"
        SSLEngine On
        SSLCertificateFile conf/ssl/<mydomain>.cert
        SSLCertificateKeyFile conf/ssl/<mydomain>.key

    </VirtualHost>

Vielen Dank für eure Hilfe!!
Ehdoranil
 
Posts: 4
Joined: 29. September 2005 08:12

Postby MisterD » 30. September 2005 22:45

keine ahnung obs daran liegt, aber wenn du NameVirtualHost * machst musst du auch <VirtualHost *> machen oder du machst beides *:443.
Steht inner Apache Doc, NameVirualHost xyz und <VirtualHost xyz> müssen die gleichen bezeichner haben..
User avatar
MisterD
 
Posts: 12
Joined: 28. August 2004 09:32

Postby Ehdoranil » 05. October 2005 08:04

Hi - ja das wars:)

mit
Code: Select all
NameVirtualHost *:443
<VirtualHost *.443>
...
</VirtualHost>

NameVirtulHost *:80
<VirtualHost *:80>
...
</VirtualHost>

funktioniert es :) Versteh noch nicht so ganz, warum - aber hauptsache es tut! Danke:)
Ehdoranil
 
Posts: 4
Joined: 29. September 2005 08:12


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests