webdav übers netzwerk

Alles, was den Apache betrifft, kann hier besprochen werden.

webdav übers netzwerk

Postby petzisxampp » 17. September 2005 11:21

hallo.
benutze eamx
habe webdav mit port 85 konfiguriert.
wenn ich nun die seite mit http://localhost:85 lade funktioniert alles einwandfrei,
nur wenn ich übers netzwerk mit http://rechnername:85 die seite lade öffnet mir der webserver meine standardseite mit der loginseite von egroupware.
was muß ich ändern , oder besser welche daten muß ich euch bekantt geben das ihr mir helfen könnt.

nebenbei finde ich die projekte und dieses FAQ sehr gut. !!!!
petzisxampp
 
Posts: 3
Joined: 17. September 2005 10:36

Postby Wiedmann » 17. September 2005 11:54

Um zu sagen was du ändern musst, müsste man wissen wie du WebDAV eingerichtet hast.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby petzisxampp » 17. September 2005 12:36

danke für deine schnelle antwort !!

wie unter webdav.txt unter webdav beschrieben habe ich
Die Module mod_dav.so und mod_dav_fs.so auskommentiert

das ist meine moddav.conf

### Section WEBDAV

# Use name-based virtual hosting.

Listen 85
NameVirtualHost 127.0.0.1:85

<VirtualHost 127.0.0.1:85>
# ServerAdmin webmaster@dummy-host.example.com
DocumentRoot "d:/eamx/webdav/"
# ServerName dummy-host.example.com
# ErrorLog logs/dummy-host.example.com-error_log
# CustomLog logs/dummy-host.example.com-access_log common
AccessFileName .htaccess
DAVLockDB d:/eamx/webdav/tmp/LockDB
#<Location />
#DAV On
#AuthType basic
#AuthName "WAMPP mit WebDAV"
#AuthUserfile d:/eamx/webdav/.htpasswd
#<LimitExcept GET HEAD OPTIONS>
#require user wampp
##</LimitExcept>
#</Location>

<Directory "d:/eamx/webdav/">
DAV On
Options ALL
AllowOverride All
AddHandler cgi-script .cgi .exe
Order allow,deny
Allow from all
</Directory>
</VirtualHost>
petzisxampp
 
Posts: 3
Joined: 17. September 2005 10:36

Postby Wiedmann » 17. September 2005 13:03

NameVirtualHost 127.0.0.1:85
<VirtualHost 127.0.0.1:85>

Wie du hier siehst, reagiert dieser VHost nur auf "127.0.0.1". Du müsstest also "127.0.0.1" durch "*" ersetzen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby petzisxampp » 17. September 2005 13:14

es geht ja einfach wenn man weiß wie ;-)

naja, da ich ganz neu bin werd ich mich jetzt doch mal mit den thema <<Apache>> auseinander setzen müssen.
ihr werdet sicher bald wieder was von mir hören.
mein nächster schritt ist ssl mit apache und webdav ;-(

danke dir 1000 mal für deine schnelle hilfe!!!!!

schönes wochenende an alle

lg
petzisxampp
 
Posts: 3
Joined: 17. September 2005 10:36


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests