keine Verbindung zum lokalen Apache Server

Alles, was den Apache betrifft, kann hier besprochen werden.

keine Verbindung zum lokalen Apache Server

Postby rainsen » 12. September 2005 15:50

Hallo,

ich bin seit einiger Zeit am rumprobieren, kriege aber irgendwie keine Verbindung zu meinem Server.
Habe mir die aktuellen Pakete von Apache2, php, mysql und Perl runtergeladen und zuerst den Apache2 installiert (Windows XP System)
Zuers wurde der Apache2-Dienst nicht mitinstalliert, das hab ich mittlerweile behoben. Laut dem "Apache Server Monitor" läuft der Dienst, im Taskmanager stehen 2 Apache.exe Prozesse von denen einer 0% CPU auslastung hat, der andere ~50% (auch seltsam finde ich)
wenn ich aber im Explorer localhost eingebe, oder localhost:80, oder localhost:8080, oder 127.0.0.1 usw passiert nichts. Manchmal kommt dei Meldung da keine Verbindung zum Server hergestellt werden kann, ansonsten läd er und macht nix.
Kann das vielleicht am Netzwerk liegen? ich bin über einen Router am Internet (IP: 192.168.2.1, meine 192.168.2.220). Hab mir schon einige Ports geforwardet, u.a. 80, 8080,... aber nix ändert sich.

Wer kann mir weiterhelfen???

Bei der Installation hatte ich erst bei "Network Name" und "server Name" localhost eingetragen, bei einer 2., neuen Installation dann meine IP Adresse ausprobiert, weil's in irgendeiner Installatonsanleitung stand. Was kann ich falsch gemacht haben??
rainsen
 
Posts: 4
Joined: 11. June 2004 15:51

Fehlermeldung in der error.log

Postby rainsen » 12. September 2005 16:50

in der error.log steht einige tausend mal

[error] (OS 10045)Der Vorgang wird von dem Objekttyp nicht unterstützt, auf den Bezug genommen wurde. : Child 2680: Encountered too many errors accepting client connections.

hängt das damit zusammen???
rainsen
 
Posts: 4
Joined: 11. June 2004 15:51

Postby Wiedmann » 12. September 2005 17:08

Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby rainsen » 12. September 2005 17:26

Ich hab jetzt die Zeile

Win32DisableAcceptEx ON

in die httpd.conf geschrieben (wo ist egal?) vorher war die nicht dadrin

das hat zuerst nichts geändert. Wenn ich selbst eine index.html in den htdocs-Ordner schreibe wird diese über localhost auch angezeigt. Ohne dieser müsste aber eigentlich doch die Standard-Apache-Seite angezeigt werden. ("Es klappt! Der Apache-Webserver ist auf dieser Website installiert!...") Dies ist aber nicht der Fall!
Wenn ich die selbst geschriebene index.html wieder lösche wird sie immer noch angezeigt, egal wie oft ich aktualisiere. Wenn ich den Browser schließe und neu starte ist wieder alles beim alten, nix funzt!

so richtig ist das also doch noch nicht.

Die Error.log ist inzwischen 5.5 MB groß; die Eiträge lauten jetzt

[Mon Sep 12 18:33:47 2005] [notice] Parent: Received restart signal -- Restarting the server.
[Mon Sep 12 18:33:47 2005] [notice] Child 2808: Exit event signaled. Child process is ending.
[Mon Sep 12 18:33:47 2005] [error] (OS 10038)Ein Vorgang bezog sich auf ein Objekt, das kein Socket ist. : Too many errors in select loop. Child process exiting.
[Mon Sep 12 18:33:47 2005] [notice] Apache/2.0.54 (Win32) configured -- resuming normal operations
[Mon Sep 12 18:33:47 2005] [notice] Server built: Apr 16 2005 14:25:31
[Mon Sep 12 18:33:47 2005] [notice] Parent: Created child process 1476
[Mon Sep 12 18:33:47 2005] [notice] Disabled use of AcceptEx() WinSock2 API
[Mon Sep 12 18:33:47 2005] [notice] Child 1476: Child process is running
[Mon Sep 12 18:33:48 2005] [notice] Child 2808: Released the start mutex
[Mon Sep 12 18:33:48 2005] [notice] Child 1476: Acquired the start mutex.
[Mon Sep 12 18:33:48 2005] [notice] Child 2808: Waiting for 250 worker threads to exit.
[Mon Sep 12 18:33:48 2005] [notice] Child 1476: Starting 250 worker threads.
[Mon Sep 12 18:33:48 2005] [notice] Child 2808: All worker threads have exited.
[Mon Sep 12 18:33:48 2005] [notice] Child 1476: Listening on port 80.
[Mon Sep 12 18:33:48 2005] [notice] Child 2808: Child process is exiting
rainsen
 
Posts: 4
Joined: 11. June 2004 15:51

Postby deepsurfer » 13. September 2005 11:25

as hat zuerst nichts geändert. Wenn ich selbst eine index.html in den htdocs-Ordner schreibe wird diese über localhost auch angezeigt. Ohne dieser müsste aber eigentlich doch die Standard-Apache-Seite angezeigt werden. ("Es klappt! Der Apache-Webserver ist auf dieser Website installiert!...") Dies ist aber nicht der Fall!
Wenn ich die selbst geschriebene index.html wieder lösche wird sie immer noch angezeigt, egal wie oft ich aktualisiere. Wenn ich den Browser schließe und neu starte ist wieder alles beim alten, nix funzt!


Mal den Browser CACHE leeren ;)
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby rainsen » 13. September 2005 11:41

das ist es nicht, mein Cache ist leer :roll:
rainsen
 
Posts: 4
Joined: 11. June 2004 15:51


Return to Apache

Who is online

Users browsing this forum: No registered users and 2 guests