WebDav - bekomm es einfach nicht zum laufen!

Alles, was den Apache betrifft, kann hier besprochen werden.

WebDav - bekomm es einfach nicht zum laufen!

Postby rain » 10. September 2005 09:59

Hallo miteinander!

Schön langsam bin ich etwas verzweifelt. Bekomme webdav unter meinem linux (xampp) webserver einfach nicht zum laufen.

Ich habe nach verschiedenen Anleitungen folgendes in der httpd.conf hinzugefügt:
(dies steht ganz am ende der datei)

DavLockDB /opt/lampp/var/DavLock

<Location "opt/lampp/htdocs/testvz">
Dav On
AuthType Basic
AuthName "WebDAV Restricted"
AuthUserFile /opt/lampp/var/davpwd/.davlogin
Require user webdav
</Location>

Die benötigten Module für Webdav werden eher am Anfang des files eingebunden:
LoadModule dav_module modules/mod_dav.so
LoadModule dav_fs_module modules/mod_dav_fs.so

Folende Berechtigungen haben die jeweiligen Verzeichnisse:

/otp/lampp/htdocs/testvz/
drwxrwxr-x
group: nobody
owner: nobody

/opt/lampp/var/DavLock
drwxrwxr-x
group: nobody
owner: nobody

/opt/lampp/var/davpwd
drwxrwxr-x
group: nobody
owner: nobody
in diesem Verzeichnis habe ich mit htpasswd -c /opt/lampp/var/davpwd/.davlogin webdav
den User webdav angelegt.

Wenn ich nun ein OfficeDokument auf meinen Windows rechner abspeichern will und z.b.: in Excel den Pfad http://192.168.200.10/testvz/ beim Dialogfeld
Speichern unter angeben dann kommt die Fehlermeldung: Die URL ... konnte nicht gefunden werden........

Wer kann mit helfen dass ich nun endlich mein WebDav zum Laufen bekommen?!?

mfg und besten Dank im Voraus
rain
 
Posts: 15
Joined: 16. January 2004 20:49

Postby rain » 10. September 2005 17:09

hat denn keiner eine idee?!

ich selbst habe einen kleinen Fehler gefunden: der apache unter xampp läuft unter der gruppe nogroup nich wie ich angenommen nobody. Aber leider klappt es immer noch nicht!!!!

Funktioniert die Möglichkeit überhaupt mit dem Excel speichern unter 192.168.200.10/testvz den Webdav ordner anzusprechen???
Wenn ich im Internetexplorer http://192.168.200.10/testvz/ öffne dann kommt die meldung : permission denied.......

Bin für jede Hilfe dankbar!

mfg
rain
 
Posts: 15
Joined: 16. January 2004 20:49

Postby rain » 11. September 2005 19:10

okay webdav läuft nun - aber ich kann die dateien im webdav vz nur ansehen, bzw öffnen. ich kann darauf aber nichts speicher.
das VZ hat aber chmod 777 - Woran kann das liegen.......

mfg und besten dank
rain
 
Posts: 15
Joined: 16. January 2004 20:49


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests