Nochmal: Virtual Host

Alles, was den Apache betrifft, kann hier besprochen werden.

Nochmal: Virtual Host

Postby Heckles » 24. August 2005 17:20

Moin, bin neu hier, aber ich habe mich im Forum und auch den anderen Themenbereichen bereits umgesehen. Nach einiger zusätzlicher Recherche im Internet bin ich aber nicht dahin gekommen, meinen VHost ans Laufen zu kriegen.
Vielleicht findet einer den Fehler. Also:
    *XAMPP unter Win XP installiert und läuft
    *Aufruf von "localhost" ist möglich (zeigt xampp-Startseite)
    *MySQL läuft und funktioniert
    *per DynDns Domäne eingerichtet und IP-Adresse aktualisiert

Solange ich mit der Standard httpd.conf arbeite, gibt's keine Probleme.
Wenn ich jetzt (für DynDns-Domäne schnulli.dyndns.org) mit dem Datenverzeichnis d:\Net\xampp\htdocs\schnulli) die httpd.conf ändere, sieht das so aus:
Code: Select all
NameVirtualHost schnulli.dyndns.org
<VirtualHost schnulli.dyndns.org>
   ServerAdmin ich@schnulli.de
   DocumentRoot D:/Net/xampp/htdocs/schnulli
   <Directory "D:/Net/xampp/htdocs/schnulli">
      Order Allow,Deny
      Allow from all
   </Directory>
   ServerName schnulli.dyndns.org
</VirtualHost>

Ich lande aber beim Aufruf von "www.schnulli.dyndns.org" zwar auf meinem Server (insofern sind DSL-Router und Firewall kein Problem), allerdings in der DocumentRoot des Servers und damit wieder auf der xampp-Startseite (/xampp/splash.php).
Auch wenn ich
Code: Select all
NameVirtualHost *   oder
NameVirtualHost *:80

eintrage oder auch die Pfadangabe vollständig in Kleinbuchstaben schreibe: Er findet die Daten (hier liegen php-Scripts) im Verzeichnis "schnulli" nicht.
Rufe ich dagegen http://localhost/schnulli auf, gibt's kein Problem. Das Forum startet.
Der Server reagiert ja auf den Aufruf, aber er leitet mich nicht ins rechte Verzeichnis. Hat jemand ne Idee, wo ich noch drehen kann???

Ich bin sooooo dankbar für jeden Tipp und Link.

Reiner
User avatar
Heckles
 
Posts: 4
Joined: 24. August 2005 14:26

Postby Wiedmann » 24. August 2005 17:32

http://community.apachefriends.org/f/viewtopi ... host#34538

BTW:
Wie man schon beim Buchstabenzählen bemerkt, sind
"schnulli.dyndns.org"
und
"www.schnulli.dyndns.org"
zwei verschiedene Dinge.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Heckles » 24. August 2005 17:48

Hupps - hier herrscht ein rauher Ton. :( Na gut:
Den Link hatte ich - wie erwähnt - bereits gefunden. Hatte mir - wie bereits erwähnt - auch keine Lösung gebracht.

Mit ein wenig Herumprobieren bekomme ich jetzt wenigstens die Meldung, das Objekt sei nicht gefunden worden, wobei die Adresse im Browser von der eingegebenen http://www.schnulli.dyn.dns.org wechselt auf http://www.schnulli.dyndns.org/xampp/splash.php.

Wieso versucht Apache, diese Seite zu finden und lädt nicht die index.php? Der Pfad dahin ist korrekt angegeben, in den Logs finde ich die Warnung, dass die DocumentRoot nicht existiert auch nicht.

Buchstabenzählen kann ich. Hat mri aber auch nicht wirklich weiter geholfen.

Reiner
User avatar
Heckles
 
Posts: 4
Joined: 24. August 2005 14:26

Postby deepsurfer » 24. August 2005 18:08

Hupps - hier herrscht ein rauher Ton. Sad Na gut:
Den Link hatte ich - wie erwähnt - bereits gefunden. Hatte mir - wie bereits erwähnt - auch keine Lösung gebracht.

Wo, denn wurde ein rauher ton angewandt ???

Mit ein wenig Herumprobieren bekomme ich jetzt wenigstens die Meldung, das Objekt sei nicht gefunden worden, wobei die Adresse im Browser von der eingegebenen http://www.schnulli.dyn.dns.org wechselt auf http://www.schnulli.dyndns.org/xampp/splash.php.

Das istz schonmal soweit ein gutes Zeichen, weil der domainname aufgelöst wird.
Solange du die index.htm ind \xampp\htdocs nicht änderst wird auch dieser Willkommenscreen immer auftauchen.

Wieso versucht Apache, diese Seite zu finden und lädt nicht die index.php? Der Pfad dahin ist korrekt angegeben, in den Logs finde ich die Warnung, dass die DocumentRoot nicht existiert auch nicht.

wie erwähnt durch die index.htm im \xampp\htdocs und durch den CACHE im Browser (diesen mal leeren!)

Buchstabenzählen kann ich. Hat mri aber auch nicht wirklich weiter geholfen.

Sollte aber eher ein Hinweis darauf sein, das www.xyz.de und xyz.de im eigentlichen sinne zwei verschiedene Dinge sind. In deiner Aufzählung und Fehlerbeschreibung kommt es aber so rüber als das du das als einziges ansiehst.

Code: Select all
NameVirtualHost *:80

<VirtualHost 127.0.0.1:80>
   ServerName schnulli.dyndns.org
   ServerAlias www.schnulli.dyndns.org   #<-- Funktioniert nur wenn im DDNS.org auch die "Wildcards" aktiviert sin
   ServerAdmin ich@schnulli.de
   DocumentRoot D:/Net/xampp/htdocs/schnulli #<-- Dieser Pfad MUSS existieren
   <Directory "D:/Net/xampp/htdocs/schnulli">
      Order Allow,Deny
      Allow from all
   </Directory>
</VirtualHost>


mal testen und melden
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Heckles » 24. August 2005 19:30

Solange du die index.htm ind \xampp\htdocs nicht änderst wird auch dieser Willkommenscreen immer auftauchen.

Hmm - darf ja eigentlich nicht, weil ich ja explizit sagen will: "Nimm nicht die index.html in /htdocs/xampp, sondern die index.php im Verzeichnis /htdocs/schnulli". Das macht doch
Code: Select all
DocumentRoot D:/Net/xampp/htdocs/schnulli

oder !? Und das ist ja auch mein einziges Problem:
Ich erkläre Apache, dass ich bei Aufruf der Domäne schnulli.dyndns.org bitte die index.php aus dem zugehörigen DocumentRoot angezeigt bekommen möchte (und per "localhost/schnulli/" funktioniert das ja auch).

Ich habe Deine Änderung leider ohne Veränderung des Verhaltens mal eingebaut (ja, ich stoppe und starte den Server jeweils neu).
Schaun wir mal in die Logs. Oh, das ist interessant. Der Zugriff auf die index.php führt zu komischen Ergebnissen:

Code: Select all
[24/Aug/2005:18:50:51 +0200] "GET /schnulli/index.php/Hauptseite HTTP/1.1" 301 26
[24/Aug/2005:18:50:51 +0200] "GET /schnulli/index.php/Index.php/Hauptseite HTTP/1.1" 301 26
[24/Aug/2005:18:50:51 +0200] "GET /schnulli/index.php/Index.php/Index.php/Hauptseite HTTP/1.1" 301 26
[24/Aug/2005:18:50:52 +0200] "GET /schnulli/index.php/Index.php/Index.php/Index.php/Hauptseite HTTP/1.1" 301 26
[24/Aug/2005:18:50:52 +0200] "GET /schnulli/index.php/Index.php/...

So geht das noch einige Zeilen weiter.
Gerade habe ich mal eine index.html-Datei hineinkopiert, lande aber wieder bei http://www.schnulli.dyndns.org/xampp/splash.php.
Ach Manno.

Muss man eigentlich die hosts-Datei manipulieren? Ich habe irgendwo gelesen, dass das bei DynDns-Verwendung nicht nötig ist. Kann da der Fehler liegen???
User avatar
Heckles
 
Posts: 4
Joined: 24. August 2005 14:26

Postby deepsurfer » 24. August 2005 22:44

So geht das noch einige Zeilen weiter.
Gerade habe ich mal eine index.html-Datei hineinkopiert, lande aber wieder bei http://www.schnulli.dyndns.org/xampp/splash.php.
Ach Manno.


Nicht verzagen :)

Browser Cache auf jedenfall leeren.

Die LOGmeldung sagt mir das der vorgang als solches funktioniert, aber innerhalb deiner index.php wird immer wieder nach Index.php gefordert dies sich wie eine endlosschleife wiederholt.
Da mal ansetzen.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Heckles » 25. August 2005 06:53

Moin,
nachdem ich ja gestern bereits festgestellt habe, dass ich auf meinem Server lande, war die Lösung am Ende einfach, wenn auch in der Art nicht befriedigend.
Der Aufruf von
www.schnulli.dyndns.org/schnulli
liefert das gewünschte Ergebnis. Warum allerdings mein Apache - das Problem habe ich eigentlich auch erst seit dem Update auf xampp 1.4.15 - die Pfadangabe ignoriert, verstehe ich leider nicht.
Danke dennoch für Deine geduldige Hilfe!

Reiner
User avatar
Heckles
 
Posts: 4
Joined: 24. August 2005 14:26


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests