Subdomain anlegen - wie?

Alles, was den Apache betrifft, kann hier besprochen werden.

Subdomain anlegen - wie?

Postby brakai295 » 23. August 2005 15:16

Hi,

ich bin ein ziemlicher Neuling mit XAMPP und kenne mich auch nicht viel mit Apache aus.
Ich muesste aber dringend wissen, wie ich eine subdomain auf meinem Rechner anlegen kann.

Also ich brauche hhtp://peter.localhost/

der dann die daten aus htdocs/peter raussaugt ;-)

Wenn mir jemand helfen kann, erklaert es mir BITTE in deutsch und so, dass es auch Deine Grossmama verstehen wuerde :-)))

Lieben Dank,

Gruesse
Kai
brakai295
 
Posts: 9
Joined: 23. August 2005 15:13

Postby Wiedmann » 23. August 2005 15:19

Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby brakai295 » 23. August 2005 15:29

hi!

danke fuer die schnelle antwort.

den beitrag habe ich aber auch schon gesehen. konnte damit aber nicht viel anfangen.

wie saehe der code denn fuer meinen speziellen fall aus?

danke und gruesse

kai
brakai295
 
Posts: 9
Joined: 23. August 2005 15:13

Postby deepsurfer » 23. August 2005 16:50

brakai295 wrote:hi!

danke fuer die schnelle antwort.
den beitrag habe ich aber auch schon gesehen. konnte damit aber nicht viel anfangen.
wie saehe der code denn fuer meinen speziellen fall aus?
danke und gruesse
kai


hhhmmm....was ist daran nicht zu verstehen ?

Lehrstunde: Verändere bitte den ZWEITEN eintrag so, wie du es meinst das es laufen könnte, als Anhaltspunkt habe ich dir den ersten Eintrag vor geformt und der zweite brauch nur von dir ergänzt werden.
Hinweis: ich kenne deine Verzeichnisfolgen nicht, von daher bitte deine Verzeichnisnamen eintragen.

(sollten fehler sein, bitte MODS diesen Text hier ändern ;) )

Code: Select all
NameVirtualHost *:80

<VirtualHost *:80>
    ServerName localhost:80
    DocumentRoot "c:/xampp/htdocs"
    <Directory "c:/xampp/htdocs">
        Order Allow,Deny
        Allow from all
        #Options All
        #AllowOverride All
    </Directory>
</VirtualHost>

<VirtualHost *:80>
    ServerName foo
    DocumentRoot "foo"
    <Directory "foo">
        Order Allow,Deny
        Allow from all
        #Options All
        #AllowOverride All
    </Directory>
</VirtualHost>


Und für den ServerName noch einen Eintrag in der Datei HOSTS ("%WINDIR%\system32\drivers\etc") machen.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby brakai295 » 24. August 2005 06:43

vielen dank ich habs endlich geschafft! :-)

liebe gr

kai
brakai295
 
Posts: 9
Joined: 23. August 2005 15:13

Postby brakai295 » 24. August 2005 07:15

Ups.. .da war ich wohl etwas voreilig.. klappt doch noch nicht.

ich habe folgenden code hinzugefuegt:

Code: Select all
<VirtualHost *:80>
    ServerName pete.localhost:80
    DocumentRoot "c:/xampplite/htdocs/safari"
    <Directory "c:/xampplite/htdocs/safari">
        Order Allow,Deny
        Allow from all
        #Options All
        #AllowOverride All
    </Directory>
</VirtualHost>


Ausserdem habe ich die HOSTS Datei entsprechend geaendert.
Ich kann zwar jetzt pete.localhost aufrufen, aber leider weist das das Root Verzeichnis http://localhost nun auch auf diesen Ordner.

Wodran liegt das? Muss ich die Zahl 80 aendern oder wie geht das? Wie schon gesagt, ich habe keine Ahnung, was die ganzen Zahlen und der Kram bedeuten. Deshalb BITTTTE in eine einfacher Erklaerung!!!!!

Vielen Dank!
Gr
kai
brakai295
 
Posts: 9
Joined: 23. August 2005 15:13

Postby bgleie » 24. August 2005 08:37

hallo

hast du die Zeile

NameVirtualHost *:80


vor deinem VirtualHost stehen?

Gruß
Bruno
bgleie
 
Posts: 10
Joined: 23. August 2005 12:51

Postby brakai295 » 24. August 2005 08:53

aehm.. was bedeuted das?
brakai295
 
Posts: 9
Joined: 23. August 2005 15:13

Postby brakai295 » 24. August 2005 08:56

achso.. sorry, ich glaube ich weiss was du meinst. also der code sieht genauso aus:

Code: Select all
NameVirtualHost *:80

<VirtualHost *:80>
    ServerName pete.localhost:80
    DocumentRoot "c:/xampplite/htdocs/safari"
    <Directory "c:/xampplite/htdocs/safari">
        Order Allow,Deny
        Allow from all
        #Options All
        #AllowOverride All
    </Directory>
</VirtualHost>



wobei nun http://localhost/ und http://pete.localhost/ die gleiche seite anzeigen :-(

gruss
kai
brakai295
 
Posts: 9
Joined: 23. August 2005 15:13

Postby bgleie » 24. August 2005 09:00

...

hast du für localhost auch einen VirtualHost angelegt?

Bruno
bgleie
 
Posts: 10
Joined: 23. August 2005 12:51

Postby brakai295 » 24. August 2005 09:13

mmh.. ich habe doch gesagt, ich habe davon keine ahnung. kannst du mir bitte sagen, wie genau der code aussehen muss, dass das gewuenschte ergebnis bekomme?

waere echt lieb von dir.

liebe gr

kai
brakai295
 
Posts: 9
Joined: 23. August 2005 15:13

Postby bgleie » 24. August 2005 09:35

...
<VirtualHost *:80>
ServerName localhost:80
DocumentRoot "c:/xampplite/htdocs/"
<Directory "c:/xampplite/htdocs">
Order Allow,Deny
Allow from all
#Options All
#AllowOverride All
</Directory>
</VirtualHost>
...

Gruß
Bruno
bgleie
 
Posts: 10
Joined: 23. August 2005 12:51

Postby brakai295 » 24. August 2005 09:49

vielen dank!!! jetzt funktioniert soweit alles so wie ich es moechte! :-)

liebe gr

kai
brakai295
 
Posts: 9
Joined: 23. August 2005 15:13

Postby deepsurfer » 24. August 2005 13:51

schadde brakai295

hättest du, wie ich geschrieben hatte, einfach den kompletten Code übernommen und nur den zweiten eintrag für dich umgeändert, so wären die ganzen nachträglichen fragen irrelevant geworden. ;)
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby brakai295 » 24. August 2005 15:49

mh.. aber gerade darum ging es mir ja... ich wusste nicht WIE ich den code anpassen musste. ihr programmierer versteht einfach nicht, dass es auch leute gibt, die mit so nem kram nicht viel anfangen koennen ;-)

liebe gr

kai
brakai295
 
Posts: 9
Joined: 23. August 2005 15:13


Return to Apache

Who is online

Users browsing this forum: No registered users and 5 guests