htaccess

Alles, was den Apache betrifft, kann hier besprochen werden.

htaccess

Postby manu0815 » 02. August 2005 22:31

Hi @ all
Nachdem ich mich jetzt schon stundenlang erfolglos durchs internet gewühlt habe poste ich nun doch einmal mein Problem.
Also folgendes:

Möchte gerne meine ganzen Verzechnisse auf meinem Webserver (Apache 2.0.54 unter Windows XP Prof) mit Passwort schützen. Habe meine .htaccess in das Rootverzeichnis des Webservers, also direkt in den Ordner htdocs abgelegt. Weis echt nicht was ich falsch gemacht habe.
In der httpd.conf habe ich auch schon den punkt "override all" angepasst.
Ich poste am besten einfach einmal den Inhalt meiner 2 dateien.

htaccess:

AuthType Basic
AuthName "Apache"
AuthUserFile C:/Programme/Apache Group/Apache2/auth/.htpasswd
require valid-user


.htpasswd:

test:123

Hoffe ihr könnt mir ein bisschen helfen

Danke schoneinmal

Manu
manu0815
 
Posts: 2
Joined: 02. August 2005 22:23

Postby Wiedmann » 02. August 2005 22:53

Weis echt nicht was ich falsch gemacht habe.

Hier wäre die Frage was nicht tut, oder was genau (nicht) passiert.
In der httpd.conf habe ich auch schon den punkt "override all" angepasst.

Hier wäre die Frage an welcher Stelle (und was du genau geschrieben hast)?

Aber hier fehlt was:
AuthUserFile "C:/Programme/Apache Group/Apache2/auth/.htpasswd"
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby manu0815 » 02. August 2005 23:58

Hi
Der Apache scheint mein .htaccess file komplett zu ignorieren, läuft wunderbar, aber zeigt alle verzeichnisse ungeschützt an.

Was ich geändert habe ist das "allowOverride All" an folgender stelle:

# AllowOverride controls what directives may be placed in .htaccess files.
# It can be "All", "None", or any combination of the keywords:
# Options FileInfo AuthConfig Limit
#
AllowOverride All

Manu
manu0815
 
Posts: 2
Joined: 02. August 2005 22:23


Return to Apache

Who is online

Users browsing this forum: No registered users and 2 guests