htaccess und der IE: Mal gehts, mal nicht...

Alles, was den Apache betrifft, kann hier besprochen werden.

htaccess und der IE: Mal gehts, mal nicht...

Postby nappio4 » 01. August 2005 17:38

Hallo,

für unseren kleinen Online-Shop können sich unsere Kunden über htaccess einloggen. Das läuft auch alles prima, aber ab und zu mal kriege ich Meldung, daß es nicht klappt. Bei mir zu Hause mit Linux/Firefox ist alles prima. Ich selbst habe kein IE. Deswegen meine Frage: Gibt es unter IE bestimmte Einstellungen, die einen Zugriff über htaccess unmöglich machen? Was muß aktiviert oder deaktiviert werden, damit man immer Zugriff hat?

Danke!
nappio4
 
Posts: 3
Joined: 01. August 2005 17:32

Postby deepsurfer » 01. August 2005 20:32

"Mal gehts, mal nicht" kommen diese Meldungen von einem Kunden oder kommen diese Meldungen immer von """""neuen""""" Kunden. ??

Sollte eine solche Meldung von einem Kunden kommen der schon öffters bei dir war, so müsste man jetzt deine htacces struktur prüfen ob da eigenarten vorhanden sind.
Desweiteren wäre es sinnvoll mal die LOGfiles zu sammeln und bei Bedarf zu prüfen, denn darin wird eigentlich der Fehler beschrieben.


Sollte die Fehlermeldung bei neu-Kunden auftauchen, so würde ich einfach raten das diese Personen unterschiedliche Einstellungen im IE haben, ich könnte mir sogar vorstellen das es sogar Kunden sind die über einen Firmen-Internet-Zugang kommen wollen, oftmals sind solche Zugangsbereiche durch Firmen-Administratoren besonders konfiguriert.
- Firmen Proxy der über mehrere IPbereiche arbeitet
- AOL Nutzer die den AOL-Proxy im Browser eingetragen haben (schitt teil der AOLproxy)
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby nappio4 » 02. August 2005 08:35

also diese Meldungen kommen von neuen Kunden. Wie gesagt, bei anderen neuen Kunden klappts problemlos. Du meinst also, daß es die AOL Proxies sein könnten, die das Problem darstellen? Meine htacces-Struktur ist nämlich völlig "normal".

Wo finde ich denn Logfiles, um das mal nachzuprüfen?

Es gibt soviele Webseits, die Logins haben, wie machen die denn das, sodaß es immer läuft? z.B. ebay oder gmx?
nappio4
 
Posts: 3
Joined: 01. August 2005 17:32

Postby deepsurfer » 02. August 2005 10:32

bei XAMPP (falls du es benutzt)
Windows: \xampp\apache\logs
Linux: /opt/lampp/logs

Wenn Du ein eigenen Server: da gibt es eigentlich eine standart vorgabe....ABER diese werden oftmals umgebogen.

Bei Windows Apache:
hier müsstest du mal in der InstallReadme schauen, wo bei der Installation des Windows-Apachen die LOGfiles abgelegt werden.
(ist auch in der httpd.conf angegeben)

Bei Linux systemen bestehen einige möglichkeiten:
/var/log/apache
/var/log/apache2
/var/log/http
/var/log/httpd
/var/log/www

Ansonsten wie schon erwähnt in der httpd.conf nachschauen wo die LOGs und wie sie heissen vom Server abgelegt werden.
Standartmässig wird access.log und error.log als Namensgebung benutzt.

Solltest du VHOST oder ALIAS name benutzen, so schau bitte in deren Konfigurationsektionen nach, es kann sein das dort die LOGfile Generierung definiert wurde.

Es gibt soviele Webseits, die Logins haben, wie machen die denn das, sodaß es immer läuft? z.B. ebay oder gmx?

Die benutzen keine htaccess Authentifizierung sonder ein Datenbank unterstütze Auth. (HTML/PHP Formulare)
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests