Session wird durch ungülitge URL zerstört, nur warum?

Alles, was den Apache betrifft, kann hier besprochen werden.

Session wird durch ungülitge URL zerstört, nur warum?

Postby Temruk » 01. August 2005 08:14

Hallo community,

Ich habe hier ein ganz seltsames Phänomen, dass ich mir nicht erklären kann und wo ich um Euren Rat bitte. Ich arbeite auf meinen Web-Servern (Apache 2.0.50) mit Sessions, die an sich einwandfrei tun. Nur beim Internet Explorer passiert etwas mir Unerklärliches:

Code (php):
// Hier rufe ich einige Werte aus den Sessions auf, z.b. die
// User_id und lasse mir die ausgeben. Das tut!

echo $_SESSION["user_id"];

// Die Quelle von diesem Bild ist falsch
<img src="URL die nicht stimmt" alt="">

Ab hier ist die Session kaputt! Wenn ich nun auf eine weitere Seite gehe, bei der ich nur die user_id wie oben wieder ausgebe bekomme ich nichts mehr, sprich die Session ist futsch. Stimmt die URL von dem Bild oben, läuft alles einwandfrei.

Hier zum testen:

http://tabea.sh-server.org/session.php

Kann sich das jemand erklären? Das Problem tritt NUR beim Internet Explorer auf und nur auf 4 von 6 Servern...

Vielen Dank!
Grüße
Stefan
Bereit für dein zweites Leben?
http.//www.second-home.org
Temruk
 
Posts: 8
Joined: 01. August 2005 08:10
Location: Karlsruhe

Postby Stefan » 01. August 2005 18:06

Servus,

eigentlich möchte ich Dir ja weiterhelfe, allerdings mußt Du schon genauer schildern was den das Problem ist.

was bedeutet
// Die Quelle von diesem Bild ist falsch
<img src="URL die nicht stimmt" alt="">
und was heißt die session ist kaputt?
http://tabea.sh-server.org/session.php

Kann sich das jemand erklären? Das Problem tritt NUR beim Internet Explorer auf und nur auf 4 von 6 Servern.


Also mit dem FF scheints auch nicht zu klappen....

vielleicht ein session_start() vergessen?

Lass doch mal ein bisschen Code sehen, mit dem Du die Sitzungsdatei füllst.

ciao, Stefan
User avatar
Stefan
 
Posts: 475
Joined: 26. December 2002 22:36
Location: Mitten in der sonnigen Südpfalz

Postby Temruk » 01. August 2005 20:26

Gern! Die Datei session.php:

Code: Select all
<?
  session_start();

  $_SESSION["user"] = "Dagobert";

  echo "<img src=\"urldieesnichtgibt\">"

  echo "<a href=\"session2.php\">Weiter zu Sesion2.php</a>";
?>


Und hier die session2.php:

Code: Select all
<?
session_start();
echo $_SESSION["user"];
?>


Genau so zu testen auf dem oben angebenenen Link. Es ist echt zum Mäusemelken :) Wie gesagt, nur der IE (in allen Versionen) ist betroffen. Server neu gestartet, /tmp gelöscht etc alles Fehlanzeige bisher.

Grüße
Temruk[/code]
Bereit für dein zweites Leben?
http.//www.second-home.org
Temruk
 
Posts: 8
Joined: 01. August 2005 08:10
Location: Karlsruhe

Postby Stefan » 01. August 2005 22:57

Grüß Dich,

also mit dem img Tag hat das sicher nichts zu tun. Ich glaube eher mit eventuell unterdrücken Fehlermeldungen oder sonstwas. Auf verschiedenen Servern, mit verschiedenen PHP Einstellungen verhält es sich dann anderst.

Allerdings, wenn das Script in Ordung wäre, dann würde es auf wahrscheinlich all Deinen Servern laufen. Und um das zu gewährleisten, genügt es erstmal in Zeile 6 ein ' ; ' anzufügen.

ciao, Stefan
User avatar
Stefan
 
Posts: 475
Joined: 26. December 2002 22:36
Location: Mitten in der sonnigen Südpfalz

Postby Temruk » 02. August 2005 07:01

Soweit haben wir auch gedacht und die ERROR_OPTIONS mal durchprobiert und auch das fehlende ";" ist nur ein c&p fehler, ist im Originalskript also da...
Bereit für dein zweites Leben?
http.//www.second-home.org
Temruk
 
Posts: 8
Joined: 01. August 2005 08:10
Location: Karlsruhe

Postby Stefan » 02. August 2005 12:43

Mahlzeit,

wo auch immer die Ursache zu finden ist, der ungültige URL um die Grafik zu refernzieren ist definitiv nicht schuld daran.

Angenommen Dein IE akzeptiert keine cookies, und bei 2 von den 6 Servern ist in der php.ini "session_trans_id" ausgeschaltet. Dann würde die SID nicht mit auf die zweite Seite wandern und die Ausgabe fände nicht statt. (...Irgendwie faul)
Schon mal mit anderen Browser ohne cookies versucht?

Du schreibts nur mit "falscher" URL würde es im IE nicht funktionieren...
Das könnte halt doch ein Indiz dafür sein, daß vielleicht der Prozess der die Bildquelle erzeugt einen Fehler macht und das script abbricht, bevor die Zeile mit der Ausgabe erreicht ist.(Quelltext im Störfall? "falsche URL", wie genau?)

Nur, mit anderen Browsern gibt es in allen Fällen ein positives Ergebnis.
Das bedeutet ja augenscheinlich, daß PHP und der Server ihre Sache vorbehaltlich gut machen.

Dann muß es ja fast zwingend an den Einstellungen Deines IE liegen.

Oder wie stehen die Tipps?

ciao, Stefan

Nachtrag:
Dann muß es ja fast zwingend an den Einstellungen Deines IE liegen.
Muß es wirklich? Mann, bin ich froh, so ein Problem noch nie gehabt zu haben. toitoitoi
User avatar
Stefan
 
Posts: 475
Joined: 26. December 2002 22:36
Location: Mitten in der sonnigen Südpfalz

Postby Temruk » 02. August 2005 12:55

Das Problem ist dass etwa 4000 verschiedene User am Tag die Seite ansurfen. Egal welche Version des IE diese Nutzer auch nehmen sobald auf der Seite eine ungültige URL befindet, ist Feierabend. Nicht so beim Firefox etc.

Ferner haben wir die gleichen Skripte (mit dem ; ;)) mal auf einem ganz anderen Webserver getestet, einwandfrei. Es muss also irgendeine Configeinstellung sein ich finde nur nicht heraus welche.

Hier mal die phpinfo-Seite, falls die weiter hilft:

http://tabea.sh-server.org/info.php
Bereit für dein zweites Leben?
http.//www.second-home.org
Temruk
 
Posts: 8
Joined: 01. August 2005 08:10
Location: Karlsruhe

Postby Stefan » 02. August 2005 13:22

Grüß Dich,

Dein Test "session.php" klappt bei mir(IE,FF,Opera) insofern, das weder mit cookies noch ohne, der User ausgegeben wird. Sieht aus, als würde garnichts ausgeliefert. Setze doch mal eine gültige URL im img Tag ein.


Code: Select all
session.use_cookies   On   On
session.use_only_cookies   Off   Off
session.use_trans_sid   Off   Off

Kannst ja mal mit den Werten von den anderen Servern vergleichen.

ciao, Stefan
User avatar
Stefan
 
Posts: 475
Joined: 26. December 2002 22:36
Location: Mitten in der sonnigen Südpfalz


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests