vhost/ssl problem

Alles, was den Apache betrifft, kann hier besprochen werden.

vhost/ssl problem

Postby AliceD » 11. July 2005 17:37

hi,

ich hab nen vhost mit ssl für einen admin bereich angelegt:

https://admin.domain.tld
Code: Select all
<VirtualHost ip.ip.ip.ip:443>
       ServerName admin.domain.tld
       ServerAlias admin.domain.tld

       SSLEngine on
       SSLCertificateFile /etc/apache2/ssl/apache.pem
       SSLCertificateKeyFile /etc/apache2/ssl/3e33a425.0

       SSLProtocol all
       SSLCipherSuite HIGH:MEDIUM

       ServerAdmin admin@domain.tld
       SuexecUserGroup webadmin webadmin

       DocumentRoot /var/www/admin-vhost-ssl/web

       <Directory /var/www/admin-vhost-ssl/web/>
               Options Indexes FollowSymLinks MultiViews
               AllowOverride None
               Order allow,deny
               allow from all
       </Directory>

       ScriptAlias /cgi-bin/ /var/www/php-fcgi-scripts/default-vhost/
       <Directory "/var/www/php-fcgi-scripts/default-vhost">
               AllowOverride None
               Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
               Order allow,deny
               Allow from all
       </Directory>


       ErrorLog /var/log/apache2/error.log

       # Possible values include: debug, info, notice, warn, error, crit,
       # alert, emerg.
       LogLevel warn

       CustomLog /var/log/apache2/access.log combined
       ServerSignature On
</VirtualHost>

klappt soweit auch, das problem ist, dass ich diesen adminbereich auch mit jeder anderen domain auf dem server erreiche die keinen vhost ssl eintrag hat.

d.h. ich erreiche auch den adminbereich mit z.B. https://mail.domain.tld was natürlich nicht so gewollt ist.

jemand ne idee woran das liegt?
AliceD
 
Posts: 1
Joined: 11. July 2005 17:34

Postby [xFlex]Claw » 14. July 2005 09:25

Hau mal folgendes vor deinem Block da oben:

Code: Select all

NameVirtualHost ip:80
<VirtualHost main/ip:80>

 DocumentRoot /opt/lampp/htdocs/defaultseite/ # <-- wenn etwas nicht gefunden werden kann!

</VirtualServer>

NameVirtualHost ip.ip.ip.ip:443

#<--- Dein Block --->

User avatar
[xFlex]Claw
 
Posts: 7
Joined: 05. July 2005 12:39


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests